Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Permissions - Cant copy, rename or delete

12 Jun 2018   #1

32 bit Ultimate
Windows 7 Permissions - Cant copy, rename or delete

I extracted a file from a zip

Tried to move it to a new directory but was told I needed Administrator Permission (I am an administrator)

I tried to rename it but was told I needed Administrators permission

I went into the properties and changed the owner to MyUserName\PCName - this is me!!.Permissions show I have full control - but the ticks are greyed out and cant be changed?) but it made no difference - I still could not copy/delete/rename the file

I turned off UAC but it made no difference - I still could not copy/delete/rename the file

I logged onto the administrators account but it make no difference - I still could not copy/delete/rename the file

I used Lockhunter to see if there was anything locking the file - no. So I told Lockhunter to delete at next reboot and, when I rebooted, I got a message saying it was not able to delete the file

Looking like I have to remove the HDD access it from another PC to delete the file!

Any suggestions as to what is going on here and how I can fix this?


My System SpecsSystem Spec
12 Jun 2018   #2

Windows 7 Ultimate 32-bit, Linux Mint 19.0 Xfce 64-bit

Judging by your thread name (can't copy, rename or delete) and its description (can't copy, rename or delete the file), it's not really clear if you have problem with move/copy/delete for just one file or for any other files.

If you can move/copy/delete other files on your computer, then the problem is in just that one file you extracted from the zip. You can try using Unlocker 1.9.2 to make the operations you want with that file. If something is locking the file, Unlocker will display the process by which the file is locked and will also display options.
My System SpecsSystem Spec
13 Jun 2018   #3

32 bit Ultimate

Thanks for the reply.

1. Its just the one file. Sorry should have made that clearer
2. As mentioned in original post, have tried LockHunter (same functions as Unlocker) which
- reports nothing locking the file
- is unable to delete the file but offers to delete at next boot

- is ten unable to delete the file at next boot.
My System SpecsSystem Spec

13 Jun 2018   #4

Windows 7 Ultimate 32-bit, Linux Mint 19.0 Xfce 64-bit

I'm out of suggestions then, but by curiosity - from where you got the zip and what is its name? In my experience, it's not possible to be able to extract a file from a zip and then not being able to delete it, saying it's permission error.
My System SpecsSystem Spec
13 Jun 2018   #5

32 bit Ultimate

In my experience also - hence the posts!

zip came from the www. Other files in the zip extract OK and can be renamed / deleted.
I have since acquired another version of the zip from another site and from there the problem file extracts just fine and can be renamed/deleted.

So there is definitely something odd about the particular version of the file in the zip I have and I would have been interested to know what.

But if its too hard . . .. it does not really matter.

Thanks for you interest.
My System SpecsSystem Spec

 Windows 7 Permissions - Cant copy, rename or delete

Thread Tools

Similar help and support threads
Thread Forum
Clear Undo Delete/Move/Rename/Copy actions from context menu
Hello, I would like to know if there is any way to clear past actions of Delete/Move/Rename/Copy from the context menu in desktop without REBOOTING. I already tried Clear Clipboard Shortcut - Create in Windows option and Hot Copy Paste - Enhances Windows...
General Discussion
File Permissions Problem - Unable to Overwrite, Delete, Rename
I've encountered an issue where I am unable to delete, rename, or overwrite existing files on my computer, at least with certain extensions (.dll, .exe). This happens, for example, when I try to install an upgrade of a program -- the installer cannot finish the upgrade because it cannot replace the...
General Discussion
BSOD & cannot copy, paste, delete or rename files and folders
(you know what? BSOD just happened right before i click the submit button. -_-* luckily Chrome's restored back this page and i don't have to type everything again..) BSOD started like a week ago. I've been trying to find ways of why it happened or what to do stuff, found one, tried it but to no...
BSOD Help and Support
How to copy and rename Language in Windows 7?
English is spoken all over the world. Windows have option of EN (US), EN (UK), EN (IN) etc, I want to copy EN (UK) and rename it with my own country's format (currency, date & time styles etc) as EN (PK)* Can anyone help me how can I do this? *Pakistan
Installation & Setup
Windows Explorer doesn't refresh after copy, rename, new, or delete
I'm not sure if this is a simply problem or some kind of other problem. Usually, when you create/rename/delete a file/folder in the directory in Windows Explorer, it will add/renamed/remove automatically without refreshing. However, I have this issue where if you do any of the above, it...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:01.
Twitter Facebook Google+