Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Open file with Notepad: Access denied. Despite being the owner!

07 Dec 2018   #1

64 bit Win 7 Ultimate
Open file with Notepad: Access denied. Despite being the owner!

HP ENVY DV6. Windows 7 Ultimate all latest updates

So I have this file extracted from a zip.
But I cannot open it. I can't even copy it to another folder.
The only way of moving it is to delete (yes I can do that!) and then unzip to another folder
I can open other files in this folder but not this one
Lockhunter says there is nothing locking this file

The user I am logged on as is the owner
The owner has all permissions
So I run notepad as administrator and try to open the file and get
You dont have permission to open this file
Contact the owner (me) or an adminstrator (I am one) to obtain permisson

Everyone also has full permission for this file
If I make Everyone the owner it makes no difference

So how can I get access to this file?

My System SpecsSystem Spec
07 Dec 2018   #2
Paul Black

7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3

Hi Rincewindwiz,

Have a look at this => General Tips - Take Ownership Of A File.

I hope this helps!
My System SpecsSystem Spec
07 Dec 2018   #3

64 bit Win 7 Ultimate

As mentioned in the post, user already has ownership of the file.

And has tried several locations
- desktop
- random data directory
- user\documents all have the same result
My System SpecsSystem Spec

07 Dec 2018   #4

Windows 7 Ultimate x64

Check if there isn't a "deny" entry in the permissions tab. A deny entry takes precedence over "allow" ones. When in doubt about permissions, also check the "effective permissions" tab about the user in question.
The owner of files is pretty much irrelevant for most purposes. The owner can change all permissions, and that's it, it doesn't confer or remove access rights on its own.
My System SpecsSystem Spec
07 Dec 2018   #5

64 bit Win 7 Ultimate

Thanks for the thoughts

The situation is the same for all Groups and Usernames (Everyone, SYSTEM, the user, Administrators)namely:-
  • All 'Allow' permissions are ticked
  • There are no 'Deny' permission ticks.
  • All effective permissions are ticked
  • All Special permissions are blank
My System SpecsSystem Spec

 Open file with Notepad: Access denied. Despite being the owner!

Thread Tools

Similar help and support threads
Thread Forum
!!UAC!! "File Access Denied" Even with admin, as owner, and permission
First off, I wasn't sure where the best place to post this would be, since UAC is supposed to be a security feature of windows 7 I figured the security section would be best. My apologies if I posted this in the wrong section. OK to the problem... Trying to simply copy/paste a game dll file...
System Security
Cannot open file Access is denied message
Hi all. I have a strange issue (or so it seems to me that i am a newbie) . I try to use a small utility which reads massively *.txt files and if they are saved as ANSI it saves them as Unicode. The problem is that when i run it (run as administrator) i get an error message saying "Cannot open...
General Discussion
Outlook 2010 Access denied. Cannot open pst file.
Hello everyone, I wonder if anybody has the same issue as me. My Office 2010 beta just expired, so I had to uninstall MS Office 2010 and reinstall the official release. After the uninstall, I saved my pst file to a different location and cleaned the AppData directory of Outlook which...
Microsoft Office
Trying to copy txt file in Notepad. "Notepad: Access is denied"
:mad::confused::cry: If I had known how much hassle Win 7 was I would have stuck with XP! Well I suppose its a learning curve.... Latest major hassle, I have a text file on my E:\drive, this is a copy of my XP C:\ drive before I installed Win 7 on it. I have now been able to get to it...
General Discussion
Put file on desktop -> open file -> access denied?
Hello there. Whenever i take a file and put it onto the my desktop, all the permissions to the file is completely stripped. Leaving none able to open the file. I am able to go into access control and add myself again, but it makes no sense at all.. Why does windows do this and do anyone know...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:56.
Twitter Facebook