Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Malware/Virus infection - Control Panel items missing, etc

07 Jul 2019   #1
rcanino

Win7 Pro 64-bit sp1
 
 
Malware/Virus infection - Control Panel items missing, etc

I just reinstalled Windows yesterday - I can't believe i got infected so quickly b/c I hardly used the computer. I foolishly waited to install Avast, which I'd been using for years w/out any problems. I thought, I expected Windows Defender and Firewall to keep me safe. Guess not.

I was able to use gpedit.msc to restore Task Manager but a bunch of stuff is missing from the Control Panel. I tried running Malwarebytes in Safe Mode but it just hangs at the rootkit scan. Also Avast won't load at all, keeps giving me a "Well this is embarrassing..." message.
Can anyone suggest a way back to normal w/out resinstalling Windows? If I have to I will but I think, I hope this is a fairly easy fix.
Any thoughts you care to share will be much appreciated - thanks!


ps - I was able to run a boot-time scan with Avast from the Cmd prompt, which is running now. I did one earlier this morning, right when I noticed the symptoms of infection - before Avast kept giving me the "Well this is embarrassing..." message, but it didn't find anything at that time. It did find 2 viruses during a regular scan which it moved to the Virus Chest.


Thanks for reading... I know you guys aren't devoted to malware per se but the old sites that used to analyze HijackThis logs seem to be gone...?


My System SpecsSystem Spec
.
07 Jul 2019   #2
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi rcanino,

Quote   Quote: Originally Posted by rcanino View Post
I just reinstalled Windows yesterday - I can't believe i got infected so quickly b/c I hardly used the computer.
What did you use to re-install Win 7?

Was it an installation DVD/USB or an ISO that you downloaded and burnt to a DVD/USB. If it was, where did you get it from?
My System SpecsSystem Spec
07 Jul 2019   #3
rcanino

Win7 Pro 64-bit sp1
 
 

Thanks for your reply Paul -



It's an OEM disc I bought years ago from newegg. I used it for the first time about a year ago (on the same computer) then, after my boot drive went belly-up last week I used it again yesterday.


btw I did let Windows Update install everything with the exception of the 2019 monthly roll-ups. That's how the system was running before so I figured I'd duplicate it. There's no "cracked" software or anything that's not legit on it; it's just the OS and a few apps I like to use.


edit: the boot-scan from Avast just finished and found nothing.
the good news is the system booted to Windows and all my control icons/items are back, and Avast seems to be behaving correctly.


In the Virus Chest I have 2 entries:


IDP.ALEXA.51 - the infected file is HjUyu.exe in AppData/Roaming


Win32:Malware-gen - the infected file is dslhost.ext in Program Files(x86)\DSL Host


I haven't plugged my internet connection back in yet...still worried this system is infected.


I ran AviraDNSRepair and it said my DNS had not been changed, for whatever that's worth.


Thanks Paul!
My System SpecsSystem Spec
.

07 Jul 2019   #4
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi rcanino,

Quote   Quote: Originally Posted by rcanino View Post
It's an OEM disc I bought years ago from newegg. I used it for the first time about a year ago (on the same computer) then, after my boot drive went belly-up last week I used it again yesterday.

btw I did let Windows Update install everything with the exception of the 2019 monthly roll-ups. That's how the system was running before so I figured I'd duplicate it. There's no "cracked" software or anything that's not legit on it; it's just the OS and a few apps I like to use.

edit: the boot-scan from Avast just finished and found nothing.
the good news is the system booted to Windows and all my control icons/items are back, and Avast seems to be behaving correctly.
NOTE: The light blue text below are links to the relevant websites and programs, just click them!

SUGGESTION: Since you are happy with the way the OS is running at the moment, create a system image. This way, if things go wrong in the future, you will be able to restore your OS back to the exact same state that it is NOW in a very short time. There are two imaging programs which are very popular among members here, the first is AOMEI Backupper Standard [FREE], and the second is Macrium Reflect [FREE].

I hope this helps!
My System SpecsSystem Spec
07 Jul 2019   #5
rcanino

Win7 Pro 64-bit sp1
 
 

Thanks Paul - I will probably use Macrium and clone my boot drive to a spare SSD I have.


One question- is there any way to determine for sure if the system is clean? I mean besides the obvious "just keep using it and watch for symptoms."


Do you have any favorite - hopefully free - A/V and Malware scanners? I don't mind spending the day running scans. Avast seems happy but I had nothing but trouble with MalwareBytes...Maybe I should download it and try it again.


Last question (i hope!) - is there any reason not to install all the Windows Updates? This is a Win7 Pro system and I do not want to deal with nag screens about updating to Win10. I think that's why I stopped running updates toward the end of last year but I don't remember for sure. Anyway when I stopped updating I had no problems...but my online behavior is very conservative these days. (that's why I'm so surprised I got whacked this morning - whatever it was)
My System SpecsSystem Spec
07 Jul 2019   #6
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi rcanino,

Quote   Quote: Originally Posted by rcanino View Post
One question- is there any way to determine for sure if the system is clean? I mean besides the obvious "just keep using it and watch for symptoms."

Do you have any favorite - hopefully free - A/V and Malware scanners? I don't mind spending the day running scans. Avast seems happy but I had nothing but trouble with MalwareBytes...Maybe I should download it and try it again.
Many members here have their own particular favourites as they will probably post. I personally have always used AVG [FREE] and MalwareBytes [FREE] and I have never had any problems!

I hope this helps!
My System SpecsSystem Spec
07 Jul 2019   #7
rcanino

Win7 Pro 64-bit sp1
 
 

Thanks Paul - for all your help...hopefully I'm good to go...sure wish I knew what the heck zapped me though...
My System SpecsSystem Spec
.
07 Jul 2019   #8
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi rcanino,

Quote   Quote: Originally Posted by rcanino View Post
Thanks Paul - for all your help...hopefully I'm good to go...sure wish I knew what the heck zapped me though...
You're welcome!
I will try and have a look into the two in the virus chest later or tomorrow!
My System SpecsSystem Spec
07 Jul 2019   #9
rcanino

Win7 Pro 64-bit sp1
 
 

i googled them and they both come up as possibly false positives. I guess I won't worry about them. Thanks again!


One nagging problem -Malwarebytes refuses to complete a scan - it hangs the whole computer. I checked "Rootkit Scan" in the Settings then clicked Threat Scan - it got to the Rootkit section and stalled. It strange b/c I've used the free version of MWB for years and never had an issue.
My System SpecsSystem Spec
07 Jul 2019   #10
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3
 
 

Hi rcanino,

Quote   Quote: Originally Posted by rcanino View Post
One nagging problem - Malwarebytes refuses to complete a scan - it hangs the whole computer. I checked "Rootkit Scan" in the Settings then clicked Threat Scan - it got to the Rootkit section and stalled.
Very strange! Have you tried downloading Malwarebytes again or tried the scan after a reboot?
My System SpecsSystem Spec
Reply

 Malware/Virus infection - Control Panel items missing, etc




Thread Tools




Similar help and support threads
Thread Forum
Control Panel items not showing
The 'Pen & Touch' and 'Tablet PC' services icons are not showing in the control panel. The tablet items Are checked in Windows features but still not visible. I have tried regediting the 'don't load' portion of the control panel but can't seem to get them to 'stick.' I've tried taking ownership of...
General Discussion
Command Line Open Control Panel\All Control Panel Items
How to open "All Control Panel Items" from the command line? thanks...
General Discussion
all control panel items icon missing
I just installed Win7 ultimate, and it works great. I went into the control panel to change the power settings, and I realized that the control panel is missing the icon for "all control panel items". I unlocked the built in administrator account and tried it that way, but the item is still...
General Discussion
control panel and recently used items
I remember in the RC build of windows 7 when I opened up the control panel on the left it showed a menu which at the bottom had applets that were recently used so could be quickly accessed. On the RTM of windows 7 this menu on the left is gone, vanished, caput. Is now just an empty area. Is...
General Discussion
Green text in all control panel items
Are my eyes just playing tricks on me or is the text in Control panel / All Control Panel Items Green?
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:31.
Twitter Facebook