Can't take ownership after harddrive change

  1. Posts : 2
    Windows 7 Professional x64

    Can't take ownership after harddrive change

    My harddrive was producing an accelerating number of corrupted files, so I moved to a new one before it died. This was a while ago, so I can't remember precisely what method I used, but I think I used a freeware drive-cloner. Some folders were encrypted with Win7's integrated encryption method and I have a whole bunch of exported keys (most of which are probably duplicates),all of which I've run through the import dialogue for.

    After "taking ownership" of all files transferred to the new drive, which I did possibly(?) before importing encryption keys and at a high level (the whole-drive? at least, no lower-level than each folder in the drive's root), I can't manage to actually open many of the encrypted files. I've tried this from a non-admin account, using elevated privileges and from an admin account. If I look at the certificate thumbprint of one files as an example, through right-click/properties/advanced/details, then it shows the same thumbprint as one of the pfx files I have backed up on an external USB stick. A few times over, I've imported this pfx file (including to the central trusted repository), or at least seemed to, but if I open the "Manage your file encryption certificates" app, then "select certificate", then none of the certificates listed have the thumbnail of the one I thought I just imported. The files still give a "there was an error accessing this file" error. If I go back to the example file's advanced attributes and try to add certificates, then I get the error "To add users to this file, you must have access to the file and Write or Modify permission for it".
    I don't know if this has any effect, but I have the same computer name and username as before switching drives, except that capitalisation of some characters has changed. I also have files which I've encrypted since the move, using a certificate generated after the move, which I can access fine.
      My Computer

  2. Posts : 6,750
    Windows 7 Ultimate x64/ Windows 10 Enterprise LTSC

    Just to make sure you're doing this right, read through this.

    You can take ownership with a registry key or this program.

    If all still doesn't work then you either have a bad Cert., the decryption process wasn't done correctly, or the data you're trying to decrypt is just bad data since you indicated you cloned a bad drive. The data is just bad. This is why A) full air gaped cloning and B) periodic data backups are essential. I clone to two hard drives and I test those clones. It can be a PITA, but a bigger PITA x10,000 is having to deal with data loss. Unrecoverable data loss where that data simply can't be replaced. Well, there are hard drive specialists that might be able to help for a pretty penny.
      My Computer

  3. Posts : 2
    Windows 7 Professional x64
    Thread Starter

    Thanks, I appreciate the help. I'm hopeful that there will be a fix for most of the data (unless I have a bad key etc), because this problem seems to effect huge numbers of files which I'm sure would have been distributed widely across the old disk.

    Does a thumbnail (or any other feature of a pfx) provide an MD5-like check?
      My Computer

  4. Posts : 6,750
    Windows 7 Ultimate x64/ Windows 10 Enterprise LTSC

    If you computed a MD5 hash of the pfx Cert. prior to the hard drive going south you'd have a good known hash to compare to with the pfx Cert. you have now.

    If you open the pfx file with Notepad++ or Notepad, I'm thinking you could view a SHA1 or SHA256 fingerprint. I'm not sure as I never used EFS before.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:46.
Find Us