Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: File and Folder Read only attribute wont disable

16 Apr 2010   #11


i was just going to say you need to run as admin everytime you want to run it.

My System SpecsSystem Spec
16 Apr 2010   #12
squall leonhart

Windows 7

yeah, but we're addressing 2 different people with similar but different problems.

the ops issue is the vista/7 program files permission restrictions while the second is a folder that lacks permissions for this user account i think.
My System SpecsSystem Spec
16 Apr 2010   #13


yes that sounds correct account restrictions due to limited account or parental controls. or both
My System SpecsSystem Spec

23 Apr 2010   #14

windows 7

Thanks squall, but the work-around of moving everything to a new folder is impractical. i have a new computer with win7 and have copied all my files from my old computer. I now have thousands of folders that are seemingly-irreversibly read-only. This is very not cool.

Is there no way to transfer folders from other computers and not end up with read-only?

My System SpecsSystem Spec
24 Apr 2010   #15

Windows 7 Home Premium x64

Everyone needs to take a step back on this. These are not file permissions that are Read Only. These are ATTRIBUTES that are Read Only. There is a big difference between the two.
My System SpecsSystem Spec
12 Jan 2011   #16

64 bit Windows 7 Ultimate

I'm getting an error in my Drupal 6 website. filename.tmp in folder /tmp cannot be copied. I'm running Windows 7 64bit. I am unable to remove the Read-Only attribute on the /tmp folder. I am logged in as admin and according to the Properties tab for /tmp, I have all the permissions. I uncheck the square for Read Only and it does not change it. I did this command, attrib -r -s c:\path\tmp but it didn't work. Any suggestions?
My System SpecsSystem Spec
10 Sep 2011   #17

Windows 7 ultimate x86 (32bit)

Quote   Quote: Originally Posted by jav View Post
1. First question, why are you trying to do it?

2. look here:
Unable to remove Read-Only attribute from folder
You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7

To view or to remove the Read-only or the System attributes of folders in Windows Vista or Windows 7
Click Start, click Run, type cmd, and then press ENTER..
To view the syntax for the Attrib command, type attrib /? at the command prompt.
To remove the Read-only attribute and to set the System attribute, use the following command:
attrib -r +s drive:\<path>\<foldername>
For example, to remove the Read-only attribute and to set the System attribute for the C:\Test folder, use the following command:
attrib -r +s c:\test
Be aware that some programs may not operate correctly with folders for which the System attribute and the Read-only attribute are set. Therefore, use the following command to remove these attributes:
attrib -r -s drive:\<path>\<foldername>
For example, to remove both the Read-only and the System attributes from the C:\Test folder, use the following command:
attrib -r -s c:\test
If the Run command is not listed on the Start menu, do the following:
Click Start, click All Programs, click Accessories, and then click Run..
note: Open cmd with run as administrator

yes, it works... but i want to hide file (not folder) as system file how can do this? : )
My System SpecsSystem Spec
04 Mar 2012   #18

Win 7 Home
So what's the issue here?


I am logged in with an account that is in the administrator group, I have a folder that is not a system folder, and my account has full permissions on it.
Yesterday the app that uses this folder (and which created it) could write to it quite happily, but today it fails when trying to update the contents.
The 'attributes' for the folder show a solid square in the read-only box. If I 'un-box' the read-only and apply, when I look at the attributes again the box is still here.

So my question is, if it's not (which it shouldn't be) some sort of protected Windows folder, and I have full permissions on the folder (supposedly), why does Windows not respect my wishes, get out of the way, and let me set it to what I want it to be?

Many thanks.
My System SpecsSystem Spec
21 Jun 2014   #19

Windows 7 Professional 32 bit

I have the same problem. I need to upload license file to a folder, but I am unable to. I tried that from administrator account (so I have full control NTFS permissions), there is no desktop.ini file anywhere (yes, I did view hidden and system files), but still the read-only persists. I am not even able to remove inheritance for NTFS permissions or to modify them in any way. Not even from builtin administrator account. Obviously, running as administrator won't help, since I want to copy a file in a folder, not to run an application. Command line command does not work, it always says "file not found". Anyone has some PowerShell script or something to solve this?
My System SpecsSystem Spec

 File and Folder Read only attribute wont disable

Thread Tools

Similar help and support threads
Thread Forum
Read-only File and Folder Attribute
How to Set and Unset Read-only Attribute of a File or Folder in Windows This tutorial will show you how to set or unset files or all files in folders to be read-only or not in Vista, Windows 7 and Windows 8. In Windows, folders cannot be set as read-only. Only the files in the folders...
Read-only Attribute for a Windows folder
Iím running a Visual Studio app that fails because the folder Temporary ASP.NET Files is Read-only. In Windows Explorer, there is a checkmark next to Read-only in the folder properties. However, it does not remain unchecked if I uncheck it, even though Iím an Administrator. If I display...
General Discussion
Remove read only attribute of folder.
I have an executable file, which is a windows service. Now I cannot start it from service control management panel. I am the administrator. I guess the readonly attribute effects it. I found that the folder is readonly. I unclick it and apply it and click OK button. However next time when I look...
General Discussion
Can't remove 'read-only' attribute from a folder
Things I have tried: 1) Enabled hidden administrator logon and logged onto it. 2) Edited user permission for entire drive and set to 'full control' 3) verified the folder is not locked/in-use even deleted it and then restored Still has the stupid 'read only' box checked when you hit...
General Discussion
How do I unset the Program folder read-only attribute?
Hello everybody, I have a problem with the C:\Programs Files and C:\Program Files (x86) folders under W7 RC 64bit: these folder have the read-only attribute set on and I can't unset it. Whenever I tried to unset this attribuite even if W7 seems to comply the folders actually remain in the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App