Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Permissions go funny on External HDD

19 Apr 2010   #1

Windows 7 Ultimate x64 RTM + SP1
Permissions go funny on External HDD

Hey peeps,

Got a funny issue with my External HDD.

Each time i plug my Ext HDD in to my PC whilst I'm using it (As in, I'm in windows) my permssions seem to reset themselves, evn though they are not.

I can copy from and read, but i cannot write or create on the drive. In my permssions, i have myself setup with control, I have even set, under advanced, it so I am the owner of the device.

It's fine after i reboot, or if i plug in the drive before switching on the PC.

Bear in mind i have gone through numerous installs over the past 6 months (For other reasons), and I wonder if it may be from that.

Is it getting to the point where i am going to need to re-download everything on my ext HDD so they have no permssions set at all or is there a way of removing the permssions from each program, dosument, media.

Thanks in advance

My System SpecsSystem Spec
19 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X

If you move a file from your hard drive to your PC does it switch the permissions back?

If so, just back up all of the info, reformat the drive and you should be ok. Granted there will likely be a real solution, but this should fix the problems.

This also might work:

Enable the real Administrator account:
Start > Search "cmd" > Right Click & Run as Administrator
Run Command: net user administrator /active:yes
Logon w/ Credentials Administrator/nopassword
Take ownership of the drive and reset the permissions through the advanced menu.
My System SpecsSystem Spec
19 Apr 2010   #3

Windows 7 Enterprise

Any particular reason it's formatted in ntfs?
Had this same problem a couple months or so ago with mine, something about putting files on it at home but cant when at work.
I ended up formatting it with exFat, which is apparently the same as Fat but with large file/volume support.
My System SpecsSystem Spec

20 Apr 2010   #4

Windows 7 Ultimate x64 RTM + SP1

Right, maybe i got a little confused, the issue is when i plug in the drive, whilst logged in to windows in my area, I can open the drive and copy but when i want to create or write to the drive i get a 'Write Protection is enabled' error message.

So not sure if this is now a permissions issue as such.

I am the owner of the drive as i sorted that after i restarted the PC the first time.

This happens all the time.

Oh, and i have it formatted as NTFS for that reason, big files and apps. a couple weigh in a 5gb a peice. but i could try ExFAT. If it was to help this issue.

Thanks for the input
My System SpecsSystem Spec
20 May 2010   #5

Windows 7 Ultimate x64 RTM + SP1


I can now confirm this has been sorted. I formatted to ExFAT and now i have no permissions issues thanks to there being none.

Downside is i can't create a system image to create and store on that drive although i do have a full backup and restore created on there so thats not too bad.

My System SpecsSystem Spec

 Permissions go funny on External HDD

Thread Tools

Similar help and support threads
Thread Forum
Permissions issues with external harddrive
So i have a laptop and an external hard drive. my previous laptop had hardware failure, so i got this one with a clean install, and majority of my files on it. i'm missing some images that i had backed up on my external harddrive, but when i tried to access it today i got this. "Windows Photo...
Music, Pictures & Video
Can't access my external HD after changing Permissions
I changed the Permissions for my External Hard Drive (I am the Admin in this computer), I actually wanted to passport-protect it, and now Windows doesn’t let me change it back (my HD will not work in other computers either). Please help! First I tried system restore, that was useless, but...
General Discussion
Strange permissions on external drive
I have a WD myBook that I have been using to store files on. It is connected via a USB to my wireless router. In explorer I can see it in my network section as well as map a drive to it. However, intermittently, it does not allow me to write or delete files on it. I know computers aren't suppose...
Hardware & Devices
External Hardrive and Permissions
I am having a few issues with my external hard drive and being able to access the files on there. A wee while ago somehow I accidentally removed all the permissions from the external and I was unable to access any of the files. For the life of me I have no idea how to re-enable those permissions....
General Discussion
Messed up with Permissions on my external drive. Help!!
Hello, I was trying out the admin permissions for my external drive and I messed up. It took all of my privileges away and I wasn't able to access it at all. I was able to get some of it back, but I am still having problems getting full control of the drive. I am seeing a pad lock on the first...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App