Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Patched UXTheme, can't use unsigned themes

31 Oct 2012   #1
X04D

Windows 7 Ultimate x64
 
 
Patched UXTheme, can't use unsigned themes

I've done this countless times in the past with 32 and 64bit versions of Windows 7, but this is the first time I've had an issue.

Using Windows 7 Ultimate x64
Tried using Universal Theme Patcher. It listed all three DLL's as patched. Rebooted, tried installing various themes, none work at all. No errors, just no change.

Restored DLL's to original.

Tried using VistaGlazz. Patched all the DLL files. Rebooted, tried various themes, none work at all. Same as above, no errors.

Restored DLL's to original.

Tried UXStyleCore. Same problem.

Any ideas?

EDIT: Also, UAC is disabled, no firewall/antivirus. I've run these commands:
Quote:
C:\Users\n0c>sc config uxpatch group= "File System"
[SC] ChangeServiceConfig SUCCESS

C:\Users\n0c>sc config UnsignedThemes group= UIGroup
[SC] ChangeServiceConfig SUCCESS



My System SpecsSystem Spec
.
31 Oct 2012   #2
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro
 
 

Welcome to the Seven Forums

I see at the bottom of your screenshot that Windows 7 is build 7600 you may need to install all updates to get Service Pack 1 installed to make it build 7601, or find Universal Theme Patcher for build 7600 and try it.

Jerry
My System SpecsSystem Spec
31 Oct 2012   #3
X04D

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Bongo View Post
Welcome to the Seven Forums

I see at the bottom of your screenshot that Windows 7 is build 7600 you may need to install all updates to get Service Pack 1 installed to make it build 7601, or find Universal Theme Patcher for build 7600 and try it.

Jerry
Oddly enough, I've been trying to update Windows for the last couple days and a service pack never showed up. Now I just checked again and...there it is. I assume that'll fix the issue I'm having, so I'll give you my thanks in advance!
My System SpecsSystem Spec
.

31 Oct 2012   #4
X04D

Windows 7 Ultimate x64
 
 

Have SP1 now. Still have the same issue. Not sure what the problem is.
My System SpecsSystem Spec
01 Nov 2012   #5
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro
 
 

Does your system meets the minimum requirements to run aero?
Quote:
Aero Requirements to be Enabled in Windows 7

NOTE: If Aero is not enabled, then Aero Shake will not work even when enabled or turned on.
  • Aero is not included in Windows 7 Starter or Home Basic, so you must have Windows 7 Home Premium, Professional, Ultimate, or Enterprise installed.
  • 1 GHz 32-bit or 64-bit processor
  • 1 GB of system memory
  • A graphics card with support for DirectX 9 graphics with at least 128 MB of memory.
  • The graphics card must support Pixel Shader 2.0 and the Windows Display Driver Model (WDDM).
  • The Desktop Window Manager Session Manager and Themes Services need to be set as Started and Automatic.
  • You must be have True Color (32 bit) set instead of High Color (16 bit).
  • Desktop composition needs to be enabled (checked) in Visual Effects.
  • Refresh or update your WEI score.
Jerry
My System SpecsSystem Spec
03 Nov 2012   #6
X04D

Windows 7 Ultimate x64
 
 

Windows7 Ultimate
Intel i5
8GB RAM
nVidia GeForce 560ti

My WEI score is 7.8 for most components, but 7.0 because of my SSD.

As mentioned, I've had themes on this system in the past, with a different install.
My System SpecsSystem Spec
03 Nov 2012   #7
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro
 
 

Try Option 2 of this tutorial SFC /SCANNOW Command - System File Checker it will not harm any data or programs you have installed it will try to find and repair any corrupt system files that you have. Be sure to reboot after the scan.

You will need to patch again as this will fix those .dlls then try again.

Jerry
My System SpecsSystem Spec
03 Nov 2012   #8
X04D

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Bongo View Post
Try Option 2 of this tutorial SFC /SCANNOW Command - System File Checker it will not harm any data or programs you have installed it will try to find and repair any corrupt system files that you have. Be sure to reboot after the scan.

You will need to patch again as this will fix those .dlls then try again.

Jerry
Thanks for the reply. I ran that command, rebooted, patched, rebooted, still no third party themes.

Anything else I can try?
My System SpecsSystem Spec
03 Nov 2012   #9
X04D

Windows 7 Ultimate x64
 
 

My System SpecsSystem Spec
03 Nov 2012   #10
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro
 
 

Do the themes show up in Personalization?

Take a screenshot of C:\Windows\Resources\Themes and post it.

Jerry
Patched UXTheme, can't use unsigned themes-themes.png


My System SpecsSystem Spec
Reply

 Patched UXTheme, can't use unsigned themes




Thread Tools




Similar help and support threads
Thread Forum
Explorer.exe crash when uxtheme patched.
Hello, I am getting often explorer.exe crashes when I have patched the windows 7 files using uxthemepatcher. Any idea why is this happening? Here's more info: Faulting application name: explorer.exe, version: 6.1.7601.17514, time stamp: 0x4ce7a144 Faulting module name: ntdll.dll, version:...
BSOD Help and Support
UXtheme isn't working - all themes revert to Aero
1. I installed UxStyle Core Beta 2. I restarted. 3. I placed two themes in C:\Windows\Resources\Themes 4. I tried starting them from the personalization tab as well as by double-clicking the .theme files. 5. This causes the standard Aero theme to load. Any idea what the problem could be? ...
Themes and Styles
System patched but themes aren't working!
Hey! I just installed Windows 7 ultimate 64bit and then I patched it so that I could use 3rd party themes. But for some reason I can install them but they don't show any change on my computer. The style just stays the same as the original aero theme that came with it. I've tried scan now on cmd...
Themes and Styles
uxtheme patched, how to restore??
I patched my uxtheme.dll (and the other .dlls you need to patch to install and use third party themes), however, when I try and logon (using patched dlls) it never makes it to the login window, refreshing to black and flashing blue, then refreshing to black over and over, until I reboot into safe...
Themes and Styles
No themes available after uxtheme patch
So what i did was patch the 3 files themeservice, themeui.dll and uxtheme.dll with the tool Power Tool Ultimate v.2.3 - Cracks & Serials - ..:: Moviez.to Board ::.. as it is told to do here: SevenMaxClearLiveBlack for 7RC by ~molinarosp on deviantART When i wanted to change the theme after...
Themes and Styles
patched uxtheme.dll for 7137
Sorry if someone has already asked this, but is there a patched uxtheme.dll for win 7 build 7137 x86? I'd love to try out the new build, but don't know if I could do with custom visual styles just yet. (I'm working on porting a vista VS to win 7 at the moment actually)
Customization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App