Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Screensaver not starting automatically.

18 Oct 2018   #1
townsbg

Windows 7 pro 64-bit sp 1
 
 
Screensaver not starting automatically.

Sometimes, and I'm not sure why, but my screensaver doesn't start automatically. This has happened with both the photos screensaver built into windows and one that I've installed. The only resolution is to log out of my profile. Today this happened just after booting up my computer. Any ideas? I have screensaver set to start after 5 minutes.


My System SpecsSystem Spec
.
19 Oct 2018   #2
wither 2

Windows 7 Pro SP1 64 bit
 
 

Hi Townsbg-

Have you tried doing a clean boot to see if there's some program running in the background which prevents the screensaver from starting?
My System SpecsSystem Spec
20 Oct 2018   #3
townsbg

Windows 7 pro 64-bit sp 1
 
 

No but I have very little running. I keep services trimmed down. VMWare doesn't start automatically so I know that it isn't that.

Screensaver not starting automatically.-services.png


My System SpecsSystem Spec
.

20 Oct 2018   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Is something starting up in the background while the computer is left idle? Or is there a process that is not closing down properly?
  1. From an admin command prompt, type powercfg/requests
  2. wait the time screensaver is supposed to kick-in (5 min)
  3. if screensaver does not start, then press <return>
should do the trick, and tell you what is preventing screensaver from starting.
My System SpecsSystem Spec
20 Oct 2018   #5
wither 2

Windows 7 Pro SP1 64 bit
 
 

Townsbg- Did you try it?

I like the response from iko22.
My System SpecsSystem Spec
20 Oct 2018   #6
townsbg

Windows 7 pro 64-bit sp 1
 
 

I'll have to wait until it happens again.
My System SpecsSystem Spec
21 Oct 2018   #7
townsbg

Windows 7 pro 64-bit sp 1
 
 

This afternoon I had the issue happen again. I ran your command and it didn't return anything. I changed the timeout to a minute to confirm that it wasn't working and then the screensaver started. It continued to work on 5 minutes throughout the rest of the day. So changing the timeout seemed to correct the issue.

FYI I've run the command every so often throughout the day and each time I had the following immediately after running a VMWare virtual machine. Do you know if there is a connection?

Quote:
SYSTEM:
[DRIVER] \FileSystem\srvnet
An active remote client has recently sent requests to this machine.
My System SpecsSystem Spec
22 Oct 2018   #8
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Had you run VMWare since changing the screensaver timeout to a minute? Did the screensaver work on that occasion? What did powercfg report on that occasion?
My System SpecsSystem Spec
22 Oct 2018   #9
townsbg

Windows 7 pro 64-bit sp 1
 
 

I didn't run VMWare. I changed the timeout to a minute and let it wait immediately. When it worked I changed it back to 5 minutes. I didn't run the command after changing it but prior to changing it the command returned nothing.
My System SpecsSystem Spec
22 Oct 2018   #10
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

So changing the timeout has reset the timer. It would be interesting to see if this is a permanent fix, or not.
I had this exact same problem, on my Windows 7 but not on my Vista machine. On mine, VMWare is not installed but, like you, I had Steam Client, and I had the AMD External Events Utility (together with an older AMD graphics card).

On my machine, changing the timeout resets the timer - but it was not a permanent fix. Maybe you got lucky with a permanent fix, if not, then I have shared these things with you.
My System SpecsSystem Spec
Reply

 Screensaver not starting automatically.




Thread Tools




Similar help and support threads
Thread Forum
w32time service not starting automatically
Does anyone else have this same problem?, w32time service does not start automatically, see pics for my settings. I can start it manually with no problems.
General Discussion
Starting magnifier automatically
Several members of my family have sight impediments and it is becoming a real issue when logging onto the computer. Is there anyway to start the magnifier as the computer starts without having to navigate to the button that turns it on. Also, is there anyway to start it at a specific zoom measure....
General Discussion
Windows 7 time not automatically starting.
I have set the service to automatically start but everytime i reboot the services is stopped. Is this normal or do i have a problem with the time service? This is on a fresh install. I just finished getting all of the updates. I am using windows 7 home premium 64bit.
General Discussion
Change IIS from starting automatically
Is there a way to set IIS so it does not start automatically when Windows starts? I know how to turn it off.
General Discussion
Slideshow Screensaver not Starting
This has been a problem for me since Vista. I was hoping that once I upgrade to Win7, this problem would go away, but it didn't. I set my screensaver to the slideshow that comes with Windows. The folders I use is on my only SATA HDD. The power scheme is the default setting. Most of the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:48.
Twitter Facebook