Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Convert FAT or FAT32 Volume to NTFS

11 Sep 2010   #60

64-bit Windows 10 Pro

Quote   Quote: Originally Posted by rameshgautam View Post
hello sir
i have 128 gb kingston usb flash drive
how to conver to NTFS format
help me


A USB flash drive will normally be formatted as FAT32 instead.

With it plugged in, could you post a screenshot of your Disk Management (diskmgmt.msc) like I posted above showing the layout of that drive?

You should be able to use the tutorial on the 1st page to convert it to NTFS, or you could also format (deletes everything though) the USB flash drive as NTFS.

My System SpecsSystem Spec
15 Oct 2010   #61

WIndows 7 - 64 bit


I tried to convert my External drive,
but it din't work, the first time so it gave me this error:

so I did the CHKDSK /F and this was the result:

Then I redid the convertion but still the error:

Is there any way to convert it without formatting it?
because it has over 800GB of files that I don't wanna lose
My System SpecsSystem Spec
15 Oct 2010   #62

64-bit Windows 10 Pro

Hello Cskiwi, and welcome to Seven Forums.

You might see if you may be able to convert it using a command prompt at boot instead.
My System SpecsSystem Spec
16 Oct 2010   #63

WIndows 7 - 64 bit


Euhm, how can I do that?
or is that the same commands? but how and where must I type them?

already thanks
My System SpecsSystem Spec

16 Oct 2010   #64

64-bit Windows 10 Pro

The tutorial link below can help show you how to boot to a command prompt at boot. You'll use the same commands once you are in command prompt at boot. :)

Command Prompt at Startup
My System SpecsSystem Spec
22 Oct 2010   #65

Windows 7 64-bit Ultimate

Hi Brink, this is a great thread and your tutorial is spot on.
It helped originally converting 1TB of data on a Seagate successfully with all my data from FAT32 to NTFS no problem.

Question: I just got a brand new Samsung G3 Station with a 1TB drive in it.
I haven't loaded anything on it yet and it comes with free software (backup etc).
I did the convert in cmd like its been taught here but it got to the end and also told me:

'cyclic redundancy check error'

I read earlier in this thread (2009) that the same thing happened to somebody else but he couldn't pick up any errors afterwards and could still access his drive. Its odd as its brand new. I'm running a CHKDSK now to see if there might be any bad sectors (defective hardrive perhaps as when I first switched it on it did make a clicking sound but then stopped.)

Any suggestions as to why I would get this error converting it to NTFS with practically no data on it?

Thx for the time :)
My System SpecsSystem Spec
22 Oct 2010   #66

64-bit Windows 10 Pro

Hello Marcel,

Since you do not have anything loaded on the 1TB drive in the Samsung G3 Station, you should also be able to just right click on it in the "Computer" window and format it using NTFS.
My System SpecsSystem Spec
26 Oct 2010   #67

Windows 7 Ultimate 32bit

Hey Shawn.
Thanks a lot for this great tutorial and for your GREAT effort in this post.

My cousin bought a kingsone dt310 256GB usb.
It came formated as FAT32.
I tried to convert it to NTFS with "conver h: /fs:ntfs /v" with no success.
Then it became unreadable and unformattable. I was able to format it with HP USB Disk Storage Format Tool v2.1.8 to FAT32 only. I also tried to format it as NTFS with no success.
It seems that it cought 128GB for nothing (can't find any file no matter what attribute I looked for).
I ran chkdsk: "chkdsk h: /f /r /v", and it found a lot of lost chains. After that I was having a FAT32 with 256GB.

Now I'm running "clean all" via diskpart (thanks to your great tutorial about it: Disk - Clean and Clean All with Diskpart Command)
It seems to take some time (already an hour with no prompt).

I didn't saved any prompt from the previous actions.
I'm trying to start from scratch.
I'll finish cleaning and then I'll try to format as NTFS.
After that I'll keep any valuable prompt and will post back.

However I wonder about what you posted to 1morethanu:

Quote   Quote: Originally Posted by Brink View Post
Hello 1morethanu, and welcome to Seven Forums.

What type of drive (ex: USB flash drive, internal HDD, etc..) are you trying to convert? Is the drive encrypted or has any write protection enabled on it.

If USB, then you may only be able to format it as NTFS instead of convert it to NTFS.

Hope this helps,
About the last comment, why it is possible only to format as NTFS and not to convert?
My System SpecsSystem Spec
26 Oct 2010   #68

64-bit Windows 10 Pro

That was a issue specific to his situation below since it failed to convert for him due to some bad sector. That's all.

Hi Brink,

after I followed your instructions for using the command prompt I was received a:

the second NTFS boot sector is unwriteable.
the conversion failed.
F: was not converted to NTFS

Am I out of luck or is this fixable?
My System SpecsSystem Spec
27 Oct 2010   #69

Windows 7 Ultimate 32bit

The "clean all" option just hang for hours and hours.
What I got from the system event log is this event:
level: error
source: VDS Basic Provider
event id: 1
description: Unexpected failure. Error code: 490@01010004

It's looking like that:
Convert FAT or FAT32 Volume to NTFS-usb-n-1.gif

According to microsoft "This event can be safely ignored.".
VDS Basic Provider event ID 1 is logged on a Hyper-V guest operating system

So I tried "CTRL+C" in order to stop diskpart. After that my computer worked slowly. I tried to run diskpart again, but it ain't loaded for a few minutes.
Convert FAT or FAT32 Volume to NTFS-usb-n-2.gif

In the system event log I got the 2 following errors:
level: error
source: VDS Basic Provider
event id: 5
description: Cannot zero sectors on disk \\?\PhysicalDrive2. Error code: \\?\PhysicalDrive2
level: error

source: disk
event id: 11
description: The driver detected a controller error on \...\DR6.

Convert FAT or FAT32 Volume to NTFS-usb-n-3.gif

I ejected the usb, reinserted it, and now my computer got back to normal and diskpart loaded well. So I performed "clean" and tried to format to NTFS. It ain't worked. It says it put some details in the system event log but they aren't any. So I formated it to exfat.
Convert FAT or FAT32 Volume to NTFS-usb-n-4.gif

BTW I can't perform full format. It just stuck for hours with event id 1 (as described above).
Just to be on the safe side I ran "chkdsk h: /f /r /v".
So I'm using it as exfat. It's working ok. I just can't get it working on NTFS.
And BTW though it came formatted as fat32, I can't format it to fat32 without 3rd party utility like "HP USB Disk Storage Format Tool v2.1.8".
Here is diskpart prompt:
Convert FAT or FAT32 Volume to NTFS-usb-n-5.gif

Brink, thansk a lot for this and for other great tutorials which helped me A LOT through this problem and taught me well. I appreciate your OWESOME effort and concern in this forum.

My System SpecsSystem Spec

 Convert FAT or FAT32 Volume to NTFS

Thread Tools

Similar help and support threads
Thread Forum
Convert from NTFS to FAT32 without reformat
Hi, I was just wondering if its possible to convert my NTFS external drive to a fat32 without formatting. I don't want to have to transfer all my data to my PC, reformatted and transfer it back. The reasons its has to be fat32 is because i just got a mac which is now my primary PC and mac...
Hardware & Devices
Can't convert FAT32 to NTFS
I keep trying chdsk f: /f and it says its clean and fixes errors and then I go to Convert F: /FS:NTFS and it says I need to do chdsk :f /f Any ideas? I can't get it to work
Hardware & Devices
convert FAT32 to NTFS in XP
I know this is (obviously) a Windows 7 site, and I apologize if me posting about XP is against the rules here -- but seems like there are some experts here that may be able to point me in the right direction. I've been experiencing the same issue as another user (Asura) who never posted as to...
Chillout Room
convert to ntfs from fat32
hi all sorry i havent checked if this thread is already covered as im in the middle of trying to convert my new external hdd, it is formatted as fat32 and i just started to convert it using comand promt like this tells u How to Convert FAT Disks to NTFS i have entered the comand convert D:...
Hardware & Devices
Convert NTFS To fat32 without format
Hello , Is there any way to convert from NTFS to FAT32 without format ? Thank U :)

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:35.
Twitter Facebook Google+