Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: User Profiles - Create and Move During Windows 7 Installation

23 Oct 2015   #1010


You might not need to wait. I think I found the culprit, please give me a few minutes to confirm my findings and post them.

I am so confident that I found the real culprit that I suggest you to cancel the download for now. If I am wrong you can always restart it.

Stay tuned...

My System SpecsSystem Spec
23 Oct 2015   #1011

Windows 7 Professional x64 SP1

I'll keep the download going. This is some good stuff! Your tutorials are fantastic.

By the way, I forgot to stop the Windows Media Player Network Sharing Service (WMPNetworkSvc) on the last two attempts. I won't make that mistake again.

My System SpecsSystem Spec
23 Oct 2015   #1012


OK, this is weird!

This is what I did just now:
  • I set up a Hyper-V virtual machine on my Windows 10 host, installed Windows 7 Professional on it with C: and D: HD partitions and E: optical drive
  • Entered Audit Mode
  • Copied your answer file from this post, pasted it in Notepad on my virtual machine, saved it on D: as relocate.xml
  • Visually inspected the file, it was absolutely correct
  • Stopped the WMPNetwork Service
  • Sysprepped, got the same error than you!
  • Opened Notepad, this time I wrote the same answer file in a new file manually, character by character copying your answer file from the same post I had first copy & pasted it
  • Saved it again as D:\relocate.xml, overwriting the failing one
  • Stopped the WMPNetwork Service
  • Sysprepped, this time sysprep worked as it should without an issue and the folders were relocated to D: drive
What this means is that somehow, accidentally of course, your answer file had a hidden character. Visual inspection revealed nothing, the answer file is and was 100% correctly written, apart that hidden character which could not be found by visual inspection. I have no idea where or what it is and how it got there when you copied the text from the PDF, but that's the only explanation.

See it by yourself: the below answer file is visually exactly the same you used, character by character, but this one worked for me after I had manually rewritten it, whereas the one I copy & pasted from your post caused an error.

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
 <settings pass="oobeSystem">
  <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
<cpi:offlineImage cpi:source="wim:E:/sources/install.wim#Windows 7 Professional" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
A bit ridiculous, I've searched the culprit everywhere else, even blaming RAID (I still don't like it!) but never ever had I thought there might be something invisible!

Anyway, copy the above answer file code and use it, it should now work for you

My System SpecsSystem Spec
23 Oct 2015   #1013

Windows 7 Professional x64 SP1

I notice that you've got "Windows 8 Pro" on line 10. Does that make a difference? Will it work if I change that to "Windows 7 Professional?"

The indents are different too. Does that make a difference?

I suspected something hidden in that original answer file.
My System SpecsSystem Spec

23 Oct 2015   #1014


No, that just means that as I have my drives full with various answer files I accidentally (I blame the whisky!) first inserted the wrong one in my post, an older one, not the one I just used in my test.

I have since edited my previous post and inserted the correct answer file, the working one, copied by manually writing it character by character. Sorry the confusion.
My System SpecsSystem Spec
23 Oct 2015   #1015

Windows 7 Professional x64 SP1

Do I use the same commands with the unattend switch?
My System SpecsSystem Spec
23 Oct 2015   #1016


You are free to choose:
  • Save the answer file as C:\Windows\System32\Sysprep\unattend.xml
  • Sysprep with sysprep.exe /oobe /reboot
--OR --
  • Save the the answer file naming and locating it as you wish, for instance D:\relocate.xml
  • Sysprep with sysprep.exe /oobe /reboot /unattend:D:\relocate.xml
Don't take this wrong but this your case is driving me nuts! Please come back to tell how it went as soon as you have done it.
My System SpecsSystem Spec
23 Oct 2015   #1017

Windows 7 Professional x64 SP1

I ran the file named unattend in the sysprep directory and I didn't get the error. However, when I arrived at the screen where you input your user name, etc..., I did ctrl shift F3 to go back into Audit Mode. Once in Audit Mode, it appears the Users folder is still on C:. Is that just how it appears in Audit Mode, but the Users folder will be on D: in OOBE Mode?
My System SpecsSystem Spec
23 Oct 2015   #1018


When you boot to Audit Mode from OOBE before any user accounts are created, you sign in using the build-in administrator account which needs to activated for this purpose and system therefore needs to create the C:\Users\Administrator folder.

When you Sysprep and enter OOBE, this account will automatically be disabled again and the need for the C:\Users no longer exists if the Users have been relocated.

However, both Users and ProgramData may remain also on C:, doing no harm and never getting bigger than a few kilobytes. See this post for one explanation: User Profiles - Create and Move During Windows 7 Installation
My System SpecsSystem Spec
23 Oct 2015   #1019

Windows 7 Professional x64 SP1

I'm in OOBE Mode and the folders didn't move. I need to get back into Audit Mode and run the file again, this time as relocate with the switches as indicated in the tutorial.

I'll follow the instructions in the tutorial for going back into Audit Mode and start from there with the new answer file.
My System SpecsSystem Spec

 User Profiles - Create and Move During Windows 7 Installation

Thread Tools

Similar help and support threads
Thread Forum
Help with User Profiles in Windows Server 2008
Hey guys and ladies. So i have scoured the forums looking for answers to my problem and have yet to get a definitive fix. It may just be me though lol. So I am an IT technician for some schools and i have just implemented a new server. It is running Windows Server 2008. My client machines are...
General Discussion
cannot create new user profiles
Win 7 Home Premium. Optiplex 755. I have a working user profile with administartive rights which works fine. I also have a working guest user. However when I try to create a new user, standard or administator, the new user is shown in "mange users" but cannot be logged into. This happens in safe...
General Discussion
Can't move user profiles
Guys ... opening this as separate thread as previous one took a direction of its own. Scenario As per Tutorial moved my profiles off the C:\ In order to use Windows Repair/Upgrade Disk I need to move them...
Installation & Setup
How do I move my user profiles back to C:\user
On advice here to keep OS disk space small, followed the tutorial and moved my user profile from C:\user\name to E:\user\name The problem is Windows upgrade (need to run for repair) will not accept profiles...
Installation & Setup
New to Win7 move User profiles or use Libraries?
I have just upgraded from Vista where we had two user account profiles on the D partition, as I recall, Vista prompted me to set it up this way initially. I got used to using this method, as my single hdd is divided into two partitions, C for the OS and D for Data. I did a new clean install of...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App