Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: User Profiles - Create and Move During Windows 7 Installation

21 Jan 2012   #240

Windows 7 Home Premium 64 bit

Nope, this is not working at all. My XML content below:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="Error" xmlns:xsi="">
<cpifflineImage cpi:source="wim:F:/sources/install.wim#Windows 7 HOMEPREMIUM" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

I can't see anything wrong in there can you?

I've checked the ISO and sure enough as expected the "install.wim" is right there as it should be.

I wonder if the OEM "Restore" and "HP_TOOLS" partitions are preventing this working in some way...............I've also tried changing the drive letters from the OEM originally designated drive letter just in case anything should try to point to the original OEM "Restore" and "HP_TOOLS" partitions............and I've tried changing them back again, but still no joy either way.

Have you, Britton30, and Kari any other ideas??

My System SpecsSystem Spec
21 Jan 2012   #241

Microsoft Community Contributor Award Recipient


Quote   Quote: Originally Posted by Britton30 View Post
<cpi:offlineImage cpi:source="wim:E:/sources/install.wim#Windows 7 ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
In the same light Kari, I will need to use the Windows DVD to run the answer file to move ProgramData back to C: then?
Yes. The install.wim file is essential to run sysprep with an unattended answer file.

Quote   Quote: Originally Posted by Amicus View Post
Hi Kari,
1) In exactly what way is the OEM recovery disk set not a normal Windows install media?
Because I do not know the contents of your specific recovery disks, I can not answer this question. Simply put, you need install.wim. If you do not have it or can not find it on your recovery disks, then you need a "real" install media.
Quote   Quote: Originally Posted by Amicus View Post
2) Surely the OEM recovery disks contain everything needed for a W7 install? Otherwise in the event of a HD replacement and subsequent install of the OS, the installation would fail, which of course it doesn't. Can the answer file text not be amended to suit?
See my answer above.

Quote   Quote: Originally Posted by Amicus View Post
3) Will the use of the ISO W7 media now completely overwrite my existing System installation, or will the Sysrep / Audit text be the only thing used, and merely locate the "Users" and if I wish, the "ProgramData" to the partition / drive of my choice, leaving all other parts of my original installation untouched and intact?
Nothing is overwritten, nothing is deleted. The script (= unattended answer file) just changes one or two of the internal Windows 7 environment variables.

Amicus, as Derek suggested above, I think you'd better to choose the other method, the one he told in his post above.

My System SpecsSystem Spec
21 Jan 2012   #242

Windows 7 Home Premium 64 bit

Hi Kari,

I'm now using the downloaded W7 Home Premium x64 ISO, the "install.wim" is in there within "Sources" as it should be.

The script I am using and which I shared in my last post above would appear to be correct to me......... g: being the chosen location, f: being the CD/DVD drive, and I've simply placed the XML-script on the root of any chosen drive (in the first instance I chose C: and when that didn't work I chose G: and altering my cmd line in each instance to suit).

I understand your comment re., derekimo's posted link but what if I now or in the future want to include "ProgramData" in the move?

I really do need to resolve this for my sake and for the sake of others who may be in the same unfortunate position.

What am I doing wrong here.....all this should work now with the ISO and "install.wim"???
My System SpecsSystem Spec
21 Jan 2012   #243

Windows 7 Home Premium 64 bit

Hi Kari and others,

I have now tested this every which way, following the tutorial instructions, and without any error messages appearing, and all apparently going to plan, but without any ultimate success.

I must confess I am now beginning to think that your method is just not possible to achieve on a laptop (I've only been testing this on a laptop) which is already running an OEM install of W7 Home Premium 64 bit, notwithstanding the fact that a downloaded "Digital River" W7 ISO of W7 Home Premium 64 bit is used as the source of "install.wim".
  • Have you, or indeed anyone else out there for that matter, ever actually achieved this in the circumstances described in my paragraph above??
  • If so, please share your methodology.
I now suspect that the only way "Users" and / or "ProgramData" can be moved is by using the aforementioned ISO to do a completely clean install and activate the OS by using the OEM product key supplied with the laptop..................that will of course mean that you will lose the entire OEM Recovery partition, and also in my case the HP_TOOLS'll have the "one-off" recovery disk set of course (if you've created it), but if you now use that as a recovery install method, the new location of "Users" and / or "ProgramData" will revert to where the OEM wants it / them placed, and not where you had moved them!

Your thoughts please?

My System SpecsSystem Spec

21 Jan 2012   #244
Microsoft MVP

Windows 7 Ultimate X64 SP1

Yes, see post #236 and follow the tutorial Derek linked to. Should work fine. I don't know specifically if someone has done either on an OEM factory install, but I would be certain it would work.
My System SpecsSystem Spec
21 Jan 2012   #245

Microsoft Community Contributor Award Recipient


First a reminder, a really, really, really important thing: If you follow the tutorial, you
A) Boot to Audit Mode
B) Run sysprep from elevated command prompt with answer file which causes Windows to boot back to Audit Mode
C) Run sysprep from GUI without answer file booting to Oobe mode (Welcome Mode, normal "first boot")

So, Amicus, an important question, a question I ask because it's been reason in a lot of cases I have been called over to friends and neighbors when they call in panic telling the folders did not move: Did you go through all the above mentioned steps A, B and C?

Explanation: When you run sysprep with answer file (sysprep.exe /audit /reboot/ /unattend:X:\name_of_the_script.xml), Windows boots back to Audit Mode. Folders are not moved at this stage so if you check the drive where you were moving your folders, they will not be there! Instead they will still be on C:.

Only the last, most crucial step, booting to Oobe, will move the folders, as told in tutorial. One more time: When the answer file is run and computer is rebooted, it is still in Audit Mode if you followed the tutorial, and no folders have yet been moved.

OEM has nothing to do with failure or success of sysprepping with an answer file. As mentioned several times throughout this thread, sometimes this fails which, also mentioned several times, I believe to be because of one or another running Windows service disrupting sysprep. As I have told, I have had identical laptops, bought at the same time from the same place, with identical OEM Windows and application setup, where one fails and one works.

As you can read in this thread, this method mostly works, also in those cases where it has first failed we have often found a small error and when it has been fixed, the result has been OK. But, in some cases it simply does not work and I have had nor do I have no time at the moment to do more reseach.

A short checklist:
- Place answer file on root of a drive THAT KEEPS THE DRIVE LETTER IN EVERY REBOOT! Some fails have been because answer file is in D: but reboot gives D: to CD/DVD drive and sysprep can no longer find the file.
- Check for syntax errors, for instance when sysprepping Home Basic or Home Premium remember that they are written as one word in answer file (HOMEBASIC, HOMEPREMIUM).
- Check the processor architecture in answer file. For 64-bit systems it must be amd64, for 32-bit systems x86.
- Follow the tutorial to the letter. There are no unnecessary steps, nothing you can skip to save time or typing.

That's it. If it works for you, good. If not, I do not think I'm able to help you more.

My System SpecsSystem Spec
21 Jan 2012   #246

Windows 7 Home Premium 64 bit

With respect, that would appear to be skirting around the issue in hand.

I am seeking to use the method proposed by Kari in the way in which it is described as being possible at the start of the post and in the tutorial, to achieve the end result.

In that regard, I am also seeking confirmation as to whether or not this has ever actually been successfully achieved on a laptop which is already running an OEM install of Windows 7 Home Premium 64 bit, using a downloaded "Digital River" (or similar) Windows 7 Home Premium 64 bit ISO as the source of "install.wim".

In the event that no one has achieved this, it would seem sensible to place an additional note at the head of the tutorial to make this clear...............would save others from possibly wasting their time trying.

Many thanks for your detailed reply. In an earlier post (#116) I seem to recall you stating that you'd been there, done that, etc., with an already installed OS........however, have you successfully achieved this in the OEM circumstances which I have described?

Re., your last post, yes, I followed the tutorial to the letter, understood completely about the correct sequence and number of audit reboots etc.,.........repeated it so many times now it's burned into my brain Lol. It all appears to go correctly, created Test account, logged into my original account etc., etc., etc., but the folders remain stubbornly on C:

Disappointingly, I do understand your comment about sometimes it works and sometimes it just doesn't, but I must confess, I am not as confident as you that this failure has nothing to do with the OEM situation...........proof would be others reporting that they have achieved it.

Also, reviewing the whole thread, issues doing this with Home Premium do seem to be rather common............unless I am mistaken?

Gone through your very useful summary checklist at the foot of your last post, and yes all seems to be as I have done, but sadly still no success for me.

I really do appreciate all the time you have put into creating your tutorial and to reviewing well over 200 posts now, and to trying to help 'all-comers'. Thanks.

Any other ideas on this which may spring to mind by you or any others would be very much appreciated.

My System SpecsSystem Spec
21 Jan 2012   #247

Microsoft Community Contributor Award Recipient


Quote   Quote: Originally Posted by Amicus View Post
I am also seeking confirmation as to whether or not this has ever actually been successfully achieved on a laptop which is already running an OEM install of Windows 7 Home Premium 64 bit, using a downloaded "Digital River" (or similar) Windows 7 Home Premium 64 bit ISO as the source of "install.wim".
I have done this several times, so have others, on a laptop with OEM Windows. Although I simply can not believe failing has anything to do with Windows edition, sysprep being a native tool in every edition, I have to admit all my rigs and those I have prepared for others have been at least Professional, mostly Ultimate.

To revert to original folder locations by running sysprep with this answer file on an existing setup, that too I have done a few times. Mostly because the secondary HD have been changed so I have to first move Users back to C:, then swap HD's, then once again move Users to D:, but I have also done this solely for test purposes.

One clear tendence can be seen in this: the older the setup i.e. the more software and devices installed and processes running, the chance to fail grows exponentially. In my opinion this again supports my theory of a service (or process) being the culprit.

My System SpecsSystem Spec
21 Jan 2012   #248

Windows 7 Home Premium 64 bit

Re., the Windows edition, you may well be right Kari, you may well be right, but it does seem curious though!

Yep, I know your theory of a service (or process) being the culprit may seems like a good call on the face of it, but in this case, you'll remember from my first post that my rig is new and straight out of the box, clean, with no connections as yet. In these circumstances I feel it would be slightly unusual for a Windows process to be the cause. Had it been used and messed around with etc., ......a different matter.

I've got to admit Kari, I am perplexed by all should work!
My System SpecsSystem Spec
21 Jan 2012   #249

Microsoft Community Contributor Award Recipient


Amicus, a Windows service being the culprit in a totally new system is not strange at all. Keep in mind the EDIT at the very bottom of the last page of the tutorial, added there when I almost accidentally stumbled upon one of the Windows Media Player services preventing sysprepping:
EDIT: Based on my own experience, sysprep does not always like Windows Media Player Network Sharing Service (WMPNetworkSvc). Reason is unknown to me. If you get an error message when trying to run the XML script, end the service and try again.

Type this to Command Prompt to stop the mentioned service and press Enter:
net stop WMPNetworkSvc
Now run the script with sysprep command once again.
My System SpecsSystem Spec

 User Profiles - Create and Move During Windows 7 Installation

Thread Tools

Similar help and support threads
Thread Forum
Help with User Profiles in Windows Server 2008
Hey guys and ladies. So i have scoured the forums looking for answers to my problem and have yet to get a definitive fix. It may just be me though lol. So I am an IT technician for some schools and i have just implemented a new server. It is running Windows Server 2008. My client machines are...
General Discussion
cannot create new user profiles
Win 7 Home Premium. Optiplex 755. I have a working user profile with administartive rights which works fine. I also have a working guest user. However when I try to create a new user, standard or administator, the new user is shown in "mange users" but cannot be logged into. This happens in safe...
General Discussion
Can't move user profiles
Guys ... opening this as separate thread as previous one took a direction of its own. Scenario As per Tutorial moved my profiles off the C:\ In order to use Windows Repair/Upgrade Disk I need to move them...
Installation & Setup
How do I move my user profiles back to C:\user
On advice here to keep OS disk space small, followed the tutorial and moved my user profile from C:\user\name to E:\user\name The problem is Windows upgrade (need to run for repair) will not accept profiles...
Installation & Setup
New to Win7 move User profiles or use Libraries?
I have just upgraded from Vista where we had two user account profiles on the D partition, as I recall, Vista prompted me to set it up this way initially. I got used to using this method, as my single hdd is divided into two partitions, C for the OS and D for Data. I did a new clean install of...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:11.
Twitter Facebook Google+