Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Startup Repair Infinite Loop Recovery

26 Sep 2014   #420

Windows 7 Ultimate x64
Infinity Looping Repair

I have followed your instructions, but when I got to the page 10 when you look at the regback screen, all the files show 0 bytes.

What are my other choices?

My System SpecsSystem Spec
27 Sep 2014   #421

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

If you have shadow copies, you can replace the reg hives from there, or even the entire os.
My System SpecsSystem Spec
04 Oct 2014   #422

Windows 7 64 bit
I/o device error

Hi , trying this, but I can't get past md my backup because it says: The request could not be performed because of an I/O device error - Please help!
My System SpecsSystem Spec
07 Oct 2014   #423

64 bit win 8 and fedora and ubuntu

did the cluser in windows 8 with a bad update to 8.1. Was about to start the linux thing to fix it when i found your tutorial which worked perfectly. YOU ROCK!
My System SpecsSystem Spec

15 Oct 2014   #424

windows 7 ultimate 32 bit

it helps me so much and it saves my money...........thank you very much...............
My System SpecsSystem Spec
16 Oct 2014   #425

W 7 64

Thank you.
My System SpecsSystem Spec
24 Oct 2014   #426


Great job! Thank you.
I know nothing about computers and systems. But this was guiding very well.
My System SpecsSystem Spec
21 Nov 2014   #427

Windows 7 Professional 64bit
Possible solution for "an I/O device error" message in stage 8


This post is helpful but there are still alot of questions unanswered for those whose pcs don't work out like the instructions. I had a similar problem like el7, all the way back in 2011 and Flashgirl just last month. At stage 8. After typing c: and pressing <enter> I got an error message: The request could not be performed because of an I/O device error

I read the whole discussion but found that years later the problem still hasn't been resolved. It would be great if these outstanding questions could be answered.

Luckily for me I found a solution. I don't know whether this will work for others but for me it was something i just stumbled upon while trying alternatives.

1. I existed command prompt after that error.

2. I reopened command prompt and run the chkdsk /f command. It ran the whole night yesterday. In the morning the log, at the very end, showed that it wasn't able to find a windows os installed on the disk. I lost hope and shut down the pc.

3. Later that day i started up the pc and when it got to the System Recovery Options window, I opened command prompt. I run chkdsk /f c: command. This time the log showed that there weren't any problems on tge disk. I'm not an expert at these things so i'm not sure if adding the c: at the end made a difference.

4. I existed the command window and reopened it.

5. I decided to try this tutorial again, just to try my luck, and was surprised when i managed to get past stage 8. All the way to stage 13.

6. At stage 13 I, like many others, found that my files sizes where considerably different sizes from what is in the tutorial. I read through the discussion and finally found a reply from "Brink" addressing "Zkhan" saying:

The important part is that they are not zero, so you should be good to go to continue the steps.

So i went ahead and completed all the steps. It worked and the pc has been running properly for an hour now . I didn't expect it to since others with similar problems didn't manage to fix their pcs.

This tutorial has helped me but it would really be helpful to resolve these outstanding queries. Thanks for the help.
My System SpecsSystem Spec
03 Dec 2014   #428

Win 7 x64 Pro, Premium, Win 8.1 x64 Premium
Step 12/14 possible work around...

There was a problem with a co-workers laptop where the config directory was trashed and chkdsk was unable to fix giving 766f6c756d652e63 3f1 Unspecified error.

I managed to boot from a Win 7 Install DVD I had and got to command prompt. From there I went to <system Drive>\Windows\System32\config and attempted a DIR command which only gave me the highest level <DIR> single '.' listing. undaunted I tried to CD into RegBack and it let me even though it would not list it through the DIR command!

After this I was able to md <SystemDrive>\RegBack then copy *.* to my new folder <System Drive>\RegBack. Since it would not let me into the config folder I tried deleting/removing (RMDIR/RD) it failed here as well due to in consistent HDD meta-data. My last attempt finally worked I just used the REN/RENAME command: REN "<SystemDrive>\Windows\System32\config" "trashed" and it let me! Yay! Then I just created a new config dir under System32 (MD/MKDIR): MD "<SystemDrive>\Windows\System32\config", and finally copy would work for me Copy "<SystemDrive>\RegBack\*.*" "<SystemDrive>\Windows\System32\config" and FINALLY it would boot again and allow me to run chkdsk repairing the disk problems! Seems to be all better now!

Thank you for this Tutorial! It and other information helped me to come up with my alternate solution!
My System SpecsSystem Spec
06 Dec 2014   #429

Windows 7 Professional x64
Worked for me, thank you!!

This thread has been an absolute life saver!!

Not entirely sure what happened but my PC (two year old Dell) decided that Windows was no longer genuine and kept prompting me to go to the Microsoft site and buy another version of Windows (like hell). I had even contacted Microsoft support to no avail.

I tried a few other solutions I found online (roll back Windows Update but that failed, system restore point which failed) then I ended up stuck in the start up repair/recovery loop...

After a few tears, purchase of a back up drive and some Googling I came across this page. Followed the steps and after about 2 mins my computer was back up and running again. Fixed the Windows not genuine problem and back to normal. Thanks to whoever wrote this, you have saved so many memories and a whole boat load of work. Thank you!!
My System SpecsSystem Spec

 Startup Repair Infinite Loop Recovery

Thread Tools

Similar help and support threads
Thread Forum
Startup Repair Infinite Loop Recovery
Help Guys, i did a startup repair infinite loop recovery, because my desktop hard disk wont boot normally so after the successfully of the repair, all my files in partition drive "D" is also back on the earlier files. how to get back to the previous windows registry. please help, ...
General Discussion
startup repair infinite loop after BIOS update, recovery not working
Hello, I recently attempted to update my BIOS (Gigabyte F8 to F10) so that I could upgrade my CPU from a sandy bridge to an ivy bridge. I did not do the cpu upgrade, yet, just the BIOS flash. The flash, using Gigabyte's q-flash) went fine, according to the flash results screen. I then rebooted,...
General Discussion
Startup Repair Infinite Loop Recovery
I now hope I am in the right spot to get some help. I am new at this stuff and I couldn't figure out how and where to post my problem. Now I implemented the tutorial about my problem and it worked just great except that whenever I start or restart, the problem is still there and I have to use...
Performance & Maintenance
Startup Repair Infinite Loop
Im having problems and am stuck in the infinite loop on startup repair. I have followed the tutorial i'm getting down to point 10 10) Type DIR and press <ENTER>, and verify that the following files and folders...
Performance & Maintenance
Startup Repair Infinite Loop
Hi, New to the forum here, hope to get some help :confused: Running windows 7 ultimate 32 bit on my computer, which ran fine until recently, where the taskbar will stop responding after I booted my computer, which eventually leads to the entire system freezing. Usually a reboot solves the...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:29.
Twitter Facebook