USB Driver - General Fix for Problems

Page 3 of 8 FirstFirst 12345 ... LastLast

  1. Posts : 294
    Windows 7 Ultimate x64 SP1
       #20

    nwnc14344 said:
    where do i find the INFCACHE.1,,,, what do you mean by uninstall? you mean that i will uninstall all the USB ports on my LAptop then the INFCACHE.1 will appear? sorry im just a newbie for this problem please help me
    INFCACHE.1 is located in C:\Windows\System32\DriverStore

    The rest of the instructions are clearly listed in the original post by pooch if you scroll back up.
      My Computer


  2. Posts : 1
    Windows 7 Home Premium x64
       #21

    similar problem but pooch's solution won't hold


    Hey all,

    So I'm having a similar problem, I think, but the general solutions doesn't totally work.

    I have at least 4 different USB controllers (one multi-card reader in front, another 2-port in front with the headphone/mic jacks, two in back, and a 3.0 in back)... but I'm not perfectly sure how to identify any of these in the Device Manager.

    Nonetheless, Pooch's solution works for me, but only for the reboot immediately following the procedure. On the next reboot, all but one of my USB controllers won't start (I get the code 10 in the device manager). But, if I go into the Device manager, and 'disable' each controller, then 'enable' each controller, I can get all the ports to work. Until the next time I reboot the system. I tried the pooch-solution three different times, all with the same outcome, one good reboot, then back to 'code 10' on all but one bank of ports.

    I'm doing my best to avoid reinstalling windows, and since eventually I can get all the ports to work, I feel like it's just a software problem. I'd prefer not to have to access the device manager every morning when I turn the machine on, so I'm hoping for some sort of solution.

    This basically started happening without any major hardware changes. I did have a USB flash drive that was causing my problems, and I started troubleshooting that, and I'm guessing maybe some 1 got changed to a 0 in the process.

    Any thoughts?

    --Dave
      My Computer


  3. Posts : 1
    Windows 7 Professional 64 bit
       #22

    Just a quick question regarding the above tutorial:

    I am having intermittent success in getting my system to recognise a Freecom external USB HDD.
    Freecom themselves have directed me to the infcache.1 renaming process as described above, but their version said to delete only shaded entries in the USB controllers list. Also I could not rename infcache.1 even though I set full permissions, and ultimately changed ownership of it. I even tried to move it out of the DriverStore folder - which I could do, but Windows did not rebuild it and it would not let me put the old one back! I ended up using System Restore to revert to the setting from 24 hours previous. So I am back where I started.

    If I delete ALL listing under Device Manager > USB controllers, as directed above, will that impact on the fact that both my keyboard and mouse are connected via USB? My mobo does not have PS2 connectivity.

    Thanks
      My Computer

  4.    #23

    Good tutorial (:
      My Computer


  5. Posts : 5
    Windows 7 Home Premium 64bit
       #24

    On the step where we have to open windows explorer, and i type in INFCACHE.1 nothing comes up.
      My Computer


  6. Posts : 70,230
    64-bit Windows 10 Pro
       #25

    Hello Wally, and welcome to Seven Forums. :)

    Did you select Computer in the navigation pane first to search for INFCACHE.1 in Computer?
      My Computer


  7. Posts : 5
    Windows 7 Home Premium 64bit
       #26

    Yes I did. I figured it out though. I just did a system restore to two days ago and started the tutorial over. So far everything's fine. Just one question, when it says connect usb device, does that mean just insert the usb cord.? Or should I insert the cord and my phone.?
      My Computer


  8. Posts : 70,230
    64-bit Windows 10 Pro
       #27

    Good news. Yes, it means to connect both to connect the device completely. :)
      My Computer


  9. Posts : 5
    Windows 7 Home Premium 64bit
       #28

    I kept my phone plugged in while it was restarting. When the computer started back up, it charged, but that only lasted for a few seconds. Anyone know why.?
      My Computer


  10. Posts : 1
    Windows 7 Professional x32
       #29

    For anyone who cannot delete the INFCACHE.1 file, there's a solution:

    After creating "Administrators" in Step 5, please check all the box under "Allow" (such as totally control, edit, read&execute, etc -> I'm using a Chinese OS so the wordings may not be exactly the same

    That should fix and can delete the file now
      My Computer


 
Page 3 of 8 FirstFirst 12345 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:19.
Find Us