USB Driver - General Fix for Problems

Page 7 of 8 FirstFirst ... 5678 LastLast

  1. Posts : 3
    Windows 7 Ultimate x64, Windows 7 Home Premium 32bit

    disable USB debugging

    Go here. "". Follow the instructions to access developer options. DISABLE Usb debugging. If that doesn't work right off the bat, try rolling back the driver for the phone.
      My Computer

  2. Posts : 3
    Windows 7 32 Bit Professional

    I tried as suggested in the reply but still no luck. Spoke to Microsoft people. They say the problem may be due to some changes done by some Windows update. Unfortunately, I removed all old restore points one day before this problem started. Some say, re-formatting Windows is the only answer. I can get it done but what is the guarantee the problem will not crop up again after sometime. I have tried a number of Android phones and problems continue with all of them. But they are all recognized on my Laptop. One thing is clear, there is no driver issue with any cell. It is some Windows file which is corrupted. Can some one help me in finding some solution other than re-formatting as it will create lot of problem in bringing my PC to shape one again after re-formatting.
      My Computer

  3. Posts : 3
    Windows 7 Ultimate x64, Windows 7 Home Premium 32bit

    If in fact Microsoft suggests that the conflict may be caused by one of their sometimes flaky updates AND if the phone is recognized by the other comp AND if both comps have the same operating system, see if you can compare the update history of both comps to see if the problem comp has an update that the good one doesn't. I know that might seem problematic but remember that both probably won't have the same hardware and while it could be time consuming at least you may be able to isolate a conflict with otherwise congruous hardware.

    While you haven't indicated how old your comps are, there is another tack to take with USB issues and that is if the problematic comp is a desktop there is a possibility that the power supply or the board is no longer delivering the appropriate levels of power to the physical ports, particularly if they are all plugged in and/or all the devices are trying to draw the maximum amount of power according to their individual specifications beyond what is available. As odd as that might sound, I have discovered over the years that if you aren't willing to try another power supply, sometimes switching to an external powered hub or turning off, say, the front USB ports in the bios and moving everything to the back or to a powered hub may allow a tired P.S. to deliver the necessary power to the remaining ports. Remember that if a controller decides it can't supply the appropriate power to any particular port in an internal hub it will shift the device to a root hub that requires less power which may actually inhibit the device. This is very common with security cameras and capture devices for instance. Could this condition be caused by an incompatible update or drivers too advanced for the ancient 8 year old basic Microsoft controller and root hub drivers? Why not? That is, whether they know it or not, why so many people have suggested that you try the anecdotal solution of switching physical ports.
    Last edited by gs20; 20 Nov 2014 at 18:31. Reason: spelling
      My Computer

  4. Posts : 1
    Windows 7 Home Premium 64bit

    Hey Pooch, I followed the tut exactly except for step 6 because it said "You need permission to perform this action" "You need permission from Administrators to make changes to this file" but i am an administrator on this laptop and the problem still occurs. and I looked at Take Ownership Shortcut but nothing happened.
      My Computer

  5. Posts : 1
    windows7 32 bit

    thanks its working
      My Computer

  6. Posts : 1
    Windows 7 64

    Bless You

    Thank you Thank you Thank you Thank you
    Thank you Thank you Thank you Thank you
    Thank you Thank you Thank you Thank you

    For solving my problem!!!

      My Computer

  7. Posts : 1
    Windows 7 Ultimate x86

    can not install


    I don't know what is happening to my Intel USB driver controller, I can not able to install in anyway...
    I delete and install them again but nothing installed and unsuccessful warning pups up everytime
    Last edited by Brink; 14 Jun 2016 at 09:54. Reason: removed broken images
      My Computer

  8. Posts : 678
    Windows 7 home premium 64 bit

    Came to this topic after a BSOD problem 'fix' (updating graphics driver) corrupted my USB drivers
    2 separate atikm?ag BSOD errors
    and more specific to the USB problem
    USB Ports Corrupted After Graphics Driver Update

    I followed all the steps, and now, not only do I still not have working USB ports, but now I've lost my network printer.

    It was only 2 Blue Screens - Why couldn't I have just left well enough alone?
    Last edited by derekimo; 08 Oct 2015 at 21:03.
      My Computer

  9. Posts : 1
    Windows 7 Home Premium

    Safe mode

    Manifa, I had to do all the deletions mentioned (ALL, not just the greyed/faded out ones) but in Safe Mode, otherwise it didn't work. Yes, it was straight after a Windows Update, something got tweaked wrongly.
      My Computer

  10. Posts : 2
    windows 10


    INFCACHE.1 doesnt show up for me..
    does that mean i dont have one?
    or i cant find it?

    plz help.
    i needto fix this quick!

    best regards
      My Computer

Page 7 of 8 FirstFirst ... 5678 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:18.
Find Us