Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Take Ownership Shortcut

20 Jan 2012   #210

64-bit Windows 10 Pro

Quote   Quote: Originally Posted by leftygt View Post
Hi Shawn

Thanks for your help.I tried unlocker, but its telling me there is no "unlocking handle"?
You might see if temporarily moving the contents back to the original location may allow you to then be able to un-share and delete it.

If not, then I would recommend to go ahead and post this issue in the Network & Sharing forum area to see what we may be able to do to help with there it since it's not related with this tutorial. This way you will get more specific help with it.

My System SpecsSystem Spec
18 Feb 2012   #211

Windows 7 Home Premium 32bit.

My System SpecsSystem Spec
21 Feb 2012   #212


Thanks... it worked... was trying for since million years... ( I think So) thanks again...
My System SpecsSystem Spec
23 Feb 2012   #213

Windows 7 Home Premium 64 bit

I had problems with iTunes showing the error message (-42404) part of iTunes not installed correctly etc.
I was advised to look at your posting re this problem - I downloaded the TAKE OWNERSHIP prog, followed your instructions and PROBLEM SOLVED.
Many, many thanks - Apple offered no such advice - I was tearing my hair out.
My System SpecsSystem Spec

08 Mar 2012   #214

windows7 ultimate x32
via cmd

 @echo off
reg query "HKU\S-1-5-19\Environment"
 cls & echo Schadenfreude..
 Pause & Exit

echo  Take Ownership:
reg delete "HKCR\*\shell\runas" /f
reg add "HKCR\*\shell\runas"         /ve                        /d "Take Ownership" /f
reg add "HKCR\*\shell\runas"         /v "HasLUAShield"          /d ""               /f
reg add "HKCR\*\shell\runas"         /v "NoWorkingDirectory"    /d ""               /f
reg add "HKCR\*\shell\runas"         /v "Position"              /d "middle"         /f
reg add "HKCR\*\shell\runas\command" /ve                        /d "cmd.exe /c takeown /f \"%%1\" && icacls \"%%1\" /grant *S-1-3-4:F /c /l & pause" /f
reg add "HKCR\*\shell\runas\command" /v "IsolatedCommand"       /d "cmd.exe /c takeown /f \"%%1\" && icacls \"%%1\" /grant *S-1-3-4:F /c /l & pause" /f
 reg delete "HKCR\Directory\shell\runas" /f
 reg add "HKCR\Directory\shell\runas"         /ve                     /d "Take Ownership" /f
 reg add "HKCR\Directory\shell\runas"         /v "AppliesTo"          /d "NOT (System.ItemPathDisplay:=\"C:\Users\" OR System.ItemPathDisplay:=\"C:\ProgramData\" OR System.ItemPathDisplay:=\"C:\Windows\" OR System.ItemPathDisplay:=\"C:\Windows\System32\" OR System.ItemPathDisplay:=\"C:\Program Files\" OR System.ItemPathDisplay:=\"C:\Program Files (x86)\")" /f
 reg add "HKCR\Directory\shell\runas"         /v "HasLUAShield"       /d ""       /f
 reg add "HKCR\Directory\shell\runas"         /v "NoWorkingDirectory" /d ""       /f
 reg add "HKCR\Directory\shell\runas"         /v "Position"           /d "middle" /f
 reg add "HKCR\Directory\shell\runas\command" /ve                     /d "cmd.exe /c takeown /f \"%%1\" /r /d y && icacls \"%%1\" /grant *S-1-3-4:F /t /c /l /q & pause" /f
 reg add "HKCR\Directory\shell\runas\command" /v "IsolatedCommand"    /d "cmd.exe /c takeown /f \"%%1\" /r /d y && icacls \"%%1\" /grant *S-1-3-4:F /t /c /l /q & pause" /f
reg delete "HKCR\dllfile\shell\runas" /f
reg add "HKCR\dllfile\shell\runas"         /ve                     /d "Take Ownership" /f
reg add "HKCR\dllfile\shell\runas"         /v "HasLUAShield"       /d ""               /f
reg add "HKCR\dllfile\shell\runas"         /v "NoWorkingDirectory" /d ""               /f
reg add "HKCR\dllfile\shell\runas"         /v "Position"           /d "middle"         /f
reg add "HKCR\dllfile\shell\runas\command" /ve                     /d "cmd.exe /c takeown /f \"%%1\" && icacls \"%%1\" /grant *S-1-3-4:F /c /l & pause" /f
reg add "HKCR\dllfile\shell\runas\command" /v "IsolatedCommand"    /d "cmd.exe /c takeown /f \"%%1\" && icacls \"%%1\" /grant *S-1-3-4:F /c /l & pause" /f
 reg delete "HKCR\Drive\shell\runas" /f
 reg add "HKCR\Drive\shell\runas"         /ve                     /d "Take Ownership" /f
 reg add "HKCR\Drive\shell\runas"         /v "AppliesTo"          /d "NOT C:"         /f
 reg add "HKCR\Drive\shell\runas"         /v "HasLUAShield"       /d ""               /f
 reg add "HKCR\Drive\shell\runas"         /v "NoWorkingDirectory" /d ""               /f
 reg add "HKCR\Drive\shell\runas"         /v "Position"           /d "middle"         /f
 reg add "HKCR\Drive\shell\runas\command" /ve                     /d "cmd.exe /c takeown /f \"%%1\" /r /d y && icacls \"%%1\" /grant *S-1-3-4:F /t /c /l /q & pause" /f
 reg add "HKCR\Drive\shell\runas\command" /v "IsolatedCommand"    /d "cmd.exe /c takeown /f \"%%1\" /r /d y && icacls \"%%1\" /grant *S-1-3-4:F /t /c /l /q & pause" /f
reg delete "HKCR\exefile\shell\runas" /f
reg add "HKCR\exefile\shell\runas"         /v "HasLUAShield"    /d ""            /f
reg add "HKCR\exefile\shell\runas\command" /ve                  /d "\"%%1\" %%*" /f
reg add "HKCR\exefile\shell\runas\command" /v "IsolatedCommand" /d "\"%%1\" %%*" /f
:: or "/grant administrators:F" instead "/grant *S-1-3-4:F"

pause & exit
My System SpecsSystem Spec
10 Mar 2012   #215

Windows 7 Professional X64

This is truly wonderful.

For a while I was dual booting windows but the "older" version of Windows 7 was no longer needed.

Getting rid of the disk space was nearly impossible until I found this.

My System SpecsSystem Spec
28 Apr 2012   #216

Win 7

Hey guys, any idea where the reg file / install is and how one may go about altering the value for the maximum number of folders to perform Take Ownership on at once? I know your can just do a whole drive and wait that way, but its just a bunch of cmd operations, shouldn't be capped like that :/
My System SpecsSystem Spec
28 Apr 2012   #217

64-bit Windows 10 Pro

Hello Jobo, and welcome to Seven Forums.

That would be the 15 selected limit that's universal in Windows 7. You can use the tutorial below to set this to be unlimited instead.

Context Menu Items Missing - Fix when more than 15 Files are Selected

Hope this helps,
My System SpecsSystem Spec
01 May 2012   #218

Win 7

Shawn, thats perfect... too easy

My System SpecsSystem Spec
01 May 2012   #219

64-bit Windows 10 Pro

You're most welcome Jobo.
My System SpecsSystem Spec

 Take Ownership Shortcut

Thread Tools

Similar help and support threads
Thread Forum
Custom 'Desktop (create shortcut)' Remove .fileextension - Shortcut
Hi guys n girls, I have for ever got sick and tired of right click -> open Send to Menu and creating a Desktop Shortcut for a file or app....then needing to go to the Desktop right click the newly made shortcut and then removing the trailing file extension, dash and words shortcut in brackets....
Creating a shortcut without - shortcut written after the original name
as the titel declares, is there any patch or something to make Windows 7 shortcuts not rename theirselves to "application.exe - shortcut" but rename theirselves into just "application.exe"? I find it very annoying having to erase " - shortcut" from the name all the time.
General Discussion
Ownership for XP
Dear helpers ,, i am using windows XP and previously i was using win7 it was not properly supported on my pc , i had forbidden some folders for users other than Administrator, how can i get ownership of those folders on XP , i have tried the "Take_Ownership.reg" and followed the procedure it just...
Chillout Room
ownership and uac
I have my UAC all the way down and cannot figure how to take ownership of folders. I have a windows.old and a windows.old.000 and I want to delete one of them. Thanks!
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App