Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Take Ownership Shortcut

20 Feb 2014   #270

Windows 7 Professional 64-bit

Help! I tried your Take Ownership shortcut, but now the file on which I used it has vanished.

I was trying to use the hard drive from my old computer as an external, but had trouble accessing the Programs and Settings folder. When I tried to open it, I was told I didn't have access. Right clicking and changing the access in the Security tab under Properties didn't help. So I used the Take Ownership shortcut on that folder. It did its thing on the DOS screen. Then when I tried to double-click and open the Documents and Settings folder, it froze up and I got a Not Responding message. I closed the program and restarted the computer. When I went back to the external hard drive, the Documents and Settings folder had disappeared. What happened? How do I get it back?

My System SpecsSystem Spec
20 Feb 2014   #271

64-bit Windows 10 Pro

Hello Chillicon, and welcome to Seven Forums.

The Take Ownership context menu only changes the owner to your account, and sets the Administrators group to have "Full control". It cannot and doesn't delete anything.

The "Documents and Settings" folder is not actually a folder, but only a junction point for backwards compatibility for older programs created for say XP. You will not be able to open a junction point such as this since it's not a folder. You do not want to mess with the permissions of junction points.

Check using step 4 in OPTION ONE of the tutorial below to see if you have hidden OS files set to show.

Hidden Files and Folders - Show or Hide

Hope this helps,
My System SpecsSystem Spec
27 Apr 2014   #272

64-bit Windows 10 Pro

Tutorial updated with more options.
My System SpecsSystem Spec
28 Apr 2014   #273

Vista/Win7/Win8/Win10 (x86/x64)

Quote   Quote: Originally Posted by Brink View Post
Tutorial updated with more options.
Nice Job Shawn, Thanks
My System SpecsSystem Spec

28 Apr 2014   #274

64-bit Windows 10 Pro

You're most welcome.
My System SpecsSystem Spec
03 May 2014   #275

Win7 Ultimate 64bit

I tried #4. It doesn't do the job. I had XP Pro 32 bit on a computer. Then I installed Win 7 Ultimate x64 on a different drive then deleted the old XP Windows, Documents and Settings and Program Files folders, and all files in the root of the old C: drive, which is now D:

The problem is there are many files created with the old XP which programs on 7 can open but are completely blocked from being able to re-save. A *copy* can be saved, usually have to save to a different folder because write access to the old folder is also blocked. BUT that new file can be moved into the old folder and overwrite the old file - from then on that file can be used normally on Windows 7 - even though other files in the folder can be opened but not written to.

It's like a bank where a teller won't allow you to withdraw your money, and on the vault door there's a sign that says "Absolutely No Admittance. Lock Broken. Press Button to Open Vault.". Security? What security? The front door is locked but there's a back door with a sign that says turn the knob and come in, and once you're inside, the front door unlocks. It doesn't do anything except annoy the user.

Another problem in these old folders is on the New right click menu, only New Folder is available. If I make a new folder and go into it, everything on the New menu is available.

What can I do to go through an entire drive and force out all the old XP file settings that Windows 7 is having problems with?
My System SpecsSystem Spec
03 May 2014   #276

64-bit Windows 10 Pro

Hello Galane,

If you like, temporarily copy what you want from the old XP drive to another location, format the XP drive to gain full NTFS permissions for it again, then copy the files back.

The New Folder issue is normal for system folders since they are protected.
My System SpecsSystem Spec
24 Sep 2014   #277

Windows 7

Brink can you please help me, I did step 3 and downloaded "To Add "Take Ownership" to Context Menu including EXE Files" and I cannot remove it. I deleted the file that I downloaded, even from the recycling bin, but "Take Ownership" still shows up instead of "Run as Administrator." The main problem I'm facing with this is, I cannot run any programs or do any actions that require admin rights. For example, I cannot see the "resource monitor", nor could I even try a system recovery, because that required admin rights too. What usually happens is, after I click run as admin for these things, the command prompt (the black sceen thing) opens up quickly and in like half a second closes and nothing happens. I'm pretty sure anything that requires admin rights I cannot do. Please help, I really want to fix this.
My System SpecsSystem Spec
24 Sep 2014   #278

64-bit Windows 10 Pro

Hello Skilledspellz, and welcome to Seven Forums.

You can download and merge the .reg file from step 6 to restore your default settings to have .exe work again.

Afterwards, you could use step 2 or 3 instead without affecting .exe files if you like.
My System SpecsSystem Spec
24 Sep 2014   #279

Windows 7

I'm sorry, I should've read the initial post completely.. thank you so much for the help.
My System SpecsSystem Spec

 Take Ownership Shortcut

Thread Tools

Similar help and support threads
Thread Forum
Custom 'Desktop (create shortcut)' Remove .fileextension - Shortcut
Hi guys n girls, I have for ever got sick and tired of right click -> open Send to Menu and creating a Desktop Shortcut for a file or app....then needing to go to the Desktop right click the newly made shortcut and then removing the trailing file extension, dash and words shortcut in brackets....
Creating a shortcut without - shortcut written after the original name
as the titel declares, is there any patch or something to make Windows 7 shortcuts not rename theirselves to "application.exe - shortcut" but rename theirselves into just "application.exe"? I find it very annoying having to erase " - shortcut" from the name all the time.
General Discussion
Ownership for XP
Dear helpers ,, i am using windows XP and previously i was using win7 it was not properly supported on my pc , i had forbidden some folders for users other than Administrator, how can i get ownership of those folders on XP , i have tried the "Take_Ownership.reg" and followed the procedure it just...
Chillout Room
Cannot take ownership
Hi,im having a problem taking ownership of any of the windows files after a fresh reinstall. It says i have taken ownership (using the command promt in elevated command method + trying to use the right click Take Ownership) but does not allow me to edit any of the files within the windows folder....
BSOD Help and Support
ownership and uac
I have my UAC all the way down and cannot figure how to take ownership of folders. I have a windows.old and a windows.old.000 and I want to delete one of them. Thanks!
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App