Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sounds - Change

26 Oct 2011   #20
xsile

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Brink View Post
Hello xsile,

If you mean the startup sound, then the tutorial below can help show you how to.

Startup Sound - Change in Windows 7

That is awesome! Thank you! Is exactly what I wanted to know.


My System SpecsSystem Spec
.
26 Oct 2011   #21
Brink

64-bit Windows 10 Pro
 
 

You're most welcome xsile.
My System SpecsSystem Spec
27 Jun 2013   #22
Legbiter

Windows 7 Home Premium 64bit
 
 
Start-Up Jingle (Kill it please, Kill it now)

No Sounds is your sound scheme Right, but Win 7 thinks you don't really mean it and Still taunts you with the pre-schooler's Start-Up jingle.

**** Un-Check "Play Windows Startup Sound" near the bottom of the Sound Scheme selection window.

I missed it.
Sanity suffered. I'm better now though, thanks.

twitch twitch blink.blink yeoOOOOOwwlLLLL
My System SpecsSystem Spec
27 Mar 2014   #23
dawnrenee88

windows 8 32
 
 
Making my own Japanese Theme

I am using a iconset from iconarchive called yoritsuki icons by hybridworks (35 Icons) I really love the japanese wallpapers that came with it. All I needed to do to fix to wallpaper problem was make a folder for both wallpapers in 1 folder and then open the folder in the theme section. Kind of a simple fix.

The hard part was understanding that I could make a separate folder for the actual sounds. I did not want to change the actual windows sounds I wanted to make a secondary folder for the new theme not have to delete or change the original sounds in case I wanted to convert back sometime.

So this post really helped me out. Thanks for writing it. By the way I plced a link to the actual icon set I used so others can find them as well. They are free and I get nothing out of just dropping a link.
My System SpecsSystem Spec
.

22 Jun 2014   #24
MourningStar

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Great tutorial, thank you. As I scan through the events that one may assign a sound to, I notice that 'delete' is missing. There may be others. How do I add this event (and others) to the list in order to assign a sound?
My System SpecsSystem Spec
22 Jun 2014   #25
Brink

64-bit Windows 10 Pro
 
 

Hey Marc,

I don't see a "Delete" event there by default.

I'm not sure that you can add anything other than restore any missing default events from the registry.
My System SpecsSystem Spec
26 May 2016   #26
treeman46

Windows 7 Ultimate 64-bit SP1
 
 
Moving Sound Schemes to Another Computer

Just wanted to say a quick thanks! I have always wanted to know how to move\save the sound schemes.
My System SpecsSystem Spec
26 May 2016   #27
Brink

64-bit Windows 10 Pro
 
 

I'm glad it could help treeman, and welcome to Seven Forums.
My System SpecsSystem Spec
15 Oct 2017   #28
schmibble

7 Pro x64 (desktop), 7 Ultimate x86 (laptop)
 
 
Still No Way To Transfer Schemes (Dwarf's Way Doesn't Work)

Preliminary Item:
Quote:
[HKEY_CLASSES_ROOT\Local Settings\MuiCache\290\52C64B7E]
"@mmres.dll,-8XX"="<SoundSchemeName>"
[HKEY_CURRENT_USER\Software\Classes\Local Settings\MuiCache\290\52C64B7E]
"@mmres.dll,-8XX"="<SoundSchemeName>"
Here, Dwarf's HKCR line is redundant (in the regedit code he provided above). It's merely a mirror of the accompanying HKCU key. Just include the HKCU key and you take care of the mirrored HKCR key automatically. (I confirmed this by running the HKCU key alone and then checking to see if it was also showing up in HKCR. Yes, it was.)


Main Item:

I notice that nobody else has reported concerning Dwarf's regedit method of making a scheme, so here's my report--of failure. I didn't export a scheme made in the Control Panel applet because I figured that if these are all the necessary keys, and they're supposed to work for placing your scheme on a different machine, then they also ought to work if you just write up a scheme yourself in the registry file. After all, your machine's not going to be able to tell that it wasn't exported from some other machine, right? At least not if these are all the required keys.

But this was a resounding flop, at least on my Win7 Pro. I saved my sounds in their theme-named folder ("CalligMod") in C:\Windows\Media. Then I spent over an hour on the registry code, checking everything, making sure I didn't have any glitches, even verifying that for 8XX on my system, 23 was indeed the next number in line. After I ran the registry merge, a look with the excellent freeware utility Registry Finder revealed that all the keys went where they were supposed to go. (Registry Finder is much better than Regedit. Search for it on DuckDuckGo--you won't be sorry.)

But all to no avail. I go to the Control Panel Personalizations/Sound applet and my new scheme is nowhere to be found. And that does not bode well for porting one's scheme to a new system, because if these are all the necessary registry entries, then we're hosed. As far as I can see, there's nothing in any of Dwarf's keys that would let Windows know whether this code was exported from the Sound applet or whether it was written from scratch. So if these are all the required keys, Windows should accept them. But it doesn't. Therefore, even if you create a scheme via the applet, if all you do is export the keys Dward has designated, it's almost certainly not going to work when you try to import your scheme onto another machine.

There is the off chance, of course, that it's just my system. My Win7 Pro is not a straight-up Win7 Pro, rather it's an upgrade from Win7 Home Premium. And there are some tutorials here on SevenForums (e.g. Windows 7 Installation - Transfer to a New Computer - Windows 7 Help Forums) which can only be implemented on systems that are not upgrades. So that might be coming into play here. One difference--hard to say how important--was that on my system I do not have key HKEY_CURRENT_USER\Software\Classes\Local Settings\MuiCache\290\52C64B7E which Dwarf furnishes in his posts. Instead, I have HKEY_CURRENT_USER\Software\Classes\Local Settings\MuiCache\84\52C64B7E. However, my 84 key does have the list of @mmres.dll,-8XX values, so I have to assume that it's the right key for my system. After the failure of my first attempt, I reversed all the changes, started over with a clean registry, and used the 290 key instead. Of course, this created a key with just a single value and separate from all the other @mmres.dll,-8XX values, at least on my system. But you never know whether something will work until you try. Still didn't matter, though.

So the exercise was completely abortive. Setting aside the possibility that there's something weird about my system that won't affect other users, which is possible but unlikely, I suspect that the sound applet might be doing a complete end-run around the registry, merely furnishing a desultory mirror of its actions to the registry. In other words, it's a one-way street: the sound applet makes changes to the registry, but those registry entries are merely cosmetic; unlike some other applets and their related regkeys, these don't reciprocate by reflecting back to the sound applet. At least not the keys Dwarf focused on. True, the .Current subkeys used in Brink's actual tutorial do work, but they don't create a scheme, which is our focus right now. It may be that the sound applet has a deeper relationship with some buried CLSIDs or something, but that takes us into territory beyond my capacities. At any rate, until someone can prove otherwise, we have to assume that Dwarf's keys are insufficient to get the job done, and therefore we continue to lack a method of transferring a sound scheme from one machine to another.

In case anyone wants to take a gander at my code, check it out below. It's possible I missed something, but I don't think so. (And yes, I am pretty minimalist when it comes to sounds--lots of empty slots in my config. Also lots of switching sounds around from the events MS thinks fitting: that's the whole point of the attempt.)

Code:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\.Default\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Ding.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ChangeTheme\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\Critical Battery Alarm\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\DeviceConnect\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Hardware Insert.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\DeviceDisconnect\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Hardware Remove.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\DeviceFail\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Hardware Fail.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\FaxBeep\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\LowBatteryAlarm\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\MailBeep\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\PrintComplete\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\SystemAsterisk\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Print complete.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\SystemExclamation\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Feed Discovered.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\SystemExit\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Shutdown.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\SystemHand\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Critical Stop.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\SystemNotification\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Balloon.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\WindowsLogoff\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\WindowsLogon\CalligMod]
@=@="C:\\Windows\\Media\\CalligMod\\Windows Logon Sound.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\WindowsUAC\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows User Account Control.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\BlockedPopup\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Pop""up Blocked.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\EmptyRecycleBin\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Battery Low.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\FaxError\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\FaxLineRings\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\FaxSent\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\FeedDiscovered\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\CalligMod]
@="C:\\Windows\\Media\\CalligMod\\Windows Navigation Start.wav"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\SecurityBand\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\DisNumbers\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\HubOffSound\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\HubOnSound\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\HubSleepSound\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\MisrecoSound\CalligMod]
@=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\sapisvr\PanelSound\CalligMod]
@=""

[HKEY_CURRENT_USER\AppEvents\Schemes\Names\CalligMod]
@="@=mmres.dll,-823"

[HKEY_CURRENT_USER\Software\Classes\Local Settings\MuiCache\84\52C64B7E]
"@mmres.dll,-823"="CalligMod"
My System SpecsSystem Spec
Reply

 Sounds - Change




Thread Tools




Similar help and support threads
Thread Forum
No Windows Sounds, but regular sounds play fine
Ok so I have a simple, but annoying problem. I have no Windows Sound Events like the login sound, the logout sound, and when the battery is low. Every other sound like playing music and running YouTube videos work fine. Even when I turn on my laptop I hear the whole computer startup sound, but I...
Sound & Audio
Change windows 7 logon+off sounds
Hi, I am desperately trying to change windows 7 logon and logoff sounds on my daughter's laptop. I have followed different instructions via control panel and it doesn't take place! What is the easiest, simplest way to do this please as am getting really frustrated, and really do not want...
Sound & Audio
How To Prevent Theme Change from Activating Windows Sounds
I prefer to have Window sounds turned off. I have several themes and rotate them frequently. Each time I change the theme the sounds (Windows default) get turned back on and I am always having to go into the Windows Sounds dialogue to turn them off (no sounds). Is there something I can do so that...
Themes and Styles
I Need help with 7 sounds
Hey, My Click noise is deactivated and i cant find how to activate it again anyone help? Thanks Jack,
Sound & Audio
Save Sounds With Theme File - Change Icon Font Color?
Hi - I'm trying to save a theme and a sound scheme associated with it. I can save all the theme elements but the sound scheme doesn't save with it. I know that my sound is working because I do hear sound from the computer speakers. Any ideas? Also, I was wondering if it is possible to change...
Themes and Styles
Can't access or change System Sounds?
I have an MSI 890GXM motherboard with the Realtek HD Audio onboard, installed all of the latest drivers ... and I have sound, it works great ... but I can't change the "System Sounds" at all. For example when I go into "Personalization" from the desktop, and click on "Sounds" to change it,...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App