Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SeaTools for DOS and Windows - How to Use

27 Apr 2016   #60

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

I successful repair will give you enough time to copy the data and replace the disk. :) I would suggest you that if that disk is containing any data that is valuable to you then back it up. It may fail again.

If you plan to wipe the disk entirely and redo the partitions etc, then Partition Wizard will be your tool to do it.

My System SpecsSystem Spec
08 Jun 2016   #61

win 8.1

Hello, not sure if this forum still active but here is my exp so far.

I have to use sea tools dos and was able to start a long scan thx to all the pervious info from this forum.
Currently is scanning a 1TB drive which has lot of bad LBAs, I noticed the long test will only fix 99 errors at a time.
Once is repaired it will replied with passed after fix. But I'll have to start the long test again and it will pick up a new sets of 99 bad LBAs to fix. This cont. on for a while.... which is very time consuming coz you have to start from scratch after it fixed 99 bad sectors. Have anyone seen this behaviour? I was hoping for the "fix all long test" but I dont see it avil on the dos 2..23 version.
My System SpecsSystem Spec
08 Jun 2016   #62
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

If it was my computer I would save all my needed or wanted data to a external drive and replace the problem drive in question.
If you keep testing the problem drive you might not be able to retrieve the data.
My System SpecsSystem Spec
27 Jun 2016   #63

Win 10 64 bit

Hi everyone found this by chance hope some one can help me
I am having the same problem as guyver99 I keep on getting blocks of 99 repairs to be done by seatools. Do I keep on re running the long test until it clears all the disk errors?
I am having trouble booting up windows so cannot access any files to back up, I would like to be able to boot up so I can back up and then replace the Hard Drive with a new one.
My System SpecsSystem Spec

27 Jun 2016   #64

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Seatools attempts for a repair, but in the real world experience a repaired bad sector is not well functional.
Let the process take its time. If the bad sectors are really repaired and the disk boots back, then you can access your data as usual.

The time taken to repair the bad sectors may be long enough; after that long time it may report a success or a failure.
Even if it is a success, run short test once again to verify that report.

Even if seatools reports a success, prepare to back up your data and shift to another disk.
If seatools fails to repair the disk, try to recover the data using this method: Emergency Kit - save your files from a dead OS
My System SpecsSystem Spec
05 Jul 2016   #65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
Booting from USB thumb drive problem

I followed you fantastic tutorial and decided to create SeaToolsDOS on a USB thumb drive as I have been having problems ejecting dvd while in System Repair (which is also why I could not use the System Images I created...I couldn't get the Installation DVD to eject so I could insert them!). Everything appeared to have burned properly using the Win32DiskImager so I adjusted the Boot order, inserted the USB drive and restarted.

Instead of booting to the GUI for SeaTools I am at a blank screen other than FreeDOS is in the upper left corner followed by a blinking cursor.

Nothing will get me out of this screen. I cannot type anything nor can I Escape.

What should I do now?

*UPDATE: Not sure what the problem was with the USB option but I created the program on a DVD adn it booted in to the GUI perfectly, found no errors after running the Long Test and the Short DST. I am very grateful that my hard drive appears to be fine so that I can use it as a backup drive after upgrading to an SSD but now I need to figure out what the problem really is...I was certain it was hard drive failure!
My System SpecsSystem Spec
06 Jul 2016   #66

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

To boot from a USB device, you may need to disable Fast Boot and UEFI Secure Boot in the BIOS/UEFI Firmware Setup; if those are enabled.

For a Sony VAIO, you may also need to enable "External Drive Boot" in "Advanced" field of the BIOS/UEFI Firmware Setup.
Then Either Esc, or F10 or F11 (depending on the build; usually disclosed in the POST screen) will let you access to the Boot Menu. The USB device will be listed there. Select it to boot from it.

If you are not having the disk issue, very good news. Please make a thread in a suitable area of the forum relating to your issue; some of your fellow members will be able to assist you.
My System SpecsSystem Spec
01 Sep 2016   #67

Windows 7 Professional x64

I'm having a slight problem following along, as when I try to set the storage controller mode to IDE/SATA in order to run SeaTools, the only other available option is RAID.

Attached Thumbnails
SeaTools for DOS and Windows - How to Use-bios.jpg  
My System SpecsSystem Spec
02 Feb 2018   #68

Microsoft Windows10 Professional 64-bit Build 16299

I know this is an old thread, but I hope someone else slogging through here with the same issue may find this helpful.

My first question would have been "Have you tried ignoring the "wrong" AHCI setting?

I am running Sea Tools for Dos right now (second attempt) on an older Dell laptop that did have an AHCI/ATA setting, BUT... while I was poking at it, I got to thinking about my wife's new (1 month old) Lenovo laptop, which I know has no such setting, and wondered how I would boot up this DVD if I ever had to.

It turned out I didn't have to make any changes to the Lenovo's BIOS. Although It was set for AHCI, It somehow figured out that it had legacy disk and handled it properly. I do believe I ended up hitting F11/F12 alternately quickly at the start to get its attention and pick the CD/DVD drive, but then it booted, and recognized the internal disk.

I'm beginning to think the new BIOS setups are not giving fewer choice just to be cheap. It might be because they are smart enough to figure stuff out that we used to have to set by hand.
... or maybe I'm just an optimist.

My System SpecsSystem Spec
18 Aug 2018   #69

Windows 8.1

I was instructed to do this over on the Eight forum due to system crashes. I've followed along everything and set the storage controller mode to IDE (it's under Compatible, but it says that'll set it to IDE?) but it doesn't work, it just takes me to Windows.
My System SpecsSystem Spec

 SeaTools for DOS and Windows - How to Use

Thread Tools

Similar help and support threads
Thread Forum
Repeated BSOD on Seatools scan
Hi I have been getting the attached BSOD almost daily recently. I tried to run a scan with Seatools (Long Generic) but I get the BSOD each time i try. I'm guessing its a hard drive fault. Any help would be greatly appreciated t Here is a copy of Hard Drive Information from Seatools. Stuart
BSOD Help and Support
Problems after running SeaTools
Hi all :) This started after I ran SeaTools for Windows, Long generic test..which passed but I'm having few issues ever since: I usually turn off my computer before going to bed, but the morning after I took the test when I powered up my computer it started with this hearable vibration. I...
Hardware & Devices
Seatools DST issue
hey folks whats up? out of curiosity i checked my HDD for errors. so, i downloaded seatools for windows. ran it and it showed the DST failed. the bar never came. it just failed. the rest ran fine. then i downloaded the seatools for dos. ran it all the test and all went fine. DST passed. now what...
Hardware & Devices
seatools test failed, could that be why not responding issues?
I am helping a friend with her PC. she has been getting not responding problems for a few years. I do minor tweaks every once and awhile,which help but never solve the problem. She finally gave me her PC to spend a few days with it and a 14 hour memtest came out clean, but seatoools short test...
Hardware & Devices
Problems checking HDD with SeaTools
Two parts to this question: (1) I installed a new 1TB Seagate Baraccuda 7200.12 Installation seems fine. SeaTools (ver and ver 1.2.04) won't detect the internal drive but detects external usb drives ok. Can you suggest why? (2) My two Seagate 500GB, 1TB externals record disk temps...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:35.
Twitter Facebook