Memory Diagnostics Tool

Page 4 of 5 FirstFirst ... 2345 LastLast

  1. Posts : 71,559
    64-bit Windows 10 Pro
    Thread Starter
       #30

    You're welcome. :)
      My Computer


  2. Posts : 1
    win7 home premium 64bit
       #31

    memory diagnostic tool looping


    I did an internet search to get here and have the same problem that thumper started this thread with. I've tried all the things he tried as well except when you pull memory, bios won't let the system start hardware 101. I haven't tried this yet from another poster from somewhere else because I only have a restore disk that's not pulling up a repair page. From command prompt, he says "bcdedit /bootsequence {memdiag} /remove" Now is there a way to get to repair with f8 f7 not working due to memory test starting before f8 can be initiated?

    Update: I downloaded a repair disk from Microsoft, and through a dozen attempts at booting to it, due to the memory test starting so quickly, I finally got the repair disk to boot and was able to repair boot, and system, as boot didn't seem to have any affect. It was VERY difficult to boot to repair disk though. It took many tries to hit it just right. Hitting F8 over and over and over.
    Last edited by mcbreeden; 06 Jan 2012 at 15:11.
      My Computer


  3. Posts : 71,559
    64-bit Windows 10 Pro
    Thread Starter
       #32

    Hello McBreeden, and welcome to Seven Forums.

    You could try opening a command prompt at boot using a Windows 7 system repair disc or any retail installation disc for this.

    Hope this helps,
    Shawn
      My Computer


  4. Posts : 54
    Windows 7 Ultimate x64
       #33

    Well, I did step 1, arrived at step 4, after a few minutes my monitor went into standby mode. After 15 minutes there was quite some disc activity but actually nothing showed up on my monitor, after another 15-20 minutes (with hardly any activity) I restarted the pc. Assume that it won't take more than half an hour, else Microsoft should warn users that it may take a long time.
      My Computer


  5. Posts : 355
    Windows 7 Professional SP1 64bit, Manjaro Xfce, Debian 10 64bit Xfce
       #34

    Wow, this test takes forever. Just added another 32GB to my PC and wanted to check it, but this test is kind of ridiculously long. They should have said "This might take several hours."

    It's been about 3 hours now on the first and only pass, and holding at 21% complete for maybe a couple hours or so. No problems detected yet. I am having it do the extended version of the test though.

    Is this typical?
      My Computer


  6. Posts : 71,559
    64-bit Windows 10 Pro
    Thread Starter
       #35

    Hello Wrend,

    Yes, this is normal. The more passes you set to run, the longer it is takes as well.
      My Computer


  7. Posts : 355
    Windows 7 Professional SP1 64bit, Manjaro Xfce, Debian 10 64bit Xfce
       #36

    Thanks.

    It's still at 21%, and has now been there for almost 20 hours. I did have it run the extended test, and I have 64GB of RAM, so maybe that is making it take so long.

    I want it to finish almost on principle at this point, but if it doesn't finish today, I'll have to stop it to get back to crunching and hosting a Minecraft server. Some of my players wanted to play yesterday and last night.
      My Computer


  8. Posts : 71,559
    64-bit Windows 10 Pro
    Thread Starter
       #37

    Oh my. Yeah, that could take a long time.
      My Computer


  9. Posts : 5
    X32, V64, S64, E64
       #38

    Greetings Brink. Thanks for the years of super-detailed information. Your time is appreciated.

    Another way to access the memory diagnostic tool, was to keep tapping the "F1" key just before booting to a Windows 7 DVD. That would bring up the following display...


    At that point, you could press "Tab" key and then hit "Enter" after the Windows Memory Diagnostic option is highlighted. (note: the GUI option to reboot into the diagnostic is designed to work with on-drive recovery and won't work with boot-dvd recovery)

    Bad memory often will not allow you to load into a full-blown operating system, whether via optical disk, flash drive, hard drive or otherwise. I've had systems where Windows PE would not load from DVD, (both DVD & optical drive good,) but would load and run the memory diagnostic tool; and it would flag a fault.

    What's curious, the "F1" key doesn't seem to work with the Windows 8.1 (and assume Windows 8) DVDs.

    Question, did Microsoft change or eliminate this option with the Windows 8 or 8.1 boot DVDs ?

    Haven't been able to get a search engine hit on this.

    Thanks Brink.
      My Computer


  10. Posts : 71,559
    64-bit Windows 10 Pro
    Thread Starter
       #39

    Hello Intuit,

    That would be about the same as step 2, but with F1 at boot instead. I'm not sure if F1 is the same on all PCs though.

    You're supposed to be able to press Shift+F8 instead in Windows 8/8.1, but there's so little time available to do so, it's just about impossible to do. You could also disable the new GUI in Windows 8/8.1 to have the old menu again if you like. :)

    Startup Options - Enable or Disable in Windows 8
      My Computer


 
Page 4 of 5 FirstFirst ... 2345 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:38.
Find Us