Windows 7 Federated Search Providers

Page 2 of 4 FirstFirst 1234 LastLast

  1. Posts : 2
    Windows Vista SP1
       #10

    Fixed it!


    Got Windows 7 beta and fixed my Twitter Search provider.

    Here's a screenshot:


    Here's the more info link:
    Twitter Search at Aalaap.com

    Here's the download link:
    http://aalaap.com/downloads/TwitterSearch.osdx

    Let me know if this works for you!

    - Aalaap
      My Computer


  2. Posts : 2
    Windows 7
       #11

    I created a simple search connector using the base provided. It's used to search the MSDN documentation.

    Hopefully someone else will find this useful.

    Download Link
    Last edited by dmex; 05 Feb 2009 at 03:54.
      My Computer


  3. Posts : 19
    Windows 7
       #12

    Today we posted the Federated Search Implementer's guide - if you're interested in building a Search Connector or an OpenSearch web service, check it out!

    http://www.microsoft.com/downloads/details.aspx?familyid=c709a596-a9e9-49e7-bcd4-319664929317&displaylang=en&tm
      My Computer


  4. Posts : 4
    Windows 7 SP1
       #13

    Has anyone created a search connector for GMail? Is this possible, with the sample script in this thread?

    Having search access to Gmail via Windows Desktop Search would be excellent!!!
      My Computer


  5. Posts : 4,925
    Windows 7 Professional 64-bit
       #14

    Wow! Never knew this feature existed! Wonder what we'l learn next.
      My Computer


  6. Posts : 1,289
    Thread Starter
       #15

    VideoSavant said:
    Has anyone created a search connector for GMail? Is this possible, with the sample script in this thread?

    Having search access to Gmail via Windows Desktop Search would be excellent!!!
    Yes, I have two different methods for allowing Gmail access via Federated Search however Im waiting for Brandon to implement changes with their PreviewHandler instance so I can replace the default locked-down previewer with a less-restricted, more functional Previewer that allows the required page scripting for gmail so users can see/preview the selected e-mail, My component also allows Flash for previewing YouTube searches and also allows Flash to be used by 64bit process's

    This is a quote from Brandon in an e-mail exchange we had two months ago:
    it's been a busy week and I've actually been working with my PMs and our architect to work out the details of how to handle the OpenSearch previewer registration. We found a couple issues with the mechanism in the current post-beta builds. To solve them we have two options on the table right now, so I can't give specifics until that decision is made, but rest assured this will be easier in the final release build than in the beta.
    Brandon said he would contact me when he had some information available but it seems there's nothing new just yet...I have to wait until I have some more information to continue working on the project so your just going to have to wait too If anyone's interested in investigating/branching the Flash x64 project or has experience with C# or COM then drop me a line


    Steven
      My Computer


  7. Posts : 4
    Windows 7 SP1
       #16

    dmex,

    Thanks for the reply and the explanation. As I'm thinking more about this federated search concept, one thing I'm not clear on is how the search actually works.

    Does the federated search lead to GMail (or other external sources) being included in the real-time index of content. It seems like it would need to in order to be really useful. If I'm searching for a client name, I really want to receive all the content relevant to that search, whether it's from a Word or Excel document on my hard drive or a series of Gmails sent to that client over the past 5 years.

    Hope that's not a dumb question. Otherwise, I'm happy to wait until you've got something worked out with the new, desired method. Thanks again.
      My Computer


  8. Posts : 3,141
    Vista Ult 64 bit Seven Ult RTM x64
       #17

    Lately my Seven forums search hasn't been working. No results found even for very common keywords. Technet still works so don't think it has anything to do with the function here. I've tried cutting and pasting the code into notepad, reinstalling and I then get results, but they all have this content blocked. Have played with security settings to try to get it working, but no joy.

    Windows 7 Federated Search Providers-fed.png

    Same thing happens when I create a Vistax64 search.

    Any idea what I'm doing wrong or what setting I need to change. Using Firefox if that matters.

    Gary
      My Computer


  9. Posts : 1,289
    Thread Starter
       #18

    garysgold said:
    Lately my Seven forums search hasn't been working. No results found even for very common keywords. Technet still works so don't think it has anything to do with the function here. I've tried cutting and pasting the code into notepad, reinstalling and I then get results, but they all have this content blocked. Have played with security settings to try to get it working, but no joy.

    Windows 7 Federated Search Providers-fed.png

    Same thing happens when I create a Vistax64 search.

    Any idea what I'm doing wrong or what setting I need to change. Using Firefox if that matters.

    Gary

    Wow, Ive never seen that happen

    Federated Search inherits and uses IE's Restricted Zone security settings, Either something has corrupted IE or the Restricted Zone settings are too high, Try resetting the Restricted Security Zone settings in IE and adding https://www.sevenforums.com/* into the Trusted Site list and see if anything changes

    If your still getting the "blocked" results after trying the above, try lowering every setting you can find in the Restricted Zone to see if it makes any difference, You can reset the zone settings to defaults after

    Let me know if you have any success.

    Steven
      My Computer


  10. Posts : 3,141
    Vista Ult 64 bit Seven Ult RTM x64
       #19

    Hi Steven,

    I have set everything to enabled in the restricted zone, seven and vistax64 were already in the trusted zone even did a complete reset of IE and then enabled everything in the restricted zone with a reboot. No joy. This is very odd as it was working, at least for sevenforums, before installing the RC. This is the first time I've tried it at sevenforums since installing the RC. The other oddity is that it works fine for technet and bing. Bing is not in the trusted zone and technet is. Since you haven't seen it then it must still be working for you, which makes it even more perplexing.

    Gary

    Update:I have 7201 installed on another partition with only Avast installed. Added the sevenforums search that you have all done up and it didn't work at all, as in 7100. Added sevenforums with my cut and paste version in 7201 and it works fine.

    I wasn't going to set 7201 all up, but I guess I will start doing tweaks and installing programs trying the federated search after each change to see if I can break it there unless you have some other idea.

    Gary
      My Computer


 
Page 2 of 4 FirstFirst 1234 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:10.
Find Us