Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Virtual Disk Service keeps hanging

24 Sep 2010   #1

Windows 7 32bit 7077
Virtual Disk Service keeps hanging


First of all, while this subject is most definitely connected with virtualization, it is merely the first step to it. To top it all off, I can bypass this problem by using Safe Mode (read on for details), but I would really like to get this fixed. If I placed this thread in the wrong section, then I apologize sincerely, and I would be grateful if a kind moderator could move this elsewhere.

I'm having some issues with the Virtual Disk service in Windows 7. I'm attempting to do something quite simple, which is creating a VHS drive (NTFS formatted).
The creation procedure works fine if I try to create a FAT or FAT32 image, but hangs on the formatting stage if I try to create an NTFS image. If I use quick format, it will hang right then and there, if I don't use quick format, then the nice window will count from 0 to 100%, and then the whole thing will hang. The size or type of the created disk (dynamic / fixed size) has no effect, it would seem.

It's worth mentioning that the problem is clearly the Virtual Disk service; the Computer Management window remains responsive. However, because the VDS is all locked up, I can't even reboot (system will be shutting itself down endlessly and I need to cycle power).

I was able to get things working in Safe Mode, and for my current limited needs, this is a solution, however I see this as a symptom of potentially more serious problems in the system. Especially since the VDS locked up in other scenarios as well, such as changing a letter of a virtual disk (regardless if it is FAT formatted or NTFS, using Safe Mode, formatted).

Since the whole thing does work in Safe Mode (in safe mode with networking even), I started by disabling all possible services and startup items using MSCONFIG and running a diagnostics boot. The VDS was still unable to create a 10MB fixed-size NTFS formatted drive. I then tried disabling all possible devices in the Device Manager, but the procedure still failed.

At this point I'm out of ideas. What else can I do to fix this issue, and get the VDS to work properly?

My System SpecsSystem Spec
24 Sep 2010   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Tell me, if you type cmd in search and in cmd type driverquery, do you see sptd as a driver?
My System SpecsSystem Spec
24 Sep 2010   #3

Windows 7 32bit 7077

No, SPTD driver (which is used by Deamon Tools, if memory servers), is not used. I use Virtual Clone Drive for my image mounting needs.

EDIT: The Virtual Clone Drive shouldn't interfere at all with the VDS, as I'm using both without a problem on a different system. Besides, I quickly checked, an removing Virtual Clone Drive didn't resolve the issue.
My System SpecsSystem Spec


 Virtual Disk Service keeps hanging

Thread Tools

Similar help and support threads
Thread Forum
Unable to connect to Virtual Disk Service, no path?
So ive checked a lot of threads here, trying to get this god forsaken system to work so i can format my latest ssd. i went into Services.msc and looked up Virtual disk, wasnt on, only said manual. So i try to start it up right, i get this message: "Windows could not start the Virtual Disk...
Hardware & Devices
Disk Shrinking problem. Cannot access to Virtual Disk Service
I was in Disk Management and was shrinking my disk C: where Windows 7 is located, to make room for another operating system. The window seemed as if it crashed so I closed it. It was a mistake. I opened it back up and now it's stuck at "Connecting to Virtual Disk Service". Partitions don't show up....
General Discussion
Virtual disk service error
Hi, I have been trying to install windows 7 but when I select the partition to install it says something like that "it has current MBR partition table ..on EFI systems windows can only be installed on GPT" While following the above instructions and using "OPTION 2" I get this error when...
Installation & Setup
Virtual Disk Service error
I have this same issue and I have Disk 0: Partition 1 100.0mb system Disk 0: Partition 2 698.5gb primary And it's giving me the same error and I'm contemplating deleting both partitions but my question is will the system automatically create a new combined partition or somethin?because I have...
Installation & Setup
connecting to virtual disk service...
Just put a new rig together. I've got Win 7 x64 on my primary C drive (2 x WD 150G Raid 0), 2 Data drives (WD 1Tb, and a Seagate 400G). I just hooked up my 2 older WD 150G drives and created a second Raid array. I would like to initialize and format this drive. When I go to Disk Management the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App