Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: XP Mode - Virtual PC - "User does not have sufficient access rights"

05 Jan 2011   #1
Dick Jagger

Windows 7 Ultimate
XP Mode - Virtual PC - "User does not have sufficient access rights"

Can no longer run XPMode. Had it running fine for 5 months or so, then the other day I tried to start it and it the machine could no longer be found. I restored the vhd files from last month's back up but now every time I try to run it or edit the settings of the machine, I get the error message:

"The virtual machine configuration could not be created. User does not have sufficient access rights"

I have tried disabling Virtual Pc under the Windows Features, then restarting, enabling it and restarting but same error and no XP mode anymore. Has anyone seen this before?

My System SpecsSystem Spec
05 Jan 2011   #2


You could try this:
  • Delete (if exists) Your_Userfolder\Virtual Machines\Windows XP Mode.vmcx and all XP Mode files in Your_Userfoder\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines\
  • Delete also the base vhd C:\Program Files\Windows XP Mode\Windows XP Mode base.vhd
  • Restore both vhd's needed for XP Mode to run from your backup, the Windows XP Mode.vhd to its default location Your_Userfoder\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines\, and the base vhd to C:\Program Files\Windows XP Mode\
  • Go to Your_Username\Virtual Machines\ and create a new virtual machine
  • Select Use an existing virtual hard disk when asked, browse to the restored vhd (not the base), select it and follow instructions on screen. Setup adds the base vhd automatically

My System SpecsSystem Spec
06 Jan 2011   #3
Dick Jagger

Windows 7 Ultimate

Thanks - I just ran through all of the steps you listed and got the same user access rights error message. Not sure what else to try here... Thanks for the input though.
My System SpecsSystem Spec

06 Jan 2011   #4


After restoring both vhd's, did you take ownership of those files? The error message in your first post suggests that you have not rights to those vhd files.

My System SpecsSystem Spec
07 Jan 2011   #5
Dick Jagger

Windows 7 Ultimate

No luck at all with getting xp mode to run... virtual PC keeps giving the same access right error. I took ownership of every file that I restored. but nothing seems to work. I just went ahead and installed Virtual Box and (ahem) got a copy of XP pro... which is up and runnng OK right now. I just liked how simple it was before to use the XP mode, then suddenly, nothing at all...

Thanks anyway.
My System SpecsSystem Spec
07 Jan 2011   #6


One, the last option would of course be to re-install VPC and XPM? But, main thing is you got XP running.

My System SpecsSystem Spec
08 Feb 2011   #7

Win 7 x64
Same problem? fixed

I came here because i had the same problem,

solution here was to disable the UAC:
  • (configurations, user accounts and paren..., user accounts
  • -- new window pops out --
  • select the last option (Change user account settings)(or something like that)
  • -- new window pops out --
  • pull slider down to last option (never display any...)

--now you might have to reboot--

now try again to create your virtual machine.

P.S. you should probably set the UAC settings back for safety.
My System SpecsSystem Spec
08 Feb 2011   #8


Add the "everyone" group to the D: security tab
My System SpecsSystem Spec

 XP Mode - Virtual PC - "User does not have sufficient access rights"

Thread Tools

Similar help and support threads
Thread Forum
CD drive "You do not have sufficient rights to perform this operation"
This is a new development. Windows 7, 64 bit laptop I put a music CD into my laptop's cd drive and windows Media player says "no CD". So I double clicked on the CD drive icon and was told "You do not have sufficient rights to perform this operation". *****the funny thing is that I think it seems...
Hardware & Devices
Import Pictures to NAS "Access Denied" Error Though User Has Access
Hi, All. I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS)...
Network & Sharing
is "clean" and "quick format" sufficient
I'm sure i dont got any bad sectors, therefor is "clean" not "clean all" sufficient? with a quick format, to delete any malware/virus etc?... like a mbr virus..? im asking this cause i dont really got the time for the long ones :O
Installation & Setup
"Access Violation" on opening OptikVerve Virtual Studio
I downloaded Virtual Studio from the OptikVerve site, and when I try to open an image in it I get this message (see image) "Access Violation..." I know this is a reliable program that others use successfully. Unfortunately, I have not yet been able to locate any forums specifically for their...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App