Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: releasing USB in VMWare

28 Jan 2011   #1

Desk Top with Win 7 Home Premium 64 bit and Lap Top with Windows 8.1 Pro 64 bit
releasing USB in VMWare

I'm trying to get VMWare figured out. I had a problem and I think I know what caused the problem, but I'm not sure if my thinking is right. I have Win7 on my desktop. I installed VMWare and put WIN XP on it. When I was in the guest machine (XP) I couldn't print. I finally found out that I had to connect the USB ports in order to use my printers. I did that and both printers worked in XP with no problems. I later shut down my virtual machine and was using WIN 7--the host machine. A few days later I tried to print while in Win 7 (host machine), but neither of my printers would print. I have an HP inject and an HP laser jet. I thought that maybe I didn't release those ports while in my guest machine, so I went back into XP and released them. (Well, at least I think I released them.) Back to my host machine but it still would not print. I reinstalled the software for my inkject and it took care of the problem--it printed. I did the same with my laser jet but it still would not print. So I thought that since it had to do with not releasing the printers while on VMWare, I un- installed VMWare. It still wouldn't print. Fortunately, a few days before I connected the printers in VMWare, I made a system image. I restored the image and both of the printers work. Here's what I think the problem was--but again--I'm not sure.
I think that somehow I never did release the printers when I was in the virtual machine. I also realize that when you un- install virtual machine, the un-install does a poor job and it is not entirely un-installed. I believe that the settings that I set when I was in the virtual machine were not completed removed. Is my thinking correct? If so, do you have any idea why I could not completely release them in the frist place. I know this is a long read and I thank you very much for your input.

My System SpecsSystem Spec
28 Jan 2011   #2


Devices that are not shared, which can be connected only to host or guest but not to both at the same time, are normally always released, disconnected from guest and reconnected to host when vm is closed.

If you close a vm with some of these devices still connected, next time you start the vm they are again automatically disconnected from the host and reconnected to guest. In this case you get a warning:

releasing USB in VMWare-vmware_devices_1.png

If you do not let vm to reconnect the device (click Cancel), you must manually reconnect it when needed:

releasing USB in VMWare-vmware_devices_5.png

To monitor your device status, you use the statusbar icons as these images show:

releasing USB in VMWare-vmware_devices_2.png

releasing USB in VMWare-vmware_devices_3.png

releasing USB in VMWare-vmware_devices.png


My System SpecsSystem Spec
28 Jan 2011   #3

Desk Top with Win 7 Home Premium 64 bit and Lap Top with Windows 8.1 Pro 64 bit

Thanks for all of that information, Kari. I have a better understanding of it now and will work on it tomorrow.
My System SpecsSystem Spec

28 Jan 2011   #4


If you have some issues with devices not reconnecting to host when vm is closed, it must not be a big problem. We can then look deeper in to settings.

My System SpecsSystem Spec
28 Jan 2011   #5

Desk Top with Win 7 Home Premium 64 bit and Lap Top with Windows 8.1 Pro 64 bit

So far--so good! I reinstalled VMWare and put XP back on. Everything is working well. The information you send me helped to clear things up.
My System SpecsSystem Spec
29 Jan 2011   #6


That's good to hear.

My System SpecsSystem Spec
03 Feb 2011   #7

Windows 7 Ultimate x64

try to kill (end process) vmware-usbarbitrator.exe from the task manager in windows 7. (see the attached img)

Attached Images
releasing USB in VMWare-temp1.jpg 
My System SpecsSystem Spec

 releasing USB in VMWare

Thread Tools

Similar help and support threads
Thread Forum
Samsung Releasing 2TB SSDs!
Apparently without fanfare, Samsung is releasing both 2TB EVOs and 2TB Pros. The EVO is supposed to be available 7/22/2015. Newegg is already accepting preorders for it for $800. Newegg also lists the Pro but hasn't announced a release date or price and isn't taking preorders yet. While the...
Hardware & Devices
VMWare Error,EFI VMware Virtual SCSI Hard Drive(0.0)unsuccessful
Hello Was functioning normally, but there was a problem I use an operating system OS X Mavericks 10.9 What is the solution? Thanks you
Does anyone have a Idea of when AMD is releasing the Bulldozer
Ok i was trying to make the tittle short but anyway ,you get the picture Does anyone possibly know the date release ? I have been looking around and they say all the same thing .pretty tired of waiting on this so im opting to get a new board ram and maybe throw in the crossfire but still...
General Discussion
Memory not releasing
This is a problem I have been having, and keeping a close eye on and I do not believe it is the programs fault, but something with the setup of windows 7 64bit. My computer that I am experiencing the problems on has 12gb DDR3 1600mhz ram, and an i920 processor, and GTX 275 SLI. The other two...
Performance & Maintenance
Sync Storage Not Releasing
I accidentally got Sync working when I mapped my "My Documents" to a shared network folder on my server. I've since disabled Sync and told it to delete all off-line files, but Windows Explorer still shows 120 GB of "C" being used when in reality I only have 26 GB. I've rebooted twice after...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App