Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Group Policy Not Applying in XP Mode

04 Aug 2009   #1

Windows 7
Group Policy Not Applying in XP Mode

I'm running Windows 7 Ultimate x64 on my laptop and have installed Windows Virtual XP. I have joined the XP virtual machine to our domain successfully and am able to connect to server shares and our Exchange Server. However, Group Policy is not applying to the virtual machine, neither user nor computer policies. When I do "gpresult" I get the following message:

INFO: The policy object does not exist.

I have verified that the DNS server entries are correct on the VM. The VM's logon server is our domain controller. I have tried running "gpupdate /force" but that doesn't work.

I appreciate any advice or tips anyone might have.


My System SpecsSystem Spec
04 Aug 2009   #2


Springboard Series - The Resource for Windows Desktop IT Professionals : Understanding XP Mode

Jeremy Chapman: From the application compatibility perspective, the best thing to do is to get applications that run natively without any virtualization aids, recoding, compatibility fixes or compatibility modes needed. If you own the code and can recode the application, then do that. If you can’t recode a line-of-business application or are not dependent on support for a third party application, you can try compatibility fixes – or “shims” – to remediate the application. Finally, when all these options aren’t possible, then look into legacy operating system virtualization. If you have exhausted all other options for application remediation and intend on using Windows XP Mode, then I’d recommend following all the best practices in the Windows XP Security Compliance Management Toolkit to secure the virtual environment and manage configuration with Group Policy and desired configuration management in System Center Configuration Manager.
My System SpecsSystem Spec
05 Aug 2009   #3

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

The Windows XP Security Compliance Management Toolkit is this link: Windows XP Security Compliance Management Toolkit

Also, what does
gpupdate /force /boot
do? Does gpresult still not show anything?
My System SpecsSystem Spec

05 Aug 2009   #4

Win 7 Pro x64, VM Win XP, Win7 Pro Sandbox, Kubuntu 11


Thanks for posting the Management Toolkit - Downloaded. :)
My System SpecsSystem Spec
05 Aug 2009   #5

Windows 7

Thanks johngalt for the reply.

I tried gpupdate /force and got the following:

Refreshing Policy...
User Policy Refresh has completed.
Computer Policy Refresh has completed.

When it was done, it didn't force a restart or logoff, so I went to the Actions menu of XP Mode and chose Restart. After logging back in, I still get the same message when doing gpresult:

INFO: The policy object does not exist.

We have other virtual PC's in our organization where Group Policy is working fine, though none running Windows 7 as the host machine.

My System SpecsSystem Spec
05 Aug 2009   #6

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

Hmmm - That is weird.

I don't have a machine to run as a DC right now so I cannot test this (and they won't let me play with GPOs at the Uni - go figure) so I am not sure where to go with this one next. Did you try using the /boot to see if it would auto run gpupdate on the reboot? perhaps if you can get it to update first thing on booting XP the policy may stick until the next boot, giving you a possible workaround to add that as a login script....
My System SpecsSystem Spec
05 Nov 2009   #7

Take your pick

I'm having exactly the same problem on Windows 7 enterprize with MS Virtual PC. I'm positive it's not an AD problem as I set up an identical (except for the computer object) image using VMWare and have no problems.
My System SpecsSystem Spec
19 Nov 2009   #8

Windows 7

The reason the GPO isn't working is because you are using NAT (default in XP Mode) and the XP Mode object does not have a unique IP. In bridged mode, the GPOs should work fine.

My System SpecsSystem Spec

 Group Policy Not Applying in XP Mode

Thread Tools

Similar help and support threads
Thread Forum
Group Policy - Apply to a Specific User or Group
How to Apply Local Group Policies to Specific User or Group in Windows Windows has three layers of local GPOs: Local Group Policy Local Group Policy is the only local GPO that allows both computer configuration and user configuration settings to be applied to all users of the computer....
How to fix Group Policy not applying for Sleep Settings?
Our GP settings for our Power Options are set to 'Never" sleep on all our Windows 7 machines. All our GP settings apply perfectly on our Dell desktops and have never had any issues until now. We've ordered newer Dell desktops but still running Win 7. Once I place them on the domain and move...
General Discussion
Adm can't open window application after applying the group policy
Hi, I have two users in my window 7 - userA (admin account) - userB (general user) I tried to limit the userB to open specific window application (I.e. win media player) by using userA to apply the follow setting: How do I allow Windows 7 users to run only specific applications?...
General Discussion
Group Policy Applies Policy EXCEPT for 1 Setting!
Hi all! Windows 7 Pro 32 bit on a domain I've NEVER seen this before and I cant figure it out. I have a group policy set on an OU named LAPTOPS. The policy gets applied, however the User Config\Windows Setting\Scripts\Logon DOES NOT. When you run the GPRESULTS on the laptop, I see the...
General Discussion
Group Policy Editor or Local Security Policy
Will either of these allow me to restrict drive access to a single user only? I've tried to restrict drive access with Group Policy Editor but it applies the restriction globally--even to me the administrator. Could anyone let me know if this is possible and how to do it? Much thanks.
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:04.
Twitter Facebook