Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 64 + Virtual XP Mode = No printing from XP Mode

26 Jan 2012   #1

Windows 7 x64 (Ultimate)
Win 7 64 + Virtual XP Mode = No printing from XP Mode

Brand New PC with Windows 7 Ultimate 64 bit w/SP1 and latest win 7 updates + Virtual XP mode w/SP3 and updates.

1 HP Laserjet 1020 connected via USB directly to the PC... hp 64 bit software installed and printing perfectly from Win 7 Environment.

1 HP Laserjet M2727nf on the network... hp 64 software installed and printing perfectly from Win 7 Environment.

Both computers Environment Workgroup Names have the same Network Name... that has been checked twice

I start XP Mode, if I go to the Printers & Faxes section, all I see is:
  • Microsoft XPS Document Writter (set as Default)
  • Microsoft XPS Documente Writter (On Win7-64bit-PC)
If if I click on the USB tab (on top), the following is showing:
  • Wireless/Bluetooth Device ----- Attached
  • HP LaserJet 1020 ----- Shared
  • USB2.0-CRW ----- Shared
I have tried installing the printers from Within XP Mode but to no avail.

I have googled this to death but none of the links I find deal with my situation, pretty much all of them can print but have other issues and that is not the case with me... I Can Not print from withing XP Mode.

I have not tried this yet but I was wondering if I should Uninstall both printers from Win 7 64 and install back again but with 32 bit software instead of the 64? Would that make any difference?

I am not a computer Genius but I know my way around them, Networking though, that is an entirely new monster and him and I just don't get along

Computer Specs on this new Machine:


Asus P8Z68-v/Gen3
Intel i5 2500K 3.3 Ghz
Crucial SSD128G
16GBs Corsair Vengeance PC1600 (2 x 8 GBs) Ram
Asus 25: LCD VE258Q

If you require more info let me know but I think I have posted enough for now

My System SpecsSystem Spec
28 Jan 2012   #2

Windows 7 Ulimate x64

i think the problem is that you need to install also win xp 32bit driver on windows 7 , simply add x86 driver in additioal driver (in shaing window) so the printer could be deploy on 32 bit client as well.
My System SpecsSystem Spec

 Win 7 64 + Virtual XP Mode = No printing from XP Mode

Thread Tools

Similar help and support threads
Thread Forum
DOS Application from XP Mode With Wireless Printing
So I have a customer with a horrendous set of requirements. He needs to run some software that is only compatible with a Win XP and earlier command line. I convinced him to try to migrate away from XP because of it's EoL but I cannot figure out how to get Windows 7 to meet all of his...
Virtual PC and XP Mode
We all know that XP Mode is availavle only for Win 7 Pro and Ultimate. There is a tutorial from another website ( a wel-known site ) posting a method to instal XP Mode in Windows 7 Home Premium, as well as in Vista. My question : Is it legal ? Will there be adverse effect employing that...
USB in Virtual XP Mode
I have a USB soundcard attached which is (or was) the only way to have access to external audio in a previous incarnation of Virtual XP. This time however none of the USB devices attached to the machine seem to be listed as available. What I have under USB is: 802.11n WLan Adaptor...
Printing to printer installed in XP Mode
I have a print driver that is not compatible with Windows 7. I installed it in XP mode, and see the printer there. (this is Castelle Faxpress fax software... the driver is installed with the software). However I don't see the printer in Windows 7 where I really need it. I was hoping that installing...
Printer printing in xp mode
sorry, i figured it out
Hardware & Devices
XP Mode printing woes
It seems that every time I log on to XP Mode, the printing ports change. The printer was initially on TS port 4, then it was 5, now it's 8. The only I can tell which it is is by printing a test page on each port until something comes out. What's up with that? Is there a fix?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App