Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VMware Player 4 & Workstation 8 Error 1920 or MSI failed at install

22 Aug 2012   #1

Windows 7 Professional (64 Bit)
VMware Player 4 & Workstation 8 Error 1920 or MSI failed at install

Hi all

I have been trying for the past couple of hours to install either VMware Player 4 or Workstation 8 and keep getting the same error on both of them.

I've tried some of the stuff on the VMware website like regedit and deleted the temp folder and that but it doesn't seem to work for me.

Could someone please help I need this software to help me with my studies.

I have also tried the Microsoft fix as well with no luck.



Attached Images
VMware Player 4 & Workstation 8 Error 1920 or MSI failed at install-vmware8failed.jpg 
My System SpecsSystem Spec
24 Aug 2012   #2

Windows 7 Professional (64 Bit)

Found a fix for the problem I was having... Hope this is helpful.

go into your registry by typing into search bar regedit

then do ctrl + F to search for

Now you want to save a copy of this first go to file then export then name it what you want it to be I just named it windowsdisabledsessions to make it easy

then after that just hit the delete key and then run your program and it should install just fine :)

If you have any questions please contact me on

[email protected]


Gamer 1238
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
BSOD Starting Vmware workstation, Error: CLOCK_WATCHDOG_TIMEOUT
Hi All, I've been getting blue screen whenever I start any VM on my VMware workstation. This had happened in the past, but not so frequent, perhaps once a month. But since two days ago, this had happened whenever I click on starting my virtual machine. It blue screens within 2seconds. I...
BSOD Help and Support
Dell M6400 VMWare Workstation, error 0xf4
Hi Folks, I found your website with a search that led to a very similar problem I am having, found it in this post: I have a Dell Precision M6400, and I am trying to get VMWare workstation to run but it BSODs...
BSOD Help and Support
VMware Workstation - Don't want to install
Hello SF members :) I have one problem. I want to install VMware Workstation 9 and to try it. I downloaded Trial version. When I run installation, select where I want to install it and start installation it closes. There isn't any error or something like error, just exit. How to fix it...
Cant install vmware workstation
Hello everyone, I'm using windows 7 ultimate x64. When i try to install vmware workstation, an error occures like following : "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." At first i thougt, it is about...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:43.
Twitter Facebook