Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet in XP Mode only?!

01 Nov 2009   #1
flatratetec

Windows 7 Professional
 
 
No internet in XP Mode only?!

My laptop will not connect to the internet at all in XP Mode. It works just fine in Windows 7 Pro. It seems like when its in XP mode it doesnt see the wireless adaptor. Is there anything else that I may need to do? I just downloaded the XP Mode app. Unfortunately I need XP to run an app for my job which also requires internet access. Any ideas or help that anyone can provide is greatly appreciated. Thanks!!


My System SpecsSystem Spec
.
01 Nov 2009   #2
HughShaw

Windows 7 Professional (x64)
 
 

Did you enable integration features?
My System SpecsSystem Spec
01 Nov 2009   #3
flatratetec

Windows 7 Professional
 
 

How do I do that?
My System SpecsSystem Spec
.

01 Nov 2009   #4
HughShaw

Windows 7 Professional (x64)
 
 

Just go to All Programs, find Windows Virtual PC, click it and find XP mode, right-click it, choose settings, find Integration Features, and check it off.
My System SpecsSystem Spec
01 Nov 2009   #5
aem

Windows 7 Ultimate 64Bit
 
 

Quote   Quote: Originally Posted by flatratetec View Post
My laptop will not connect to the internet at all in XP Mode. It works just fine in Windows 7 Pro. It seems like when its in XP mode it doesnt see the wireless adaptor. Is there anything else that I may need to do? I just downloaded the XP Mode app. Unfortunately I need XP to run an app for my job which also requires internet access. Any ideas or help that anyone can provide is greatly appreciated. Thanks!!
Check in VPC Settings that your "Network" include integration for your wireless adapter. See mine is set as Adapter 2.

Also, To se auto integrade just enable it in the "Integration Features" below "Networking"..in the Setting Window. OR from the Xp mode window, click ACTION > Enable Integration Features.


Attached Images
No internet in XP Mode only?!-noname1.jpg No internet in XP Mode only?!-noname.jpg 
My System SpecsSystem Spec
02 Nov 2009   #6
flatratetec

Windows 7 Professional
 
 

Thanks guys! Adjusting the network adaptor settings in the virtual PC menu fixed the problem. Only the wired ethernet card was set up by default. Thanks again.
My System SpecsSystem Spec
30 Mar 2010   #7
Debbie Hallberg

Windows 7 64 bit with XP Mode
 
 

I was having the same issue, it had initially worked, then stopped when I added my ethernet to the settings network. In the settings network, I had my wireless 1st, my ethernet 2nd.

Looking at AEM's setup, I added Shared Networking (NAT) in the 1st slot and moved everything else down...

That was my silver bullet.

Thanks
My System SpecsSystem Spec
Reply

 No internet in XP Mode only?!




Thread Tools




Similar help and support threads
Thread Forum
Very slow internet in normal mode but fast in Safe mode
Hi, this is my first post on SevenForums. My internet speed is really slow. I'm lucky if I can reach 1Mbps when I start up Normally. However, when I start up in Safe Mode with Networking I can reach 12Mbps. The computer is fairly old (8/9 years old maybe) and I've only just upgraded from XP...
Network & Sharing
No Internet in Normal Mode; Works in Safe Mode
Hello, I'm running a Gateway NV Series and as of last night I have fallen victim to the problem that Windows 7 seems to be plagued with. My internet has completely stopped working, both Ethernet and Wireless. I have tried many of the fixes suggested in this forum and others, but none of them...
Network & Sharing
Internet working in safe mode but not normal mode
I have tried the following: No proxy server is being used (box is unchecked) All of the drivers appear to be working fine I have run Hitman, Superantispyware and Malwarebytes (in safe mode). They each detected different problems. Any other ideas before I take this to the computer shop?
Network & Sharing
Internet faster in Safe Mode, slower in "normal mode"
As title says, my internet in safe mode with network activity is 10x times faster than in normal mode, i've removed a lot of services but the problem insists. Logfile of Trend Micro HijackThis v2.0.5 Platform: Windows 7 SP1 (WinNT 6.00.3505) MSIE: Internet Explorer v8.00 (8.00.7601.17514) ...
Network & Sharing
normal mode acting like safe mode and now internet not working
Hi all, my laptop has been acting crazy the past couple of days. First of all, I was watching a movie on it and it just shut down. when I tried restarting it in normal mode i would get to the welcome symbol after what seemed an eternity of loading, but then the screen just went black. when I...
General Discussion
No internet in normal mode but works in safe mode with networking
Hi! I'm just a new here, hope someone can help and give advice here. (Sorry if this is not the right thread to start my topic) Scenario: (this is my first time to encounter this problem) While playing facebook games last monday, my computer get BSOD and restarts. After booting up on windows,...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App