Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: KB958559 fails to configure in Windows 7

16 Dec 2009   #11

Windows 7 Professional 6.1.7600 Build 7600

By the way: My apologies if I sounded snotty in my posting before you fellas came around - I've just gotten really frustrated by this whole thing.

I HAVE to get this up and running immediately - I just began my 70-290 & 70-291 studies (which only lasts a few weeks total), and I have to be able to use XP Mode/Virtual PC so I can also run/install a virtual of Server 2003 to use for the bookwork and mock problems etc.

My System SpecsSystem Spec
16 Dec 2009   #12

Windows 7 Ultimate 64 bit

Hi Serloren,

It might be idea to check compatibility with the Hardware-Assisted Virtualization Detection Tool - HAV Detection Tool

and then check that you have the latest versions of all software. It's also worth re-downloading in case your install files were corrupted.
Download details: Windows Virtual PC
Download details: Windows XP Mode

Last thoughts, if it's a driver issue and you install the driver on MSupdate it might all work for you. Perhaps after it installs you can update the driver again to the latest one supplied by Dell.

BTW - Why do you need XPmode? I don;t remember installing it when I installed virtual PC and my virtual XP box's work fine (I'm thinking that there is something here that I don't know )
My System SpecsSystem Spec
17 Dec 2009   #13

Windows 7 Professional 6.1.7600 Build 7600
All been and done - several times...

Hi Tim,

All of those things have been done, checked etc - and in some cases several times (i.e. attempted to use different downloads of files, attempted to install with various services on/off, and on down the line).

I don't need a driver installed, I have newer driver already installed - but Windows tried to install an older driver, and that failed install listed in my Windows Update somehow blocks Virtual PC from completely installing. - That this failed install is blocking VPC comes from a Microsoft employee I was working with on the Technet forum who looked over all I did, and went through my CBS log(s).

Why I need XPMode: Essentially, it isn't so much XPMode that I need as it is VPC. I think of the two of them together as one functioning app, and if I can get stuff going, I'd of course prefer to be able to use Microsoft's provided virtual vs. having to create my own with my own numbers blah blah blah (for my XP virtuals that is)...

BUT, if Virtual PC would install, my actual probpem would be resolved as I could then create and run virtuals of Server 2003 (and later 2008) that I need to run to do classwork (labs, exercises, demo builds, etc).

Essentially, I'm stuck until I can find a way to remove/excise the references to the failed install attempts of that stupid Realtek driver from my Windows Update files located wherever they are on my system.

I'd even be willing to just remove the NIC driver I have installed so that Windows could retry the one it wants, and update it myself after that one was in - BUT, since it is the only driver I have, I'd be unable to connect to the update site in the first place. Y'know?
My System SpecsSystem Spec

17 Dec 2009   #14

Windows 7 Professional 6.1.7600 Build 7600

KB958559 fails to configure in Windows 7 Professional
Virtual PC KB958559 RTM install failed - Start Menu/Program Folder Permissions root cause

If you'd care to look, here are links to the threads on Technet; and it appears I now have a colleague in misery...<wry smirk>
My System SpecsSystem Spec
18 Dec 2009   #15

Windows 7 Ultimate 64 bit

Quote   Quote: Originally Posted by serloren View Post
KB958559 fails to configure in Windows 7 Professional
Virtual PC KB958559 RTM install failed - Start Menu/Program Folder Permissions root cause

If you'd care to look, here are links to the threads on Technet; and it appears I now have a colleague in misery...<wry smirk>
I just read them.... there's a lot of info there.

Can you please confirm that you have tried to remove the currently installed realtek driver and disable the device and then try to install VPC? It is important to remove the driver from the windows driver store after you from device manager (so that windows doesn't know that there is a newer driver available). I'm presuming that you can always reinstall this later from disk or realtek website.

At this stage and given all else that has been tried, we may as well clear the page-file on shutdown as well (you can change this back later), it's surprising how often this can help, especially if there is corrupt data from a broken install.

Regedit to the link below and change the clearPageFileAtShutdown to 1
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory =METHOD 2=
opening secpol.msc and changing the local security policy / security options /shutdown: clear virtual memory pagefile

I just realised my win 7 64 bit has Virtual PC 2007 installed (the 64 bit version). I know that installing the earlier version is not a 'fix'; but keep it in mind that it works and providing you don't have the same installation error, you can at least get your studying done.
My System SpecsSystem Spec
19 Dec 2009   #16

Windows 7 Professional 6.1.7600 Build 7600

Well, had a Microsoft tech tell me which folders to delete to clear my Windows Update history, and which service to shut down before I did it. After reboot, no Windows Updates listed at all, and none waiting to install. Tried to install VPC again, and this time it went to 100% configuration...before failing and rolling back out. *sigh*

A fella named Thayu on Technet is digging through some more logs and such trying to get this resolved. And Microsoft is supposed to have a tech call me Monday afternoon as well.

Until then...*shrug*
My System SpecsSystem Spec
20 Dec 2009   #17


um, why not just use virtualbox? its a freeware virtualization app, only thing it won't do is the "xp mode" seamless integration. which it doesnt sound like you need anyways.
My System SpecsSystem Spec
20 Dec 2009   #18

Windows 7 Pro

I just found this thread after searching the net for a solution. I have the exact same problem as serloren on two machines, an HP dv8000, and a Lenovo T60, both running Win 7 Pro 32 bit. Mine does exactly the same thing as serloren, installs up to 96 percent on the Window Virtual PC install, and then fails and uninstalls itself. I am however, not aware or do I see any installed drivers or misinstalled drivers.

I was able to get XP mode installed and running on a T60p I have running Win 7 Pro 64 bit with no issues at all, so I know what I need to get done to get XP mode running on a laptop. I'm wondering if the problem is limited to the 32 bit XP mode install? If serloren's install is a 32 bit as well, then perhaps there is some issue with 32 bit XP mode installs? I've downloaded and reinstalled at least 10 times already, and gave both laptops full rights. The bios in both machines have been enabled to accept virtualization. I'm at my wits end in getting this to work. Just thought I'd post since the end result of my issue is the same as serloren.
My System SpecsSystem Spec
21 Dec 2009   #19

Windows 7 Professional 6.1.7600 Build 7600

For the advice about maybe using VPC2007....

1) I installed VPC 2007 SP1 without incident.
2) I installed the hotfix without incident
3) I installed XP Mode without incident
4) I fired up VPC, received error (see attached jpg) that stated:

Virtual PC could not open the Virtual Machine Network Services driver.

Access to the external network and host will be unavailable to all virtual machines using virtual networking. Virtual machines using virtual networking will still be able to access other virtual machines using virtual networking.

Virtual PC can fix this problem by binding Virtual Machine Network Services driver to all the network adapters. Do you want to proceed?

Check box - Don't show this message again.

Click Yes or No

I may just be very tired, or I'm just dumb-n-numb at this point, but reading that gave me a virtual headache! ;-)

I clicked no. VPC fired up, it came up again, I again clicked no - figured better to wait and can always change it later. I created a VPC, and pointed it at the VXD file in XP MODE.

XP MODE fired up and installed without incident. To see how connected it was/wasn't, I installed a few updates and an anti-virus - no problems.

I have not yet activated the XPMode as I think it may be better to wait until I get the whole thing worked out correctly - would hate to correct the other junk, and then have it refuse activation on that install.

I will shoot an email to my instructor tomorrow and find out which Server 2003 I am supposed to use from our site - there are 4 or 5 different ones.

For what else I am doing or why....

The above is meant only as a workaround until I can get the real issue figured out and running correctly. I am working with another fella privately who is digging info and such for me - I will post here what I try/do/etc, so that maybe someone else can benefit from what I find or even just from not bothering to do things I have that don't help<g>.

Which version of 7 am I running...

I am running Windows 7 Professional x64bit.

Why not use VMware.....

I actually tried to use VMLiteWorkstation because it is actually supposed to work with XPMode AS XPMode is purported to work, not just as a VHD. It also failed to install, giving me this error:

Can't install network filter driver:The operation completed successfully.


This may very well be a program for others to give a try though, as it states that it will run XPMode even if you do not have hardware virtualization . You can read more about it or get it here:

VMLite XP Mode Overview

Have a very Merry Christmas everyone!!!

My System SpecsSystem Spec
21 Dec 2009   #20

Windows 7 Ultimate 64 bit

Thanks for the update Mate, Keep at it.

Merry Christmas
My System SpecsSystem Spec

 KB958559 fails to configure in Windows 7

Thread Tools

Similar help and support threads
Thread Forum
64bit install fails with "Windows could not configure one or more.....
I am performing a clean install of Windows 7 64bit Home Premium with SP1 integrated on a Dell Studio XPS 8100, and after the first reboot during installation, I get a message "Windows could not configure one or more system components. Windows installation cannot proceed. To install Windows, click...
Installation & Setup
Service Pack 1 fails to configure/install
1. System Update Readiness tool runs to completion. 2. SFC scan detects errors but cannot fix them. 3. The SP1 update (KB976932) has failed (and succeeded once) with several error codes: 1/16/2013 - Code 8024000B - Installation status: Cancelled 9/7/2013 - Installation...
Windows Updates & Activation
Can Not install KB958559
I had XP mode working in my machine and uninstalled it along with the virtual machine KB958559 a few months ago. I'm trying to install it again and XP mode installed OK but when I try to install KB958559 it gets to 96% then fails and reverts back. Have no idea what is wrong.
cant install Windows Virtual PC-Windows6.1-KB958559-x64
oki so i have funy problem my sys is windows 7 ultimate 64. i went to download page i downloaded this "WindowsXPMode_pl-pl" and then this "Windows6.1-KB958559-x64" acording to my language. so i sucessfuly instaled this "WindowsXPMode_pl-pl" first and restart pc. after reboot trying to install...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:27.
Twitter Facebook Google+