Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows XP mode doesn't start right after installation

21 Nov 2009   #1
mmo

2x Windows 7
 
 
Windows XP mode doesn't start right after installation

On one of my two system XP mode doesn't start.

On both systems I have installed Win7 Ultimate. First updated both systems from the Update site, then I installed Virtual PC and then Windows XP mode. On one system after the end of the XP installation everything works fine, the VM starts as expected and I can install XP apps.

On the other, after entering the XPMUser-pwd the system says it's now launching XP mode for the first time to configure it, but then the progress bar "starting XPMode for the first time" (or so...) gets slower and slower and after maybe 5 minutes I get an error message that configuration of XP mode failed.

Any ideas? What could cause Windows XP Mode to fail starting?

Just in case: I ran the havdetection tool on both systems, on both the virtualization is enabled on the BIOS. And, yes, I rebooted both after the installation of the fixes and of Virtual PC, as suggested each time.

Michael

PS.: somehow I can't help and apple's ad comes to mind: "trust me! This time everything will be better." Well, problems are starting even earlier than ever this time


My System SpecsSystem Spec
.
22 Nov 2009   #2
HughShaw

Windows 7 Professional (x64)
 
 

I think I had a similar problem, and I ended up updating my BIOS which fixed the problem.

And once you discover how slow XP Mode is, download VMware Player 3.0 and transfer over your base VHD. It's much faster at running XP...I can even play games!
My System SpecsSystem Spec
22 Nov 2009   #3
mmo

2x Windows 7
 
 

Quote   Quote: Originally Posted by HughShaw View Post
I think I had a similar problem, and I ended up updating my BIOS which fixed the problem...
I already have updated my BIOS before installing Windows 7. The manuf's website explicitly had mentioned that this BIOS upgrade was specifically targetted (and necessary) for Windows 7. So, guess that prereq I can check off.

Any other idea what could cause XPMode startup hang?

M.
My System SpecsSystem Spec
.

22 Nov 2009   #4
mmo

2x Windows 7
 
 

Strange enough, in the 10th (or so) attempt the thing finally - again after quite some waiting time - came up and finally continued to "load settings", bringing up the XP desktop etc..

That is, it finally started and seems to behave "normal" so far (I hope at least...). But that wasn't exactly a very convincing first appearance...

M.
My System SpecsSystem Spec
22 Nov 2009   #5
HughShaw

Windows 7 Professional (x64)
 
 

XP Mode will do this from time to time. Once in a while it won't be able to start, or it won't be able to get integration to work. For me, it was buggy to say the least. But sometimes it worked perfectly.

Once you get tired of the slow XPM, be sure to check out the free VMware Player. It can import your base VHD (w/o any installed programs) from XPM. Once you got it all set-up, you can delete XPM and Virtual PC. Just be sure to save the XPM base VHD file (about 1.12GB) and move it to your VMware working directory.
My System SpecsSystem Spec
Reply

 Windows XP mode doesn't start right after installation




Thread Tools




Similar help and support threads
Thread Forum
Windows doesn't login properly in normal mode but fine in safe mode
Hi, I got win 7 home premium 64 bit on an i3 laptop. My system worked fine until today morning. The problem is this; When I boot the system in normal mode, I get to the part where I need to enter my password to login. Once i do that, all I get is a black screen with the mouse pointer that...
General Discussion
Windows Normal Mode Crashes to BSOD and Safe Mode doesn't load
I need some help please as I do not know where to start. I installed a Windows Update a few days ago and then got a BSOD the next time I turned my PC on. So I did a system recovery and this seemed to work. Now, it's happened again without me doing a Windows Update and I cannot get into...
BSOD Help and Support
XP Mode or Virtual PC doesn't start
Hello! I've been struggling with this problem for a while and thought that I might get some help here. I have a Thinkpad T500 with Windows 7 Pro 64-bit installed, and I need VPN connection to my library. The library handles only Cisco clients properly, so I have to use the provided Cisco...
Virtualization
Press any key to start installation doesn't show up when installing
Hello. I want to reinstall windows 7 again, but for some reason this time, it doesn't show the Press any key to start installation. I went to BIOS and CDROM is set to boot first. I also put in the disk in and it runs normally from desktop. The CD is a little scratched, but I don't think that is the...
Installation & Setup
Test Mode doesn't start / work
Hi, I restart my PC spam F8 and enable test mode. Windows boots up and then... nothing. it's normal windows starting without the watermark in either corner and I can't install drivers without certification. I've no clue what's the problem. Thx in advance for any help.
General Discussion
Windows Stuck in Start Screen or Start-Up Repair Mode
Hi, I am hoping people on the forum can help me. Got a Dell XPS M1550 last year January. Everything was fine until today. It's a North American machine, but I was in England for an exchange and currently am, and I think Dell warranty on Hardware is 1 year anyway so really no point after 3...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App