Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VM Disk 2 (from VHD XPMode) is unknown, not initialized, unallocated

22 Sep 2017   #1

Windows 7 Pro SP1 x64; Virtual Machine XP Mode
VM Disk 2 (from VHD XPMode) is unknown, not initialized, unallocated

Win7 Pro SP1 with Virtual Machine/ XPMode (hibernated) was running during daily Norton Utilities 16 Optimize session set to check registry and clear windows/browsing history. The session advanced to a new component (not previously encountered) that looked like it was doing a quick defrag (moving files); this also launched what looked like CHDSK with DOS screen reports showing files checked for Win7. Then advanced to a what looked like a CHKDSK screen in XP Mode with many files being 'found' along with a long scroll of 'Invalid Security converted to Default Security for File_nnnn' (where nnn incremented to 55,000 by end of session). The session concluded with XPMUser screen to logon. I chose 'Shut Down' instead of logging in.

Later, I tried to launch XP Mode, status bar progressed about 30% and it gave a message to the effect 'unable to enable Integration Features'. Status bar cleared and started again, reached 30% (no message), cleared and repeated multiple times. Unable to boot XP Mode.

Consulted SevenForums post about XP Mode not booting. Learned to Save (copy) all Virtual Machine files, especially VHD which is 102 GB with lots of data. Learned and completed uninstall VM, XPMode. Successfully installed VM and XPMode again. Launched XPMode and all Win 7 drives are listed in XP Mode Windows Explorer. XP Mode Disk 0 is healthy in Computer Management.

Next, wanted to import the files from XPMode VHD that would not boot. Shut down 'new' XPMode, opened XPM settings in VM folder to add Disk 2. Pointed to saved VHD from failed XPMode in User\Public folder). Created Disk 2 as 'Fixed Size' of 105 GB (larger than the VHD file size). No errors but took along time to create disk.

Next, launched XPMode and expected to see Disk 2 VHD files. Could not see Disk 2, either as a Drive or contents. Used XP Computer Management to view drives. Disk 0 is Healthy/Allocated. Disk 1 has no Drive letter, and is listed as unknown, not initialized, unallocated. Learned that option to 'initialize' or 'test' will wipe disk. Screen shot of Computer Mgmt Screen. XP Windows explorer shows 'Local C:' and Drives C, D E, F, H, M on Win 7 system.

All steps done on one Win7 Pro Sp1 computer, no external drives used. Need help and solution to recover files on VHD Disk 2 that was created and added to current Virtual Machine.

Thank you.


Attached Thumbnails
VM Disk 2 (from VHD XPMode) is unknown, not initialized, unallocated-xp_mode_computer_mgmt.jpg  
My System SpecsSystem Spec
06 Oct 2017   #2

Windows 7 Pro SP1 x64; Virtual Machine XP Mode

I resorted to data recovery services on flawed VHD. Recovered 96% of total file size. Thank you for reading about my dilemma, I still don't understand why or how the VHD was corrupted. -pjb2
My System SpecsSystem Spec

 VM Disk 2 (from VHD XPMode) is unknown, not initialized, unallocated

Thread Tools

Similar help and support threads
Thread Forum
disk 1 is unknown, not initialized, unallocated
Hi I have the same problem. when i plug in the drive, it says that its succesfully installed however it does not appear in "my computer". also when i go into system tools it says that disk 1 is unknown, not initialized, unallocated can you please help me, i dont want to lose my data, it...
Hardware & Devices
Windows 7: disk 1 is unknown, not initialized, unallocated
Hi All, I have WD external hard disk connected via USB and it does not get detected in explorer. Checked few threads here and tried them and no success. I am attaching screen shot from My computer disk management where it shows disk as "Not initialized" and "Unallocated". I had installed Minitool...
Hardware & Devices
External Hard Disk, Unknown, Not Initialized ! No Unallocated Space.
Hi, I'm new to this forum. My external hard disk (Seagate) is detected in the task bar after connecting, but not visible in "My Computer". It is visible in Device manager under Disk Drives but not under USB. There are few threads in this forum which are similar to mine, except that...
Hardware & Devices
1TWD external hard disk unknown,not initialized,unallocated,i/o error
This quick new hard disk. So sad I cant access it anymore? why this happen? You can see from the photo MY computer cant even see this driver anymore, so I check on the - Disk management it said unknown no driver letter too ,Not initialized. -Click Initialized it said i/o device error I...
Hardware & Devices
Disk 1 is unknown, not initialized, unallocated, Please help
Disk 1 is unknown, not initialized, unallocated, Please help disk 1 is unknown, not initialized, unallocated.. plizz help I already use PhotoRec recovery but "disk capacity not correctly detected" Disk 1 = seagate 500Gb hdd
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:38.
Twitter Facebook Google+