Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Setting up bridged mode properly on vmware

04 Apr 2018   #1

Windows 7 64 vir
Setting up bridged mode properly on vmware

Hello guys,
I'm experiencing a bit difficulties and hope you'll be able to give me proper advices.

I decided to replace two old windows xp machines with two virtual guests on one new PC.
Host PC has windows 7 pro installed and it has two NICS.

Each old windows xp machine had two nics. I have successfully created virtual machines from existin ones and started these machines as guests on a new one. Everything went OK and I0m able to run windows XP and all programs as before on guests virtual machines. The problem is to create networking.

I'll try to exaplain the old setup.
One Win XP machine (let's say A) has the following setup:
NIC1 is connected to one private network:, other NIC is
Machine B also has two NICs: one is ( to communitace to machine A) and other network is

So, on host machine both NICs have default setups. I have adjusted vmware player in settings to use bridged connections (to share files with others on the network i.e. I don't want other network machines on network know they are now communicating with virtual machine.
I have created one specific virtual network for communication between two virtual guest machines A and B and this works.

I have started virtual machine A and inside this machine I have made setup for one virtual LAN properties (same IP as on old machine A) and second LAN to
I have checked and other machines on this 172.xxxx. network can ping virtual machine A as it is real machine. Virtual machine A is propery configured and it works as expected.

Then I have started virtual machine B, set up one LAN as and I was able to ping (virtual machine A) and I have set up on other virtual LAN (same IP as on old machine B).But the problem is that when trying to ping other computers on network. I receive Request time out! Command ipconfig /all returns OK addresses ( and

This is confusing part and I cannot understand why this is happening. Host machine has two NICs and in vmwplayer setting of both machines I have checked bridged connection option. So both virtual machines should be able to share their network resources, but somehow on machine A it works and on B doesn't.
I have tried to unplug cable from network to host machine and in that case ping from machine B returns "host unreachable".

Both NICs on host are OK. I have checked that.

Basically I'm trying to find a way to bridge one physical NIC on host to one virtual adapter on machine A and other NIC on host to bridge to virtual adapter on machine B.
Not sure what I'm doing wrong.

Any advice is really appreciated.

Thank you!

P.S: I use vmwplayer 14. It seems that virtual adapter on machine B bridging on wrong host's NIC

My System SpecsSystem Spec

 Setting up bridged mode properly on vmware

Thread Tools

Similar help and support threads
Thread Forum
adjusting network adapter properly in vmware/virtualbox
Hello guys, I have relatively old windows xp machine that is failing, but I have some important software on it that communicates with other machines via local LAN network (192.168....). In order to prevent possible problems that can failing the machine cause, I have created virtual machine from...
Using bridged mode works but pppoe doesn't work
First of all, I am new to the forums, and really don't know if i can ask this question because it might not be related to W7.( I posted it here becase at anytime this forum is visited by over 10000 people) Anyways: I have a router tp link td 8840t. It is a small modem which i got from my isp and...
Network & Sharing
Windows doesn't login properly in normal mode but fine in safe mode
Hi, I got win 7 home premium 64 bit on an i3 laptop. My system worked fine until today morning. The problem is this; When I boot the system in normal mode, I get to the part where I need to enter my password to login. Once i do that, all I get is a black screen with the mouse pointer that...
General Discussion
Display setting problem with LinuxMint13 and VMWare Player
G'day, I have several versions of LinuxMint (9, 11 and 12) as well as a few other distros running perfectly at 1920 x 1080 resolution (my native resolution) under VMWare Player. I have never had a problem specifying this resolution, without or without the VMWare tools installed. Recently I...
Vmware WKS 7.1 and vmware player 3.1 KILLS XP Mode
Hi all You can try the new versions of vmware player (3.1) FREE and Workstation (7.1) - Commercial I think now that you can launch applications directly in UNITY mode with these new releases it should eliminate the need to use XP mode at all -...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12.
Twitter Facebook Google+