Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 Half Blind - Can't see VM as Resource

28 Feb 2010   #1
Geekster2

Windows 7 Ultimate 64 and Ubuntu 9.10
 
 
Win7 Half Blind - Can't see VM as Resource

Windows 7 Ultimate is not showing VM's as a location from which to add User's to the Windows 7 Security list.
How can you grant file rights to user accounts on the XP-Mode Virtual Machine if you can't list the XP-Mode VM?

I've enabled FileSharing at the root of C: on the XP-Mode VM.
Windows 7 Obviously sees the XP-Mode VM. (See first attached.)

But when I try to access the VM's share, Windows 7 suddenly clams up and can't see anything on the VM!!!??? (see second and third attached).

It's Like Windows 7 is half-blind!

You can plainly see that XP-Mode is running. Why can't I connect to the VM's share?
I also can't grant rights to Windows 7 drives to any users on the XP-Mode VM... Why?
(See last attachment.)




Attached Thumbnails
Win7 Half Blind - Can't see VM as Resource-cantsharefilesfromxp-mode.jpg   Win7 Half Blind - Can't see VM as Resource-cant-select-users-vm-grant-rights-.jpg  
Attached Images
Win7 Half Blind - Can't see VM as Resource-win7-halfwayblind01.jpg Win7 Half Blind - Can't see VM as Resource-win7-halfwayblind02.jpg 
My System SpecsSystem Spec
.
28 Feb 2010   #2
Dinesh

Windows® 8 Pro (64-bit)
 
 

Hi there, which windows 7 version are you using? I have never heard of "Ultra" version. Did you mean Ultimate?

Or could you please type winver in run command and post a screenshot?

Like this:
Win7 Half Blind - Can't see VM as Resource-winver.png


My System SpecsSystem Spec
28 Feb 2010   #3
Geekster2

Windows 7 Ultimate 64 and Ubuntu 9.10
 
 

sorry. I meant Ultimate. I guess I was typing too fast.


Wow, your credentials are impressive: Gold Member, Seven Guru?

Tell me, there MUST be a way to do what I'm trying to do eh?

I'm only trying to do this because Outlook loses connection to the Windows 7 Ultimate C: drive so often that it's driving me nuts! It only seems to do this with Outlook. When using Windows Explorer (I still like to call it "File Explorer") I have no issues. So I'm out to solve that issue by trying to grant rights to the XP-Mode user to the C: drive on Win7. Is it doable?
Thanks,
Vic
My System SpecsSystem Spec
.

28 Feb 2010   #4
Kari

 

Please Geekster don't understand me wrong, but that's not really true. You have told about your Win7 Ultra in at least a couple of threads and several posts, and you tell in your system specs your OS is Win7 Ultra. I do not believe it is this one word, Ultimate, you misspell every time when you clearly can type English quite well, better than me.

I think I could help you, but before I'll do that I need to be sure your Windows is valid and legal. I don't want to have anything to do with issues related to illegal Windows versions, nor want I help members using illegal versions of Windows or any other OS / application. Only references I can find in Internet are pointing in the direction that Ultra is an illegal Windows 7 version, available in torrent and P2P networks.

Please provide a screenshot showing which version of Windows you are using, and that it is activated. I believe we can then help you to connect your XPM and host.

I know I'm going to get some negative feedback because of this post, I can just hope you could understand my point of view.

Kari
My System SpecsSystem Spec
28 Feb 2010   #5
Geekster2

Windows 7 Ultimate 64 and Ubuntu 9.10
 
 

Kari: Well, you certainly won't get any negative feedback from me. I completely understand. What a coincidence I'd use a word that's associated with a pirated version. Here's my winver output. see attached.

If there is anything else you need to feel comfortable of my activated status, please advise. I hope YOU feel comfortable that I'm not publishing my product key here on the forum.


Attached Thumbnails
Win7 Half Blind - Can't see VM as Resource-windowsproofofactivation.jpg  
Attached Images
Win7 Half Blind - Can't see VM as Resource-winver-output.jpg 
My System SpecsSystem Spec
01 Mar 2010   #6
Kari

 

Thanks, Geekster.

OK, let's look your issue. Could you confirm these two details:

1) In XP Mode settings, you have chosen your host's NIC to be used in XP Mode? In my case, my host machine has a Realtec NIC so I choose that to be used with also in XP Mode:

Win7 Half Blind - Can't see VM as Resource-xpm_nic.png

2) Your router can see the XP Mode in DHCP list. In my Belkin router it looks like this:

Win7 Half Blind - Can't see VM as Resource-dhcp_list.png

Check these first, then we know what to do next.

Kari


My System SpecsSystem Spec
01 Mar 2010   #7
Geekster2

Windows 7 Ultimate 64 and Ubuntu 9.10
 
 

Kari: Thanks for the info. I'm at work right now. Just starting my day. I think we're just a "few" timezones apart.

I left everything default when I set up the VM stuff. But I'll take a look at it when i get home (in about 9 hours from now).

One thing I can say is the NIC is functioning. I know this because in XP-Mode, the web browser works fine.

I did notice I can't ping the VM from Windows 7. Windows 7 has an ip of 192.168.1.5 while the VM assigned itself 192.168.131.65 as you can see from the IPCONFIG attachment at the top of this thread.

I'm assuming some kind of DHCP server is built into the XP-Mode vm. correct?
Do you think it would hose the VM if I manually set the IP to one on my network?

I was thinking of trying that.
My System SpecsSystem Spec
01 Mar 2010   #8
Kari

 

I think your issue could be easily solved when you change the XP Mode NIC to that of your host. Let's see.

Kari
My System SpecsSystem Spec
01 Mar 2010   #9
Geekster2

Windows 7 Ultimate 64 and Ubuntu 9.10
 
 

Hi Kari. I'm home from work now, and as you suspected, the XP-Mode's VM settings weren't using the "real" NIC. It was set to "Shared Networking", which must be why the IP address was so strange. You've got to wonder why Microsoft made that setting the default.

I set it to the real NIC, which is "nVidia nForce 10/100/1000 Ethernet"

Immediately the VM picked up the ip of 192.168.1.101, which the DHCP server in my router supplied.

Ok, so now from the VM, I could ping my Windows 7 session.
Ping 192.168.1.5 got a return.

So I minimize the VM and open a cmd shell in the Windows 7 session and ping the VM at "ping 192.168.1.101" and it fails to return.

Ok, so I check for a firewall inside the VM, and turn it OFF.

Now I can ping both ways.

Sounds hopeful, right? Well I still can't access the VM's shares when I click on the VM's machine name in File Explorer's Network section, or see the machine name in Security settings "Location" button. Everything here is just like the problems described in my pictures.

However, since we can ping both ways, I'd say Windows is only 1/4 blind now.
So there's progress at least.
.
.
.
My System SpecsSystem Spec
Reply

 Win7 Half Blind - Can't see VM as Resource




Thread Tools




Similar help and support threads
Thread Forum
WIN7 Resource Monitor
I cannot open the Resource Monitor on my WIN7 64 bit system. I have never used it in the past so I don't know if it ever worked. I have read one article that says it has to be enabled by a lot of playing around with the Registry. Is there any simple way to get it to work. My resmon.exe is in...
General Discussion
Blind leading the blind - insight required
G'Day all. A friend asked me "where do I find a super-simple web page or blog where I can post up some stories (etc) that I've been asked to translate to english?" "Sure. No worries. Easy. i'll find you the best solution & get back to you." I replied. Well I've put my foot in it there. ...
Chillout Room
win7 default show desktop icon resource?
hi, does anyone know where i can find that icon so i can change it even if i need to use reshack
Customization
Stop Win7 reassigning (and half-hiding) my folders
Stop Win7 assigning my folders to its own special ones Hi. This is a year-old Win7 Pro PC that gets very heavy home office use. Just yesterday I noticed that 2 top-level folders I created long ago no longer appear in the Explorer view of folders under C:\. In each case, if I explicitly enter...
General Discussion
The remote device or resource won't accept the connection win7 32bit
my friend is getting this error and cannot connect to the internet so im posting this for him... He downloaded and ran a .reg file that was named crack1 without even reading any comments or anything and it corrupted his internet..... Whenever he tries to go to a website it just says cannot...
BSOD Help and Support
half hdd not showing in win7
aoa just bought ultimatew win 7 and simply its rocking except that i had a problem i have two hdds seagate 80gb(my win and program drive) and wd 500gb for games and other stuff i seagate had two partitions in win xp 21 gb and 53 gb i placed all the data on 53 gb and formated 21gb one and did...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App