Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VMWare Workstation cant connect to the Internet

24 Apr 2009   #11
cefurkan

win 7
 
 

Quote   Quote: Originally Posted by jimbo45 View Post
Hi there
KevinG from Vmware has answered the post
....
Reply2. Re: Windows 7 - both X-64 and X-86 NAT Broken Apr 23, 2009 10:52 AM


Windows 7 is NOT supported at this time because Windows 7 is only BETA software and not a released product.

After Windows 7 is released, support will be added for this host OS


So you may run into some issues with a untested host OS ..................

So you are out of luck at the moment.

VirtualPC or VirtualBox might work but I don't really want to bother with those ---I am lucky in that I can continue with "Bridged" Networking.

Cheers.
jimbo
i am very sick and tired of this "beta os we dont support "


My System SpecsSystem Spec
.
24 Apr 2009   #12
jimbo45

Linux CENTOS 7 / various Windows OS'es and servers
 
 

Quote   Quote: Originally Posted by cefurkan View Post
i am very sick and tired of this "beta os we dont support "
Actually it's not their fault even though it's annoying.

Until you get the actual released OS you can't really spend a lot of time and resources designing a process that might not even exist in the final released version.

A program running a Virtual Machine is extremely complex to write as it has to integrate completely with the running kernels of BOTH the HOST and GUEST OS.

A lot of programs that simply don't use a lot of "Internal Core" windows features will run essentially unchanged even on a BETA OS - for example even large programs like OFFICE will give few if any problems. Most of the "base top layer" of Windows won't have changed much if the programs "Obey the rules and use basic WINDOWS API's.

Things like the .NET interface has changed so programs using the older versions will be a problem for a while.
Also once you start interacting with the actual hardware then it gets more difficult as this stuff DOES change from release to release. This is why things like TV tuner applications, complex Video applications, and Vitrtual Machine software tend to be the hardest applications to upgrade to the new OS.

You can see from the amount of Build leaks etc et we've already had since the beta that you cant expect Microsoft to dish out fully working Windows source code to everybody -- how long before you'd see it on"The Bay" (Is there Swedish Jail Network server - judging by the comfortable conditions in most Scandanavian Prisons the'd probably get a BETTER server funded by the taxpayer ).

We'll just have to live with it -- and maybe you can find some way of getting round the ISP 1 IP address restriction you have in the dorm -- you might be able to find a way of setting your HOST machine up as a VPN and then logging on to the Internet from your XP VM machine via the host's VPN and sharing that Internet connection.

Just an Idea BTW - I wouldn't know how to do it so you'll have to ask someone else.

Cheers
jimbo
My System SpecsSystem Spec
24 Apr 2009   #13
cefurkan

win 7
 
 

i wish there were a solution for this
or a small fix maybe
My System SpecsSystem Spec
.

02 May 2009   #14
cefurkan

win 7
 
 

when will vmware new version out

does anybody know

because i really need nat working one
My System SpecsSystem Spec
03 May 2009   #15
nechan

win7.7100x64
 
 

i have the same problem only i can ping a webpage from my vmware workstation.
but if I try to open it with IE I get something with connection problems ...
My System SpecsSystem Spec
04 May 2009   #16
jimwillsher

Win7 x64 RC 7100
 
 

I'm using VMWare Workstation 6.5.2 on Win7 RC x64, and everything works really well. Internet connectivity is fine (Bridged mode for me).


Jim
My System SpecsSystem Spec
04 May 2009   #17
cefurkan

win 7
 
 

Quote   Quote: Originally Posted by jimwillsher View Post
I'm using VMWare Workstation 6.5.2 on Win7 RC x64, and everything works really well. Internet connectivity is fine (Bridged mode for me).


Jim
yeah bridged mode is working
but i need nat
My System SpecsSystem Spec
04 May 2009   #18
jimwillsher

Win7 x64 RC 7100
 
 

Agreed, NAT doesn't work for me either.

Strange thing is, connectivity itself seems to be working - I can :

ping news.bbc.co.uk

and the address gets resolved and I get replies. But both IE7 and Google Chrome refuse to establish connectivity to a website.

So, IP connecivity seems to be "partly" working....
My System SpecsSystem Spec
10 May 2009   #19
cefurkan

win 7
 
 

pfffff
My System SpecsSystem Spec
19 May 2009   #20
Ralph

Microsoft Windows 7 Ultimate 64-bit English
 
 

Hello everybody,

I was able to connect to the Internet through Bridged Networking and Microsoft Loopback Adapter in a NAT-like fashion.

Hint: From the command prompt, run "hdwwiz.exe". This should launch the "Add Hardware Wizard".

I hope this will be useful to someone.

Regards.

Rafael Lopez.
My System SpecsSystem Spec
Reply

 VMWare Workstation cant connect to the Internet




Thread Tools




Similar help and support threads
Thread Forum
Can't connect to the internet in VMware.
Hello, I am virtualizing Windows 8 in VMware. It has 2GB Ram, 30GB Hard Drive, and is 32-bit. My Host OS is Windows 7 Professional, 4GB Ram, 282GB Hard Drive, and is 64-bit. The VMware will NOT connect to the internet. I have tried Bridged, NAT, and LAN, and the others. If anyone can help, It...
Virtualization
Windows 7 + VMWare Workstation 7 - no internet access
I'm running Windows 7 and VMWare Workstation 7, and I cannot access the internet from any virtual machines using bridged connections. I used to be able to, so I'm not quite sure what happened. I did not modify anything within VMWare.... bridged connections are set as they were by default - to...
Network & Sharing
I can't connect to internet by using the VMWare Player.
My host system is 64-bit Windows 7 RTM. And I installed the vmware player 2.5.2. The virtual system is the 32-bit Windows 7 RTM. But the virtual system can't connect to internet, the connect type is "NAT". I also try to use the other two mode, it also can't connect to internet. Does anybody know...
Virtualization
VMWARE XP Machine can't connect to Internet
I have a dell studio 1537 I'am running 7 as my OS and have VMWorkstation 6.5.2, but for the some reason my XP Machine won't connect to the internet I have installed VMware tools, but still can't connect to the internet. The XP machine sees the network adapter. Has anyone been able to successfully...
Network & Sharing
vmware server vs vbox vs vmware workstation
Hi all W7 x-64 host 4GB RAM dual core 2.3 ghz cpu. Host CPU usage with 1 XP pro SP3 2GB Virtual machine running a file copy of a 2GB file. Host machine not running any other app. Virtual Box 24% Vmware workstation 19% Vmware server 11%. Now this shouldn't be taken as a rigorous...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App