Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Service Pack 1 (SP1) installation error: 0x800F0A12

18 Feb 2011   #1
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
Service Pack 1 (SP1) installation error: 0x800F0A12

This may apply to imaged systems:

A disk management tool from another software manufacturer was used to copy (or clone) the disk or partition on which you’re trying to install SP1.

My System SpecsSystem Spec
20 Feb 2011   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

I have used Acronis True Image Home 2011 to image and restore multiple Windows 7 installs and had no trouble upgrading them to SP1.
I wonder what third party disk management tool they are referring to.
My System SpecsSystem Spec
20 Feb 2011   #3

Windows 10 Pro

It could be anything, including ATI, if the right circumstances occur. You might not have an issue but someone else may.
My System SpecsSystem Spec

20 Feb 2011   #4
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

That is good to know. However, some people seem to have that error.
My System SpecsSystem Spec
23 Feb 2011   #5
Julio Cortez

Windows 10 1703

Here is one. At the moment I think GRUB was my problem.

I have this disk layout:
Disk 1 (Samsung Spinpoint 1TB):
 C:\ > 250GB NTFS Windows 7 (primary, with Windows 7 installed)
 D:\ > 500GB NTFS Data (primary)
 S:\ > 150GB NTFS Software (primary)
     > 100GB NTFS Legacy (primary, with XP installed, not accessible through W7)

Disk 2 (Samsung Spinpoint 160GB):
     > 100GB EXT4 /home (primary)
     >  50GB EXT4 / (primary, with Linux Mint 10 installed)
     >  10GB SWAP (which should be used by Linux Mint 10)
In addition, while installing Mint I also installed GRUB (on disk 2) which takes care of loading all the three OSes (I set the BIOS to boot from disk 2 instead of disk 1 which was the default) and everything has always worked great.

Yesterday, as I was normally using Windows 7 (so I first booted into GRUB then asked it to load Windows 7) I downloaded Windows 7 SP1 and tried to update.
It refused to install giving me that very same error (0x800f0a12).
I've tried several times to start the installer as administrator manually (which isn't required, as it asks anyway for elevation a little after it has been laubched) and to disconnect any other device that could interfer (like the disk I have on eSATA) to no avail.

To get it installed with no trouble, I had to restart the machine and enter the manual boot selector to make it bypass GRUB and boot directly into Windows 7 (don't ask me how I got to the conclusion GRUB was the problem, probably it was the beer).
By doing that, the SP1 installed flawlessly.

So, although I solved my problem, I'm here to ask if there's someone more educated than me that could explain me why it has failed in a way and has succeeded in another, seeing that I never moved the disk which Windows was installed on and the OS was just the very same.
I suppose (but it's really nothing more than a guess) that the installer didn't like the fact Windows 7 was not on the "main" boot disk, but I'm curious to know what triggered this kind of behaviour.

Thanks in advance to anyone who could answer this.. And of course also the little rep I can give :)
My System SpecsSystem Spec
23 Feb 2011   #6

Windows 7 Ultimate x86

Hi Julio,

From what I understand, this error is caused by Windows Update being unable to access the system volume (an approx 200mb partition created during Win7 installation, normally inaccessible through the UI but available to the kernel). Apparently GRUB doesn't mount this volume.

More info from MS:

Windows 7 and Windows Server 2008 R2 Service Pack 1 (SP1) installation error: 0x800F0A12

Would you mind being a little more specific about how you resolved it? I haven't attempted SP1 yet but it looks like its going to be a prob for me also because I'm also using GRUB to dual boot on my laptop.

Thanks and cheers!
My System SpecsSystem Spec
24 Feb 2011   #7
Julio Cortez

Windows 10 1703

I guess you're talking about the 100MB partition that should have been created at startup?
Well, my "System reserved" partition is the whole 250GB partition which hosts the Windows 7 files (I followed this tutorial, especially method three, to avoid creating a primary partition for those system files as I had already planned to use all the 4 primary partitions with the scheme above).
The only difference I noticed is this: my system boots by default from the second hard disk (which is the one with GRUB), and it's GRUB that allows me to choose if I want to boot Windows 7, Windows XP or Linux.
So, the cases are two:

1) The case in which I start the PC normally:
After POST, GRUB starts (from Disk 2)
   > GRUB lets me choose which OS to boot (and I choose Windows 7)
      > Windows 7 starts (from Disk 1)
         > Windows 7 SP1 refuses to install with the error code shown above
2) The case in which I choose manually to boot from Disk 1:
During POST, I launch the boot selection popup
   > I choose to boot directly from Disk 1 (so bypassing GRUB, and Disk 2, completely)
      > Windows 7 starts (from Disk 1)
         > Windows 7 SP1 installs with no problem of any kind
So I came to the conclusion that Windows 7 SP1 doesn't like the way the boot sequence is executed if I boot through an external boot loader such as GRUB.

Now I don't know if
  • it's because GRUB is on a different hard disk
  • or just because GRUB handles the boot sequence differently from how Windows 7 does.
_ EDIT ___________________________________________________________

Doing some research I found this blog entry:
Windows 7/2008 R2 Service Pack 1 fails with 0x800f0a12 - Ramblings of a Support Engineer - Site Home - TechNet Blogs

I find among the comments some advice about moving the "boot" flag from the GRUB partition to the Windows 7 one (e.g. with gparted).
This could probably be done in the case you have GRUB on the same HD you have Windows 7 on, and may solve the problem.

In my case, having a "boot" flag for any HD (Disk 1 had the "boot" flag set to the Windows 7 partition, Disk 2 had it set to GRUB) the only thing I had to do was instruct the system to boot once off Disk 1 before Disk 2.
But I'm confident that moving the "boot" flag with gparted would solve it also for people that have GRUB and Windows 7 on the same disk. They should just remember to put it back where it belongs once finished installing SP1
My System SpecsSystem Spec
24 Feb 2011   #8

Windows 7 Professional 64-bit
SP1 installed finally

I tried installing SP1 via Windows Update and by downloading the file, but each time I got the same error message (0x800f0a12). While searching through another Win7 forum I found a solution that worked for me. I also dual boot between Win7 and OpenSuse 11.3 using Grub, and what I did was go into Control Panel, Administrative Tools, Computer Mgmt, and then Disk Mgmt. Right click on your C partition and Mark that partition as Active. Close control panel and all other programs, and then reinstall SP1. I used the downloaded file, right clicked on the file and Run as Administrator which finally installed SP1. Hope this works for you.
My System SpecsSystem Spec
26 Apr 2017   #9

Windows 7 Pro x64

Same problem. I tried making my C drive active as jchorn suggested. Didn't help, same error. Win7 then crashed (surprise, surprise) and would boot up, couldn't find the boot partition. I booted off the Win 7 install disc and was able to run the auto recovery. After the recovery it did boot and SP1 DID install. So definitely something goofy with Windohs not properly recognizing the boot disk.
My System SpecsSystem Spec

 Service Pack 1 (SP1) installation error: 0x800F0A12

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 - Service Pack 1 installation error 8007065E
Hello, I am having difficulty updating windows. Specifically, when I attempt to install service pack 1 (KB2585542), I receive error 8007065E. Before coming to these forums, I tried rebooting the machine and installing with antivirus temporarily disabled. I have since followed the instructions on...
Windows Updates & Activation
Service Pack 1 Installation
Hi, I am having trouble installing service pack 1. I have not been able to install it using windows update and i also have tried to use the update readiness tool but it does not work. I even went so far as to order the DVD from microsofr containing SP1 but even that did not work. I get the...
Windows Updates & Activation
Service Pack installation failed with error code 0x800b0100.
OS is Win 7 Home Prem 64-bit. Cannot install SP1, and one of the .Net 3.5.1 updates (KB2656355 and KB976932). Get Error: TRUST_E_NOSIGNATURE(0x800b0100). Have tried many of the suggs, but can't seem to lick this. After running SURT, looking at the CheckSUR.log, it appears that a third KB is mucking...
Windows Updates & Activation
Created boot partition manually, Service Pack update error 0x800F0A12
I reinstalled Windows recently, but it used the same boot partition from my old installation. I got rid of the old partition (it was on the wrong hard drive) and created a new one with the repair disc. Windows boots, but won't install updates. Bcdedit outputs The boot configuration data store...
Windows Updates & Activation
Windows 7 32-Bit Service Pack 1 Installation Error...
Wonder if you guys can help with an installation of SP1 for Windows 7 32-Bit. I have attached the cbs.log containing the error information however all the fixes suggested around the net (disable AV, selected startup, install in safe mode etc) don't work and the service pack still fails to install....
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:45.
Twitter Facebook Google+