Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 SP1 x64 Install Error 0x80070490

04 Mar 2011   #21

Windows 7 Ultimate x64

I was on a chat and remote with Microsoft for 3 hours last night and it is still not installed. He told me to back up my laptop and run an upgrade in place. That is what I am attempting now.

My System SpecsSystem Spec
04 Mar 2011   #22

Windows 7 Ultimate x64
Finally got Win7 x64 SP1 to install

After receiving multiple errors (seemed like a different one every time) while trying to install Win7 SP1 on my system, I came here to review the many threads. After trying many things and many hours or troubleshooting, I decided to do a system image and start from scratch... Below are the steps that I took that allowed the SP1 to install on a totally clean install.

1. Before Format, downloaded the Windows SUR package and the SP1 x64 standalone installer and saved to secondary storage hard drive.
2. Booted from Win7 x64 Ultimate full install disc.
3. Used Custom install
4. Formatted main system drive where windows was to be installed
5. Let windows install
6. Upon installation did not download any Windows Updates or other drivers (this includes video and sound). Just used stock windows drivers.
7. Ran SUR package saved on secondary drive
8. Rebooted computer in Safe Mode with Command Prompt
9. Changed to drive with SP1 x64 Installer and ran file from command prompt
10. Let installer run
11. Once complete and computer rebooted, let system boot to Windows in Normal Mode
12. Windows booted and said it was installing Service Pack and then finally boot all the way up.
13. Checked in Control Panel to verify SP1 installation and it was listed.
14. Proceeded to Run Windows Update and download all additional updates.
15. Finally installed audio and video drivers and then antivirus.
16. System appears stable and snappy. Have not had any crashes or other issues.

This was a long process and took some time but hopefully this will help others looking to install SP1 that are receiving errors. Doing this process from the beginning was actually quicker than the time I wasted trying to find a solution without a clean install.
My System SpecsSystem Spec
12 Oct 2011   #23

Windows 7 Home Edition X64

I am encountering this issue on my wifes Dell XPS laptop, we have 5 computers at home with Windows 7 x32 and x64 and only her laptop report this 0x80070490 error, followed the click me link on the error page, did the procedures , the windows cleaner what ever the name was, and teh readiness tool, and that one actually made my updates needed from only sp1 to 7 updates, so rebooted and redid the update , all installed expect sp1, it just refuses to install, wife doesnt want a reformat/install because she has a lot stuff she needs on a daily basis. (uses it at work but is personal computer).

I am at a lost after reviewing what to try to get this to go through.. any though on what can I run to get "idea" where the problems lies, ion a msd site I saw something about scannow, but I did did not understand it
My System SpecsSystem Spec

27 Dec 2011   #24

Windows 7 Professional x64

I realize this thread is old, but I'm posting this because I do see some people still having the issue. Additionally, this site is the first hit on Google if you search for "0x80070490 SP1"

So, if you are having these problems please refer to my solution that I provide in this location:

Windows 7 ERROR_NOT_FOUND 0x80070490 while trying to install SP1

Good luck!
My System SpecsSystem Spec
27 Dec 2011   #25

Win 7 Ultimate 64-bit. SP1.

I will read through your link when I can grab a bit of time.
Thank you for sharing with us here.

Happy Holiday & New Year.
My System SpecsSystem Spec
28 Dec 2011   #26

Vista Home Premium x86 SP2

Quote   Quote: Originally Posted by BenH View Post
I realize this thread is old, but I'm posting this because I do see some people still having the issue. Additionally, this site is the first hit on Google if you search for "0x80070490 SP1"

So, if you are having these problems please refer to my solution that I provide in this location:

Windows 7 ERROR_NOT_FOUND 0x80070490 while trying to install SP1

Good luck!
Hello, and welcome to the Seven Forums!

Thank you so much for posting this. It will really help those suffering this problem in the future.

To summarise the thread, whilst possibly adding in a few of my own comments, for Windows Vista this is an extra solution: Error message when you install an update by using Windows Update on a computer that is running Windows Vista or Windows Server 2008: "0x80070490"

For Windows 7, this error more often means ERROR_CODE_ERROR_NOT_FOUND than JET related errors, and effectively becomes error 0x490-->0n1168.

In Windows 7, that error code is very general, and can mean a lot more than what is in that thread. In reality, that error code usually only means what that threads talks about, because less general error codes are usually used. Error codes are complicated!

Technical stuff over :)

What to try:

The System Update Readiness Tool: Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows 7, and for Windows Server 2008 R2

If that fails, the solution here: The error 0X80070490(Element not found) when you are installing a service pack or update - Microsoft Reduce Customer Effort Center - Site Home - TechNet Blogs

This basically comes down to what Ben-IS said in that thread, except that some of his Access is Denied stuff is a bit dodgy. I would leave out all of the Access is Denied Stuff. I can never recommend deleting (even with a backup) live Windows files whilst supplying no alternative. Better solutions involve giving permissions to the TrustedInstaller. What mfx2525 did is good.

If you don't feel happy doing that, please post for help here: Windows Updates & Activation - Windows 7 Forums, and we can help you :)

After that, either post a new thread here, or try a Repair Install: Windows Update error 80070490
My System SpecsSystem Spec
08 Jan 2012   #27

Windows 7 Professional x64


- thanks for your welcome words.

I believe that you should go and review the issue and details I posted in my thread over on the microsoft forums.

Now, for full disclosure I didn't read through this entire thread here. I read enough to see that many were having the problem and that no one had come up with a proper solution.

The issue at hand with the SP1 install to Windows 7 - which is what this thread is about (so no need to discuss the Vista or 2008 topics) - has to do with problems in the the driver catalogs.

I can guarantee that if you don't follow my instructions as I wrote them in the linked thread regarding the access denied errors then you will not be able to solve the issue (I evidence this by the dozens of posts I've seen by people having this issue who could only resolve it following my steps).

There is nothing "dodgy" about my recommendations - what is dodgy is how Windows 7 deals with security :). Reinjecting the driver with the pnputil effectively updates the catalog. However, this won't work in many cases because of the permissions on the file. Renaming the file as I suggest will allow the driver to be reinjected.

Thus I am (A) NOT recommending to delete any files, simply rename them and (B) my method of running the pnputil will immediately copy the appropriate file back to the store so when you say I am supplying "no alternative" - I'm not sure what you mean.

Additionally, I'd like to note that the link you posted from the Microsoft Reduce Customer Effort center was basically a MS tech who created a blog entry that contained all the steps that everyone found unsuccessful in solving this problem, followed by a quick reference to what I detailed in my post. In essence, they stole my solution (not like I'm trying to copyright it ) and did a very poor job of explaining the more important parts of it!

I don't know why so many people feel obligated to try to summarize an already streamlined procedure and thus create more confusion or misinformation.
I highly recommend if you are experiencing this issue to just look at my post in the original thread

good luck!

Oh - I also want to note that the recommended solutions of doing an in-place upgrade my work for some, and I suspect many home users would simple skip to that since it is a sweeping approach. i arrived at my solution since I didn't feel running an in-place upgrade on multiple systems was a feasible approach for a sys-admin. Granted, my method isn't easily automated, but should be much quicker.
My System SpecsSystem Spec
26 Jan 2012   #28

Linux Lite 3.2 x64; Windows 7, 8.1

Ben - thanks so much. I ran through the solution and found only one offending driver - for usb video, whatever that is, and corrected the situation. The SP1 install then sailed through on a Win7 Starter 32bit install. Amazing.

I've been seeing a lot of rough edges on MS updates of late, and pretty poor remedial support on it from MS. Solutions like this should be coming top-down, the same way the problems come. But since MS hasn't been doing the job, I'm grateful to guys like you who are.
My System SpecsSystem Spec

 Windows 7 SP1 x64 Install Error 0x80070490

Thread Tools

Similar help and support threads
Thread Forum
Cannot install SP1 ERROR_NOT_FOUND 0x80070490 Please help
Hello, I have been trying to install sp1 but have been having much difficulty. I have tried the sfc /scannow and the system update readiness tool. I have uploaded the CheckSUR.log Any help would be greatly appreciated
Installation & Setup
Update KB2726535(x64), Error 0x80070490
For a few days I am trying to install the update KB2726535; I always get the Error 0x80070490. Tried everything to fix it, but nothing worked. You are my last hope! Thank you for helping me, 2press
Windows Updates & Activation
This has been an ongoing issue since my first attempt to configure it on 24 June 2011: It always reboots @ 10% during the configuration; restarts @ 7% configuring, then fails completely @ 10%. Error: ERROR_NOT_FOUND(0x80070490) STEP 1: Before attempting any fixes, this was the result after...
Windows Updates & Activation
How to fix error 0x80070490 so windows 7 sp1 will install
Have tried for several days to install SP1 on Windows 7 Ultimate. Ran/installed System update readiness tool, ran the CSC log, ran the windows update troubleshooter and still no luck. Last update received was at 8:42 pm (PST) for KB978821. Please help if you can.
Installation & Setup
Cannot Install Win 7 over XP Home~ERROR Code: 0x80070490
Greetings Friends. I have an unfortunate problem with Windows 7. I purchased it for installation on a PC on which I've long been happily running XP; it was time to update. The new Win 7 installed beautifully on my lapotp with Vista on-board. Here is what occurs: the first language I get...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:29.
Twitter Facebook Google+