Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gateway error in Win7 SP1

06 Apr 2011   #1
dirt316hoerr

Win 7 ultimate x64
 
 
Gateway error in Win7 SP1

So i installed windows 7 SP 1 on my computer and now it wont remember the gateway the i have set for my computer to use. I dont have anything fancy set up, i just have it so my router always gives my computer the same IP so i can host a server off it. However upon reboot i have to plug in the gateway into my adapter settings everytime. It remembers bothe the Ip adress i asigned, the mask, and the DNS servers, but it refuses to remember the gateway (which is the default 192.168.1.1) im using a netgear router WNR3500L with the original firmware, and my network card is a realtek PCIe GBE family controller, one that worked before the update, and was saving the gateway. any help would be greatly appreciated. Thank you


My System SpecsSystem Spec
.
07 Apr 2011   #2
dirt316hoerr

Win 7 ultimate x64
 
 

so 40 views and no help?
My System SpecsSystem Spec
08 Apr 2011   #3
dirt316hoerr

Win 7 ultimate x64
 
 

bump....
My System SpecsSystem Spec
.

08 Apr 2011   #4
Fayla

Windows 7 Professional 64 Bit SP1
 
 

This thread: Default Gateway missing after re-start has a discussion about this issue.

Various fixes are suggested but I read a couple of posts saying that this one worked (feel free to try the others though if you want):
Quote:
Solution

1. Open the registry with regedit.exe
2. Go to the path: HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/
3. Here you'll need to select the CLSID of your networkadapter where you change the settings. You'll probably recognize it by looking at the value IPAddress that will have the IP of this adapter.
4. Open the value "DefaultGateway" by doubleclicking it. You will see a list of all the gateways that disappeared! (maybe in your case it will be only one, in my case there were due to lots of testing several addresses) Very likely, the first line will be empty. I'm not sure, how this little flaw can make such a big problem. However, if you manually remove this first empty line, click OK and reboot your system everything should be working fine again.

After doing this, everything seemed normal to me. I could change the GW manually and by NSM. After a reboot everything was still there. Of course it needs to be verified in a long-term use if it fixes it forever or if the problem comes back at some point.

Thank you Ilja Herlein!
Tyler McLaughlin

Quote   Quote: Originally Posted by dirt316hoerr View Post
So i installed windows 7 SP 1 on my computer and now it wont remember the gateway the i have set for my computer to use. I dont have anything fancy set up, i just have it so my router always gives my computer the same IP so i can host a server off it. However upon reboot i have to plug in the gateway into my adapter settings everytime. It remembers bothe the Ip adress i asigned, the mask, and the DNS servers, but it refuses to remember the gateway (which is the default 192.168.1.1) im using a netgear router WNR3500L with the original firmware, and my network card is a realtek PCIe GBE family controller, one that worked before the update, and was saving the gateway. any help would be greatly appreciated. Thank you
My System SpecsSystem Spec
Reply

 Gateway error in Win7 SP1




Thread Tools




Similar help and support threads
Thread Forum
The default gateway is not available WNDA4100 error
So about two weeks ago I bought a new adapter, a Netgear WNDA4100. The Internet had been working great up until this Afternoon, at which point I began receiving the little yellow error exclamation point over my connection while not being disconnected from the Internet. Ran a troubleshoot and got a...
Network & Sharing
Gateway Installation Disc Error 0xc000000f
Ok, so Ive been playing Minecraft on my PC and I went to bed, so I turned off my PC. The next morning I got Windows Startup Repair or Start Windows Normally. That never happened before, so I did some research and now I have a new error. This is the error: Windows failed to start. A recent...
Hardware & Devices
BSOD Recurrence On Gateway Gateway NV53 -- Will Only Boot In Safe Mode
Windows 7 Home Premium (x64) Service Pack 1 (build 7601) Hello: At the beginning of Sept 2012 I posted a BSOD thread here that was eventually resolved. The situation then, as now, was/is that I received an error about Windows Desktop Manager then went to BSOD. I received some great...
BSOD Help and Support
Gateway Laptop Win7 unbootable, startup repair loop
Hey everyone, So I've got a gateway laptop here that one day was booted up and went to a boot menu screen stating there were errors with the option to launch startup repair. After doing so there has been no sucess, after a looooong process of checking for errors, it says it's unrepairable,...
Performance & Maintenance
Keep getting Default Gateway Not Available Error, Need Help!
Hi all. I am having a horrible problem right now with the default gateway error in windows 7. I am on my laptop which is only 3 months old and has worked perfectly fine until about 3 days ago. I keep losing connection after several minutes, or if I try to stream something online. I am on a wireless...
Network & Sharing
Win7 no internet connection at startup but works after pinging gateway
OK so i upgraded some of our PCs from a old machines running XP to a new DELL running Win7 Professional 32 Bit - I am on a wired LAN with a server and separate gateway/firewall PC When I start my PC everything is just fine - connects to the network etc and I start receiving my e-mails from...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App