Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sp1 , was not able to install

02 May 2011   #1
drugo

windows 7 ultimate 64bit
 
 
sp1 , was not able to install

Hi

i used the internal update module to download the sp1 for windows 7 32bit

it downlaoded and installed
after the reboot , it tried to configure the sp1 , but stopped with an error

what can i do ?

id event 20
Installation error. It was not possible to install the following update, error 0x800f0826: Windows 7 Service Pack 1 (KB976932).




My System SpecsSystem Spec
.
02 May 2011   #2
drugo

windows 7 ultimate 64bit
 
 

does w7 some service(maybe i stopped) or some feature to install the service pack?

my copy is legit

thanks
My System SpecsSystem Spec
02 May 2011   #3
wysiwyg

Vista Ultimate 32 bit, Win 7 Pro 32 bit, Win 7 Pro 64 bit
 
 

If you have a corrupt file on your system it will refuse to Install/configure.
My System SpecsSystem Spec
.

02 May 2011   #4
johnnya

Windows Home Premium 64bit
 
 

To check for corrupt files, run the following command in an elevated command prompt.

sfc /scannow

Hope this helps
JohnnyA
My System SpecsSystem Spec
02 May 2011   #5
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by wysiwyg View Post
If you have a corrupt file on your system it will refuse to Install/configure.
i installed some hotfixes released after the sp1 , could be the issue?

Quote   Quote: Originally Posted by johnnya View Post
To check for corrupt files, run the following command in an elevated command prompt.

sfc /scannow

Hope this helps
JohnnyA
thanks i will try
My System SpecsSystem Spec
03 May 2011   #6
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by johnnya View Post
To check for corrupt files, run the following command in an elevated command prompt.

sfc /scannow

Hope this helps
JohnnyA
it failed , it told me some files could not be recovered
it saved a hug log file

the service pack nane is
windows6.1-KB976932-X86.exe

and it send to this page Risoluzione dei problemi di installazione di un Service Pack per Windows 7


Attached Images
sp1 , was not able to install-cattura.jpg 
My System SpecsSystem Spec
03 May 2011   #7
hjonesMCT

Win7 Ultimate x64, Server 2008 R2
 
 

Nearly the same happened to me. I had to install almost ALL the "optional and recommended" updates FIRST...then it seemed my system was ready for sp1. Go to Windows Update and see if you have any other updates pending, and install them (except language packs).

Hope this helps!

Heather

My System SpecsSystem Spec
03 May 2011   #8
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by johnnya View Post
To check for corrupt files, run the following command in an elevated command prompt.

sfc /scannow

Hope this helps
JohnnyA
but sfc /scannow should ask me the original dvd , shouldn't?

thanks
My System SpecsSystem Spec
03 May 2011   #9
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Windows 7 will not ask for the DVD like it used to do in XP. All of the system files are contained within the operating system. (See post # 113, last page in this tutorial.)

SFC /SCANNOW Command - System File Checker

If SFC detects any damaged, corrupt, etc files it's suggested to run the scan three times because of file dependencies. Just as an example, first scan may repair files D and G, but A, B and C might not be repaired until E and F are repaired during the second scan.

You might also want to take a look at this Microsoft article. It has some suggestions for a successful install.

Learn how to install Windows 7 Service Pack 1 (SP1)
My System SpecsSystem Spec
Reply

 sp1 , was not able to install




Thread Tools




Similar help and support threads
Thread Forum
Windows update fails to install IE10 after repair install
I did a repair install of W7 Ult. x64 SP1. Applied all updates, but if fails to install IE10 update : (as you see it is a dutch version). If have run sure & sfc /scannow. Both report no problems. CBS files are attached. Please help ?
Windows Updates & Activation
Windows 7 Install - Cannot install required files... Error message
I have been trying to do a clean install of windows 7 and I am now getting this message. I have probably done a clean install using the exact same disk 5 times before. I've tried formatting the hard drive and re partitioning. This is a custom build. The thing that is interesting to me is that I...
Installation & Setup
BSOD playing Guild Wars 2, recent SSD install and fresh install of W7
I just added a new SSD drive and installed a fresh copy of Win 7 Enterprise. I have had a previous driver issue with this system in the past. The amazing people on this site helped me work it out. Now for the life I just can't seem to sort it out again myself this time. I ran and uploaded the...
BSOD Help and Support
BSOD on fresh install when install updates, misc error codes
My system info is in my profile, installing Windows 7 x64 Ultimate Retail. Attached is all of the report info. I have no idea what is going on. Whenever I try to install all of the Windows updates it blue screens. Then it will reboot, try to apply the updates, and blue screen again. I've run...
BSOD Help and Support
Windows 7 Install Disc fails to see hard disk after Ubuntu install
After I tried to make a dual boot with Ubuntu and Windows 7 Ultimate (64-bit), Windows now does not boot. I have tried to reinstall and repair the HDD but the disc fails to recognize my HDD (Western Digital Scorpio Black 500 GB). My HDD is Basic, has 3 primary partitions and 1 extended (3 logical)....
Installation & Setup
Office 2010 programs wont install / lauch after install
one of my co-workers wants me to get rid of some viruses and install office 2010 home and student on her computer with the key she bought. her computer runs windows 7 64-bit. after backing up her data, i finally ended up doing a factory reinstall from the backup partition. so i downloaded all...
Microsoft Office


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App