Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Same Update (KB2467175) Keeps Appearing

11 Jun 2011   #1

Windows 7 Home Premium 32bit
Same Update (KB2467175) Keeps Appearing

I have successfully installed the same update KB2467175 at least five times and it continues to appear as an important update that should be downloaded and installed. What's up with this?

My System SpecsSystem Spec
11 Jun 2011   #2
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit

Try a manual install for this update here.
Download details: Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update

Your specs show Win 7 32bit so download the vcredist_x86.exe.

Follow prompts and restart if asked to do so.

Let us know if that works.
My System SpecsSystem Spec
12 Jun 2011   #3

Windows 7 Home Premium 32bit

Tried your suggestion but it didn't work. Gave error: "Error 1606. Could not access network location %APPDATA%\."
My internet connection was active. Can you suggest any other fixes? Thank you for your help.
My System SpecsSystem Spec

12 Jun 2011   #4
Layback Bear

Windows 10 Pro. 64/ version 1709

Here is a little something from Microsoft that might help you. Suggest you read through all of it before doing anything.
Repeatedly offered KB2467175 (Microsoft Visual C++2005 - Microsoft Answers
My System SpecsSystem Spec
20 Jun 2011   #5

Windows 7 Ultimate 32 bit

I solved it! I’m on Windows 7 32 bit.
For me, this problem became a bigger problem when I could not install Nero10 which wanted to use the right C++2005 Redistributable. So the suggestion to just hide the update is not sufficient.
Here's how I solved it:
Elesewhere it is often suggested to try and install the update manually. This always ended in failure with the update asking me to specify the right path to the update and never accepting it.
Then I noted there are several versions of the vcredist_x86.exe around. The one that worked for me is the 6.0.3790 that I found here:
Download Confirmation - Microsoft Download Center
Just to be complete, I also found a v. 6.0.2900 that didn’t work which is here:
Download Details - Microsoft Download Center - Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update
so don’t download that.
Try to just install the 6.0.3790 first, maybe this is just a better or bugless update. If that doesn’t work, well, here’s what I did just before that:
In the Windows uninstall software page (not on the installed updates page) you will find one or more Microsoft Visual C++ 2005 updates (and 2008). I tried uninstalling the 2005 ones (we’ll put them back later) , and then again the resource not found error came up, making it impossible to uninstall.
Then, with Tune up Utilities 2010, I was able to just kick the entry from the installed software list. Ashampoo Uninstaller and some other utilities also have the option to get something off the list if you cannot uninstall them. It just scratches the entry in some way. Possibly some regedit hack could do it too.
After this and a reboot to make sure, I was able to install the 6.0.3790 update found on the first link above. From there on, windows update will pick up any updating and reinstalling of the redistributables that is left to do. And after that Nero10 installed fine as well.
I hope this works for some people and saves you time. If it works please post something in response(thanks?) I would appreciate and enjoy that!

My System SpecsSystem Spec
21 Jun 2011   #6

Windows 7 Home Premium
2005 Service Pack1

Any one understand why the following repeats at every shut down? This has been happening since the 15/6/11 and is very irritating I have now hidden the update..

Security Update for Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package (KB2538242)
Installation date: ‎20/‎06/‎2011 21:47
Installation status: Successful (is it, if so why so many repaeats?)
Update type: Important
A security issue has been identified leading to MFC application vulnerability in DLL planting due to MFC not specifying the full path to system/localization DLLs. You can protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.
More information:
My System SpecsSystem Spec
21 Jun 2011   #7
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit

You will need to manually download the update and install. Reboot if prompted after install.
Go to this link > Download details: Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package MFC Security Update

There are three downloads listed. You will need the second or third marked as below.

vcredist_x64.EXE This is for 64bit.

vcredist_x86.EXE This is for 32bit.

Since you did not post which version of Windows Home Premium you have you will need to find out then select proper download.
My System SpecsSystem Spec
21 Jun 2011   #8

Windows 7 Home Premium

Gentle admonishment to me (its 64bit)!

Very much a newby (76yrs)

Thanks for speedy response. I did the manual load but not your other suggestion - v-credist etc.

I will let you know.
My System SpecsSystem Spec
21 Jun 2011   #9

Windows 7 Home Premium
Still unsolved!


Tried it twice - still no joy! It was this update you were referring to (KB2538242)? I hope.
I'll hide the update, 'though it troubles me (especially as I don't know what its all about), when I see 'important' attached to it.

Perhaps I went to the wrong thread?
My System SpecsSystem Spec
21 Jun 2011   #10
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit

Sorry that didn't work.
It works about 95% of the time.
Yes it was the right one I double checked it.

This was down the page from the download buttons.
Additional Information
Please see the Knowledge Base Articles KB2538242 for more information.
Top of page

Related Resources

My System SpecsSystem Spec

 Same Update (KB2467175) Keeps Appearing

Thread Tools

Similar help and support threads
Thread Forum
Green flecks appearing after update?
Hi there, Recently updated my laptop and following the restart green flecks have appeared littered across the screen, which are not there where the laptop is switched off - I have attached a photo which should give you some visual reference. I've tried restoring the system back one update,...
Graphic Cards
Windows 7 SP1 not appearing in Windows Update
Hi all, Windows SP1 has been out for quite a while, but despite this, Windows 7 SP1 refuses to show up in Windows Update. I have unhidden and installed all hidden updates and followed all steps (apart from step 6) on this Windows help site: You do not have the option of downloading Windows 7 SP1...
Windows Updates & Activation
Windows 7 update fails and Windows not genuine message is appearing
Computer built 06/2011 with Windows Pro 64 bit. Overheating caused a RAM failure and video card failure. During repairs, upgraded Intel SSD. First, Windows update started failing and just recently, started receiving the "not genuine message". Tried reactivating which was successful. Still getting...
Windows Updates & Activation
Re-Appearing Icons ?
Hello, Not at all sure that this is truly a W7 related problem, but thought I'd ask anyway. Sure is weird, though. Have never bothered with .wav files before, but tried to download a few of them that had some radio stuff recorded on them. I started the download, then quit, as they said...
General Discussion
Devices appearing
hi, i have had two new devices appear in my device manager, SM Driver (SM bios service) & Microsoft eHome Infrared transceiver. The Microsoft eHome Infrared transceiver is to do with my infrared but why has it installed now when i've had the CIR Driver installed for a couple of months now and...
Hardware & Devices
Red x's appearing in WLM
I'm beginning to see red x's where an image should be in incoming mail. For instance, my GM dealer sent an ad with service deals, but all images are a red x. I've changed no settings, and yet, something must have changed because I've not encountered it before. I went to Tools >Options thinking...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App