Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CBS Registry Errors

02 Jul 2011   #11
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

Awesome Niemiro!!!

Quote:
A Repair Install doesn't just fail randomly. So it still won't install. However, if we fix it up to nearly perfect, and then do a Repair Install, we might just be able to fix this.

Also, before we start, I want to see which packages are corrupt. If they all originate from a few updates (1 update can contain many packages) we might be able to do an uninstall of that update, and then reinstall it (there are FAR more powerful ways of uninstalling an update than through Add/Remove programs :P)
I'm right on board with all of this! Here are (should be anyway) all of the Logs you've requested. For security purposes, COMPUTER, DOMAIN and USERNAME(S) have been blocked out where they exist.

dziękuję,
Drew


My System SpecsSystem Spec
.
02 Jul 2011   #12
niemiro

Vista Home Premium x86 SP2
 
 

No problem, Drew! This is a fascinating challenge!

However, I want to delay things *again*, and first fix another small corruption (very much like the one you found)

From your CBS.log (x many)

Code:
2011-07-01 17:33:33, Info                  CBS    Invalid character in name: Package_2_for�KB2345316 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Failed to validate component name: Package_2_for�KB2345316 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Failed to load identity from attributes. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to create identity from string: Package_2_for�KB2345316~31bf3856ad364e35~amd64~~6.1.1.6. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to get identity from key form: Package_2_for�KB2345316~31bf3856ad364e35~amd64~~6.1.1.6 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to populate children. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to initialize internal package for package: Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~amd64~~6.1.7601.17514 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Delay load failed for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Delay Initialization Failed [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Session: 30160950_2267298141 initialized by client WindowsUpdateAgent.
2011-07-01 17:33:33, Info                  CBS    Invalid character in name: Package_2_for�KB2345316 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Failed to validate component name: Package_2_for�KB2345316 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Failed to load identity from attributes. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to create identity from string: Package_2_for�KB2345316~31bf3856ad364e35~amd64~~6.1.1.6. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to get identity from key form: Package_2_for�KB2345316~31bf3856ad364e35~amd64~~6.1.1.6 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to populate children. [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Failed to initialize internal package for package: Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~amd64~~6.1.7601.17514 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Info                  CBS    Delay load failed for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80070057 - E_INVALIDARG]
2011-07-01 17:33:33, Error                 CBS    Delay Initialization Failed [HRESULT = 0x80070057 - E_INVALIDARG]
Could you have a look in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect

and basically go hunting for: Package_2_for�KB2345316~31bf3856ad364e35~amd64~~6.1.1.6

and if you find it, change it to an underscore.

I think that this corruption will be located there...hopefully you will be able to find it!

Richard
My System SpecsSystem Spec
02 Jul 2011   #13
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

Good catch my Friend! Can't believe I missed that one, as it was right in front of my FACE! LOL Sometime we look too deep...

At first I searched the entire leg of the Registry that you mentioned, but everything looked fine. I then searched the entire HKLM for the string "KB2345316~31bf3856ad364e35~amd64~~6.1.1.6" and found / fixed it under the following;

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~amd64~~0.0.0.0]
"Package_for_KB2345316~31bf3856ad364e35~amd64~~6.1.1.6"=dword:00000002
"Package_for_KB2345316_RTM~31bf3856ad364e35~amd64~~6.1.1.6"=dword:00000002
(FIXED HERE) "Package_2_for_KB2345316~31bf3856ad364e35~amd64~~6.1.1.6"=dword:00000002
"Package_for_KB2525835~31bf3856ad364e35~amd64~~6.1.1.2"=dword:00000002
"Package_for_KB2525835_RTM~31bf3856ad364e35~amd64~~6.1.1.2"=dword:00000002
"Package_8_for_KB2525835~31bf3856ad364e35~amd64~~6.1.1.2"=dword:00000002
"Package_for_KB2525835_SP1~31bf3856ad364e35~amd64~~6.1.1.2"=dword:00000002
"Package_2_for_KB2525835~31bf3856ad364e35~amd64~~6.1.1.2"=dword:00000002


Seems to be fine everywhere else in the reg (about ~55 hits total). I also ensured the COMPONENT leg of the Registry was loaded by running Windows Update and scanning for Updates - just to be sure nothing was screwed up in there as well.

Repaired, rebooted, ran SURT (it fixed 1 Error this time around), re-ran SURT again and here's the Post of the CheckSUR.logs after that. (NOTE: I had to take Ownership and give Administrators full rights, but reversed this back to SYSTEM as Owner and Read-only for Admins after the fact.)

Server Manager is now FINALLY working properly for Role and Features!!! So we made progress!!! Still only one "Important" update in Windows Update (2008 R2 Service Pack 1), and two "Optional" Driver Updates that I care nothing about at this point...

THANKS BRUTHA!!!
Drew


Attached Files
File Type: zip CheckSUR_Logs_2nd.zip (38.1 KB, 25 views)
My System SpecsSystem Spec
.

02 Jul 2011   #14
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

P.S. For giggles, I re-ran RegistryBooster 2011 and it found 9 System Related Reg Errors. Out of these, 8 are "System Software Settings" and 1 is "ActiveX, OLE, COM sections". I'm holding off telling it to repair these unless you agree. My thinking is why not let it fix 'em, but I don't want to let it repair these if you're not on board with it Niemiro. Please let me know...

Drew
My System SpecsSystem Spec
03 Jul 2011   #15
niemiro

Vista Home Premium x86 SP2
 
 

Very well done! I really didn't know where that corruption was going to be, so couldn't be of much help, so well done

Well, I bring important news. One of the reasons why I sent you away to fix that was because I wanted more time to think over this case. And I believe that I have now worked out exactly what is causing this issue, and so many corrupt registry keys/values.

Quote:
Also, before we start, I want to see which packages are corrupt. If they all originate from a few updates (1 update can contain many packages) we might be able to do an uninstall of that update, and then reinstall it (there are FAR more powerful ways of uninstalling an update than through Add/Remove programs :P)
I was looking through, trying to make sense of so many different errors (go through the CBS.persist.logs, and you will see so many more, and varied errors) Could I find a pattern...yes!

All of the packages do not come from a few discrete updates, actually, they all come from core Windows. The only thing I can think of for this, is a badly failed SP1 update. Basically, those components were in the process of being updated to SP1, and then SP1 fails/crashes/something, and they all become corrupt. That is why you have so many corrupt registry keys/values, and that is why it is those particular registry keys/values.

This leads to a lot of questions (and one of those questions will, I am sure, be "What is the fix!")

Do I want to fix all of these (which means removing package from package watchlist). Do I want to fix just the missing Deployment Keys? If I remove all of these Core (but not necessarily critical) components, are there SP1 components to stand in their place. Would I cause more harm by removing them.

Taking as a fact (unless you have a better theory) that SP1 is half installed, and half not installed (rather than not installed after multiple failures) do I want to get to a state of SP1 installed, or a state of SP1 not installed.

Difficult questions! For better or worse, I have made up my mind. I wish to try to uninstall SP1, (which avoids much of the possibly dangerous removing or not removing of package watchlist components) and then with SP1 uninstalled, I plan to do a Repair Install. After that, we shall re-run SURT, I shall go through the logs, and then if all looks well, try SP1 again.

But why did SP1 fail? If these errors are caused by a failure of SP1, what caused SP1 to fail. IMPORTANT QUESTION: Did you PSU fail while installing SP1, and therefore cause these corruptions, or did it fail earlier, causing a corruption which failed SP1? I went through the other logs...

and each of these had many repetitions:

Code:
2011-05-28 06:42:12, Error                 CSI    00000a2c (F) STATUS_OBJECT_NAME_NOT_FOUND #70972327# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey(flg = 0, key = {provider=NULL, handle=0}, da = (KEY_READ|DELETE|KEY_WOW64_64KEY), oa = @0xe2cf30->OBJECT_ATTRIBUTES {s:48; rd:NULL; on:[213]"\Registry\Machine\COMP\u804fNENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFamilies\amd64_microsoft-windows-bubbles.resources_31bf3856ad364e35_en-us_51f2b3972f87c6d0\v!6.1.7600.16385"; a:(OBJ_CASE_INSENSITIVE)}, disp = Unmapped disposition: 14865144 (0x00e2d2f8))[gle=0xd0000034]
2011-05-28 06:42:12, Error                 CSI    00000a2d@2011/5/28:10:42:12.214 (F) d:\win7sp1_gdr\base\wcp\sil\merged\ntu\ntsystem.cpp(3676): Error STATUS_OBJECT_NAME_NOT_FOUND originated in function Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey expression: (null)
[gle=0x80004005]
2011-05-28 06:42:12, Error                 CSI    00000a2e (F) STATUS_OBJECT_NAME_NOT_FOUND #70972326# from Windows::Rtl::SystemImplementation::CKey::OpenExistingKey(f = 2, da = (KEY_READ|DELETE), oa = @0xe2d390, key = NULL, disp = (null))[gle=0xd0000034]
2011-05-28 06:42:12, Error                 CSI    00000a2f (F) STATUS_OBJECT_NAME_NOT_FOUND #70972321# from Windows::Rtl::SystemImplementation::CKey::DeleteRecursively(...)[gle=0xd0000034]
2011-05-28 06:42:12, Error                 CSI    00000a30 (F) STATUS_OBJECT_NAME_NOT_FOUND #70907804# from Windows::Rtl::SystemImplementation::CKey::DeleteRecursively(...)[gle=0xd0000034]
2011-05-28 06:42:12, Info                  CBS    Failed to get CSI store. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2011-05-28 06:42:12, Error                 CBS    Failed to initialize store parameters with boot drive:  and windows directory:  [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2011-05-28 06:42:12, Error                 CSI    00000a31 (F) STATUS_OBJECT_NAME_NOT_FOUND #71046189# from Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey(flg = (AllowAccessDenied), key = {provider=NULL, handle=0}, da = (KEY_READ|DELETE|KEY_WOW64_64KEY), oa = @0xe2cf30->OBJECT_ATTRIBUTES {s:48; rd:NULL; on:[213]"\Registry\Machine\COMP\u804fNENTS\DerivedData\VersionedIndex\6.1.7601.17592 (win7sp1_gdr.110408-1631)\ComponentFamilies\amd64_microsoft-windows-bubbles.resources_31bf3856ad364e35_en-us_51f2b3972f87c6d0\v!6.1.7600.16385"; a:(OBJ_CASE_INSENSITIVE)}, disp = Unmapped disposition: 14864080 (0x00e2ced0))[gle=0xd0000034]
2011-05-28 06:42:12, Error                 CSI    00000a32@2011/5/28:10:42:12.698 (F) d:\win7sp1_gdr\base\wcp\sil\merged\ntu\ntsystem.cpp(3676): Error STATUS_OBJECT_NAME_NOT_FOUND originated in function Windows::Rtl::SystemImplementation::DirectRegistryProvider::SysOpenKey expression: (null)
[gle=0x80004005]
^^ This one disappeared as quickly as it came. I will investigate this only as required.

Code:
2011-05-21 12:29:29, Info                  CBS    Obtained poqexec from Cbs key. C:\Windows\System32\poqexec.exe /display_progress \SystemRoot\WinSxS\pending.xml
2011-05-21 12:29:29, Info                  CBS    Removed poqexec from Cbs key.
2011-05-21 12:29:29, Info                  CBS    Removed CCP impactful-commit disabling value.
2011-05-21 12:29:29, Info                  CBS    Running poqexec with: C:\Windows\System32\poqexec.exe /noreboot /transaction 182068 /display_progress \SystemRoot\WinSxS\pending.xml
2011-05-21 12:29:29, Info                  CBS    Waiting for poqexec.exe to complete...
2011-05-21 12:29:29, Info                  CBS    Progress: UI message updated. Operation type: Update. Stage: 1 out of 3. Percent progress: 15.
2011-05-21 12:29:34, Info                  CBS    Waiting for poqexec.exe to complete...
2011-05-21 12:29:39, Info                  CBS    Waiting for poqexec.exe to complete...
2011-05-21 12:29:44, Info                  CBS    Waiting for poqexec.exe to complete...
2011-05-21 12:29:45, Info                  CBS    SQM: Reporting poqexec status with status: 0xc0000043, failed file: install.ins, interfering process: , context: Shutdown, first merged sequence: 200
2011-05-21 12:29:45, Info                  CBS    SQM: Upload requested for report: PoqexecStatus, session id: 142861, sample type: Standard
2011-05-21 12:29:45, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-21 12:29:45, Info                  CBS    Failure in poqexec.exe while processing updates. [HRESULT = 0x80070020 - ERROR_SHARING_VIOLATION]
2011-05-21 12:29:45, Info                  CBS    Set the CCP impactful-commit disabling value
2011-05-21 12:29:45, Error                 CBS    Shtd: Failed while processing critical primitive operations queue. [HRESULT = 0x80070020 - ERROR_SHARING_VIOLATION]
2011-05-21 12:29:45, Info                  CBS    Progress: UI message updated. Operation type: Update. Stage: 1 out of 3. Temporary Rollback.
2011-05-21 12:29:45, Info                  CBS    Progress: UI message updated. Operation type: Update. Stage: 1 out of 3. Temporary Rollback.
^^ Please may you create a new logs folder, and this time add

C:\Windows\Winsxs\Pending.xml* (basically, every Pending.xml, if any)
C:\Windows\winsxs\poqexec.log
C:\Windows\winsxs\cleanup.xml


Some of the above may not exist. Just whatever exists, please

Code:
2011-05-13 03:29:34, Error                 CSI    00000012 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #112011# from CCSDirectTransaction::PerformChangeAnalysis(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    00000013@2011/5/13:07:29:34.469 (F) d:\w7rtm\base\wcp\componentstore\csd_winners.cpp(550): Error STATUS_SXS_ASSEMBLY_NOT_FOUND originated in function CCSDirectTransaction::PerformChangeAnalysis expression: m_Analysis->AllCompositionsWereFound()
[gle=0x80004005]
2011-05-13 03:29:34, Error                 CSI    00000014 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #112010# from CCSDirectTransaction::PrepareForCommit(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    00000015 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #112009# from CCSDirectTransaction::ExamineTransaction(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    00000016 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #112008# from CCSDirectTransaction_IRtlTransaction::ExamineTransaction(...)[gle=0xd0150004]
2011-05-13 03:29:34, Info                  CSI    00000017 TLC operation Install (0) incomplete for [Microsoft-Windows-ServerDesktopExperience-Deployment, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]), missing compositions
    Microsoft-Windows-Shell-Accessories, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_IA32_ON_WIN64 (10), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral

2011-05-13 03:29:34, Error                 CSI    00000018 (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #165515# from CCSDirectTransaction::PerformChangeAnalysis(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    00000019@2011/5/13:07:29:34.874 (F) d:\w7rtm\base\wcp\componentstore\csd_winners.cpp(550): Error STATUS_SXS_ASSEMBLY_NOT_FOUND originated in function CCSDirectTransaction::PerformChangeAnalysis expression: m_Analysis->AllCompositionsWereFound()
[gle=0x80004005]
2011-05-13 03:29:34, Error                 CSI    0000001a (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #165514# from CCSDirectTransaction::PrepareForCommit(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    0000001b (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #165513# from CCSDirectTransaction::GenerateComponentChangeList(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    0000001c (F) STATUS_SXS_ASSEMBLY_NOT_FOUND #165512# from Windows::COM::CPendingTransaction::ExtractInformationFromRtlTransaction(...)[gle=0xd0150004]
2011-05-13 03:29:34, Error                 CSI    0000001d (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #108847# from Windows::COM::CPendingTransaction::IStorePendingTransaction_Analyze(...)[gle=0x800736b3]
2011-05-13 03:29:34, Error                 CSI    0000001e (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #104835# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_Commit(Flags = 47 (0x0000002f), pSink = NULL, disp = 0, coldpatching = FALSE)[gle=0x800736b3]
2011-05-13 03:29:34, Error                 CSI    0000001f (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_NOT_FOUND) #104834# 1973324 us from Windows::ServicingAPI::CCSITransaction_ICSITransaction::Commit(flags = 0x0000002f, pSink = NULL, disp = 0)
[gle=0x800736b3]
2011-05-13 03:29:34, Info                  CBS    Setting ExecuteState key to: ExecuteStateNone
2011-05-13 03:29:34, Info                  CBS    Setting RollbackFailed flag to 0
2011-05-13 03:29:34, Info                  CBS    Clearing HangDetect value
2011-05-13 03:29:34, Info                  CBS    Saved last global progress. Current: 0, Limit: 1, ExecuteState: ExecuteStateNone
2011-05-13 03:29:34, Info                  CBS    Exec: Restoring driver operations because of a CSI commit failure.
2011-05-13 03:29:34, Error                 CBS    Exec: Failed to pend CSI transaction because transactions cannot be merged: 0. [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:34, Info                  CSI    00000020@2011/5/13:07:29:34.968 CSI Transaction @0x1e824e0 destroyed
2011-05-13 03:29:34, Info                  CBS    Perf: InstallUninstallChain complete.
2011-05-13 03:29:34, Info                  CBS    Failed to execute execution chain. [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:34, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:34, Info                  CBS    WER: Generating failure report for package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, status: 0x800736b3, failure source: Execute, start state: Installed, target state: Installed, client id: RMT
2011-05-13 03:29:34, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2011-05-13 03:29:34, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
2011-05-13 03:29:34, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
2011-05-13 03:29:35, Info                  CBS    Reboot mark refs: 0
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting selectable update change for package: Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, update: InkSupport, start: Staged, applicable: Installed, target: Installed, client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: UpdateChange_InkSupport_Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142860, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting package change for package: Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, current: Installed, pending: Default, start: Installed, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142859, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting package change completion for package: Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, current: Installed, original: Installed, target: Installed, status: 0x800736b3, failure source: Execute, failure details: "(null)", client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2011-05-13 03:29:35, Info                  CBS    SQM: Failed to initialize Win SAT assessment. [HRESULT = 0x80040154 - Unknown Error]
2011-05-13 03:29:35, Info                  CBS    SQM: average disk throughput datapoint is invalid [HRESULT = 0x80040154 - Unknown Error]
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Microsoft-Windows-TabletPC-Server-InkSupport-Package~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142862, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting selectable update change for package: Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, update: DesktopExperience, start: Staged, applicable: Installed, target: Installed, client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: UpdateChange_DesktopExperience_Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142860, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting package change for package: Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, current: Installed, pending: Default, start: Installed, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142859, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Reporting package change completion for package: Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, current: Installed, original: Installed, target: Installed, status: 0x800736b3, failure source: Execute, failure details: "(null)", client id: RMT, initiated offline: False, execution sequence: 141, first merged sequence: 141
2011-05-13 03:29:35, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2011-05-13 03:29:35, Info                  CBS    SQM: Failed to initialize Win SAT assessment. [HRESULT = 0x80040154 - Unknown Error]
2011-05-13 03:29:35, Info                  CBS    SQM: average disk throughput datapoint is invalid [HRESULT = 0x80040154 - Unknown Error]
2011-05-13 03:29:35, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Microsoft-Windows-ServerDesktopExperience~31bf3856ad364e35~amd64~~6.1.7600.16385, session id: 142862, sample type: Standard
2011-05-13 03:29:35, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
2011-05-13 03:29:35, Info                  CBS    Enabling LKG boot option
2011-05-13 03:29:35, Info                  CBS    Restored system sleep block state: 0x80000000
2011-05-13 03:29:35, Info                  CBS    Exec: Processing complete.  Session: 30150975_2073748683, Package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385 [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:35, Error                 CBS    Failed to perform operation.  [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:35, Info                  CBS    Session: 30150975_2073748683 finalized. Reboot required: no [HRESULT = 0x800736b3 - ERROR_SXS_ASSEMBLY_NOT_FOUND]
2011-05-13 03:29:35, Info                  CBS    Session: 30150975_2188096884 initialized by client RMT.
2011-05-13 03:29:36, Info                  CSI    00000021@2011/5/13:07:29:36.793 CSI Transaction @0x1e82f30 initialized for deployment engine {d16d444c-56d8-11d5-882d-0080c847b195} with flags 00000002 and client id [26]"TI5.30150975_2188096884:1/"
^^ Finally, this is the one which I think needs the most investigation.

I really don't know if this is going to work, but I think that this really is our best bet. I wish to see if I can properly role back this SP1 install.

lol. Back to Flavius again! After all, you only have a selection of me, Flavius, and MowGreen (and soon to be Marsmimar)!

He honestly does know his stuff...

Windows Update - Uninstall from Console Level

Basically, open an Elevated Command Prompt: Elevated Command Prompt

and type in: wusa /uninstall /kb:976932

This method is the best, if you can. It won't take long to tell you that it isn't happy if it isn't happy! (OK, that sentence was pretty lame )

Otherwise, it is big download time I am afraid (sorry) Download Details - Microsoft Download Center - Windows 7 and Windows Server 2008 R2 Service Pack 1 (KB976932)

I am only continuing to tell you this, because I have a time saving trick for later!

wusa /uninstall C:\Temp\windows6.1-KB976932-X64.exe

Lastly, try PKGMGR. Hopefully, we won't get here.

Firstly, use my tool to extract the Service Pack: Windows Update - Extract an Update (I find it SO much more convenient that using the Command Prompt - and I have to extract very many updates each day in order to help everyone) (it isn't actually too helpful for this, but will be good practice, because I have many time saving tools, and you might just need to become acquainted with some of them! Go up a directory from the automatically opened Extracted directory to find the .cab file.)

start /w pkgmgr /m:C:\Temp\windows6.1-KB976932-X64.cab /up /s:C:\Sandbox

The very best of luck,

Richard
My System SpecsSystem Spec
03 Jul 2011   #16
niemiro

Vista Home Premium x86 SP2
 
 

Just forgot one little thing...

If your Windows Update is set to Automatically install, then could you please hide SP1, and if it isn't, can you please NOT attempt SP1 until I can assess the situation. Thanks a lot!

Quote:
P.S. For giggles, I re-ran RegistryBooster 2011 and it found 9 System Related Reg Errors. Out of these, 8 are "System Software Settings" and 1 is "ActiveX, OLE, COM sections". I'm holding off telling it to repair these unless you agree. My thinking is why not let it fix 'em, but I don't want to let it repair these if you're not on board with it Niemiro. Please let me know...
I personally don't really bother with Registry Cleaners, but I can't see it doing too much more harm at this point, since I have now found answers to some of what is going on here.

Richard
My System SpecsSystem Spec
03 Jul 2011   #17
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

Outch... LOL I can pretty much assure you my friend (despite the d@mning evidence in the logs) that SP1 for 2008 R2/Win7 was NEVER attempted as an install on this machine. The initiative to move this Cluster to SP1 was brought up, and after discussion of us making sure that both Cluster Nodes were absolutely, positively on the same Patch Level BEFORE attempting an SP update we then started getting the flakeyness of the PSU dieing. At first, we thought that Windows was flaking out because this Node was over heating (dust and crud in the vents, heatsyncs, fans, etc... With that , we downed it, unplugged it, took it out to the Air Compressor and blew every spec of dust out of it. It came back up, seemed to run fine for over a week and we thought all was finally well. We then went to update it first (all Updates aside from SP1), as the 1st Node in the Cluster, but it BSoDed in the middle of an Update (so my colegue reminded me) but not certain which one. We then toubleshoot further and finially found that the PSU was causing the issue due to low voltages on the + sides. We ordered another PSU, but unfortunatley this System BSoD'ed probably a couple more times before we could down and replace.

At any rate, here's the results of the Commands you suggested;

ATTEMPT #1
wusa /uninstall /kb:976932
======================
Windows Update Standalone Installer

Installer encountered and error: 0x8000ffff

Catastrophic failure
=================================


ATTEMPT #2
wusa /uninstall C:\Temp\windows6.1-KB976932-X64.exe (Made absolutely sure that SP1 was DL'd and saved to this exact name in this exact Path)

================
Windows Update Standalone Installer

Installer encountered an error: 0x8007065e

Data of this type is not supported.
==============================


ATTEMPT #3
(DL'd your tool, excellent by the way!!!, and used it to Extract SP1)

(Confirmed Paths) C:\>start /w pkgmgr /m:C:\Temp\windows6.1-KB976932-X64\Extracted\windows6.1-KB97
6932-X64.cab /up /s:C:\Sandbox

=================
Windows Package Manager

Operation failed with 0x8007000B (isn't this the same error that you sometimes get when WU is broken on machines?)

An attempt was made to load a program with an incorrect format.

======================================


Short of it, SP1 was unfortunately never installed on this Machine as far a I know, but we planned on it in the future. This just points to Windows being really messed up like you stated way earlier I guess... lol At any rate, please don't feel pressured by any of this, as this is first and foremost my problem. Second, the Sever / Cluster Node is totally usable now (thanks to your help earlier with the Pii sign corruption I missed in the Reg). And third, at this point of functionality, this doesn't have to be fixed right away. Like you said, this is a kewl challenge for us both, and what's really kewl is that no one will suffer if it takes us several months to finally figure out. But in the end, we'll ALL benefit from our work on this!


Enjoy the rest of your weekend my friend, and we'll keep pecking away at this! We'll figure it out eventually!
Drew

P.S. Since you didn't mention the 9 RegBoosters Errors that I mentioned earlier I went a head and told it to fix them. At this point, what could it hurt... =)
My System SpecsSystem Spec
03 Jul 2011   #18
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

Oh Poo... lol I think you asked for these Logs... Here they are...

LOL

Thanks,
Drew


Attached Files
File Type: zip 3rd.zip (914.0 KB, 13 views)
My System SpecsSystem Spec
03 Jul 2011   #19
Drewmann69

Windows 7 Ultimate x64, Windows 2008 R2 Enterprise x64
 
 

Quote:
If your Windows Update is set to Automatically install, then could you please hide SP1, and if it isn't, can you please NOT attempt SP1 until I can assess the situation. Thanks a lot!
No problem. WU was set to "Check for updates, but let me choose whether to download and install them..."

I definitely won't attempt any install of SP1 till we're through all of this and truely ready for it.

Thanks,
Drew
My System SpecsSystem Spec
Reply

 CBS Registry Errors




Thread Tools




Similar help and support threads
Thread Forum
fresh install has registry errors
Hi, my name is William. I downloaded windows 7 32 bit from MSDN (since i can get a copy for free from the school I'm in), and then did a clean install. After installing it, I have been getting a few error messages that I can't seem to fix. I keep getting error messages like windows explorer...
General Discussion
Registry Errors-Please help
Hi Forum users: Here is my issue. I use AVG AV and it has a component called PC Analyzer that analyzes my computer. It lists Registry error and can supposedly fix them if needed. Well it found over 200 errors on my latest scan and i've listed just a few here. I am really concerned because of the...
Performance & Maintenance
Can i delete ALL registry ERRORS ?
hello. i saw alot of registry errors when i do a PC analyzer. it listed 300++ registry errors . I wonder if i can delte this registries.
General Discussion
Registry Errors
Good Morning Folks: I recently started running Windows 7 that came preinstalled on a Dell Inspiron 64 bit machine. In general, everything is working quite well so the following problem doesn't appear to be interfering with the operation. However, being a fanatic regarding having all functions...
General Discussion
severe registry errors???
I have been having troubles trying to download and install programs. I keep getting error messages. (i have attached 3). The programs will download but when it comes to the install part, i get the errors. Even when trying to install the Windows updates it sometimes has a problem. I have also had...
System Security
Windows Registry Errors
I used a utility today to clean out/check my my Windows Registry for errors. The utility found over 400 errors but because it was a free trial, it only removed 30, I think. Anyways, on PCWorld's website, I found a download for DBAN (Darik's Boot And Nuke). You burn it to a blank CD and then start...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App