Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: CFGMGR32.dll is missing

01 Sep 2011   #1

windows 7 home premium 64 bit
CFGMGR32.dll is missing

hi, installed 1 update last night and when i came to sart computer today i get this message, i can put my password in but screen goes black, but in the corner it says "this is not a genuine copy of windows". but it is a genuine copy and have the disc right next to me

i cant access safe mode to restore either. only thing i can do is get the task manager to open, but no idea how im suppose to re-install this 1 file to sort my computer out

any help be greatly appreciated


My System SpecsSystem Spec
01 Sep 2011   #2

windows 7 home premium 64 bit

managed to get my windows disc to boot right on th 3rd attemp, trying system restore now for 2 days ago before this last update

ill post back with results
My System SpecsSystem Spec
01 Sep 2011   #3

Windows 7 Home Premium x64 SP1

Hello Twister

If you have the windows installation cd use that to enter the recovery console - System Recovery Options and try this - SFC /SCANNOW Command - System File Checker. That may replace the missing file.

My System SpecsSystem Spec

01 Sep 2011   #4

windows 7 home premium 64 bit

thanks, managed to run system restore from booting windows disc and just seen this now. took 3 attemps to actually load anything from booting from disc though but got ther eventually

just running a full virus scan now, if that picks up nothing then ill have to check what this update was and see if thats the cause of it

ill keep you posted over the next day or 2

My System SpecsSystem Spec

 CFGMGR32.dll is missing

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App