Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Update - CSI Manifest All Zeros, msil_corlib.resources

05 Oct 2011   #1
Charlie7

Windows 7 Ultimate x64
 
 
Windows Update - CSI Manifest All Zeros, msil_corlib.resources

Hi there,

Been having some issues with Windows Update, especially when it comes to trying to install SP1 (64 bit) on my Windows 7 Ultimate x64 machine. I've downloaded the latest (Aug. 2011) System Update Readiness tool, which has shown be that two manifests are corrupted and showing all zeros.

I've tried typical things such as resetting Windows Update, etc. however nothing has fixed it so far. I have a few friends in the house (shared student house) also on Windows 7, so thought about copying the files off their machine and replacing the corrupted ones on mine, however the files were non-existent on their machines.

Here is a copy of the CheckSUR.log file:

Code:
Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 13.0
2011-10-05 16:26

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store
(f)    CSI Manifest All Zeros    0x00000000    winsxs\Manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.20935_en-us_4fdd65da8f1fc992.manifest    msil_mscorlib.resources_b77a5c561934e089_6.1.7600.20935_en-us_4fdd65da8f1fc992    
(f)    CSI Manifest All Zeros    0x00000000    winsxs\Manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.16789_en-us_66afb31075744e72.manifest    msil_mscorlib.resources_b77a5c561934e089_6.1.7600.16789_en-us_66afb31075744e72    

Summary:
Seconds executed: 343
 Found 2 errors
  CSI Manifest All Zeros Total count: 2

Unavailable repair files:
    winsxs\manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.20935_en-us_4fdd65da8f1fc992.manifest
    winsxs\manifests\msil_mscorlib.resources_b77a5c561934e089_6.1.7600.16789_en-us_66afb31075744e72.manifest
Any help would be much appreciated.

Also, upon running sfc /scannow I'm told that it "found corrupt files but was unable to fix", so I checked the CBS.log file and had a look to see what was unable to be fixed:

Code:
2011-10-05 16:07:06, Info                  CSI    000002d9 [SR] Cannot verify component files for mscorlib.Resources, Version = 6.1.7600.16789, pA = PROCESSOR_ARCHITECTURE_MSIL (8), Culture = [l:10{5}]"en-us", VersionScope neutral, PublicKeyToken = {l:8 b:b77a5c561934e089}, Type neutral, TypeName neutral, PublicKey neutral, manifest is damaged (FALSE)
Cheers.


My System SpecsSystem Spec
.
10 Oct 2011   #2
Charlie7

Windows 7 Ultimate x64
 
 

Done a repair install/upgrade which sorted the issue.
My System SpecsSystem Spec
Reply

 Windows Update - CSI Manifest All Zeros, msil_corlib.resources




Thread Tools




Similar help and support threads
Thread Forum
Windows Update Stuck at Checking For Updates - Missing Manifest Files
I have been attempting to install Windows Updates as well as the Windows 10 upgrade over the last few days but each time the Update gets stuck at "Checking for updates". I haven't seen any error codes however it was stuck at this status for 8+ hours today. I have attempted to install updates via...
Windows Updates & Activation
Windows update agent 7.6 taking all of my CPU resources
I installed new clean windows 7 ultimate a few days. Everything was ok. Installed well. Activated well. Getting windows update well. After service pack 1 was installed successfully, a new version of windows update agent 7.6 was installed and then the whole problem started. Every time I start my...
Windows Updates & Activation
CSI Manifest All Zeros - where to find them?
Trying to upgrade XP to 7- issues along the way, but now boots under WIN7, have applied several rounds of updates, including SP1. Have some updates that won't apply, getting BSODs and lock ups. Have run SCF, no issues; Have run diskchk, no issues; Have run memtest, no issues; Have run CheckSUR -...
Windows Updates & Activation
Win7 update errors (CSI Manifest All Zeros)
Hi. I'm getting errors when trying to do a Windows update to service pack 1 (Windows 7). I've run CheckSUR, and it seems to be complaining about: "amd64_microsoft-windows-ieframe_31bf3856ad364e35_8.0.7600.20651_none_dbf7b4b157dae956.manifest" I've attached a zip file with both the...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App