Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Software Installation Fails Because of Missing MSXML4

28 Oct 2011   #1

Win 7 Ult SP1/Win 10 Pro (all x64)
Software Installation Fails Because of Missing MSXML4

The thing is I have installed the latest update to MSXML4 SP3 - in fact WU did it for me, but there is no MSXML4.dll in Windows/System32. 3 and 6 are there OK.

I can't figure out why this is as I haven't done any registry cleaning.

Tried sfc /scannow, it finishes OK but it says some files are corrupted.

This is my spare Windows 7 Ultimate SP1 on Disk 1 partition 1 - in other words the 4th in a row of multi-boots with the boot files residing in Vista on C: (It goes C:, D:, then on the next disk L: and M:

Dare I stick a Win 7 SP1 installation disk in and do an upgrade/repair install? Will that lose me my mutli-boot?

Edit: I checked both my Windows 7 installations on my main PC and the one on my Netbook and neither one carries it. Neither do any of my Vista installations. But they all have the MSXML 4 SDK installed by Windows Update - but that installs into Program Files (x86) not the Systemroot.

Perhaps there is a glitch in the installer as it seems to be thinking everyone has XP, as it has all - MSXML2,3, 4, and 6 DLL's in that exact location.

Ideas anyone?

My System SpecsSystem Spec
30 Oct 2011   #2

Win 7 Ult SP1/Win 10 Pro (all x64)

Solved by formatting that partition and I'll start over when I have the time and the patience.
My System SpecsSystem Spec

 Software Installation Fails Because of Missing MSXML4

Thread Tools

Similar help and support threads
Thread Forum
Installation on a Sony Vaio fails
Hello everyone! My sister asked me to install her newly acquired copy of Windows 7 in her Sony Vaio, I formatted his Vista and then procceeded to install it, but then an error appeared every time on the second step, telling me rollback.exe was creating an application error and it would take me...
Installation & Setup
Missing MSXML4
I have suddenly developed a rash of applications failing to launch due to a "Missing MSXML4" file. A file search verified that it is present in the "Sys/WOW64" folder so I presume that it is somehow corrupted. What is the best way to repair or replace this?
Programs missing, Windows repair fails, and Windows upgrade fails
Hello and thanks for reading. Let me begin by saying I've been trying to figure this problem out for hours and hours now, and every solution I find that looks promising, just leads me in circles. I'm trying my best to avoid a clean install. The problem started while playing a game, causing a...
General Discussion
Windows 7 Clean Installation from USB 3.0 fails
Hi folks, Got Windows 7 Clean Installation over the computer's USB 3.0 port done without too many problems but with some hassle anyhow. For the clean installation I followed the procedure of GreGrocker...
Installation & Setup
installation/upgrade fails
I have a netbook that came with the starter edition. I am trying to install the pro edition over it. The install dies and tells me I cannot install it and I need to select Windows Anytime Upgrade instead. However, that will not accept my license key from my pro edition. Am I stuck with a disk I...
Installation & Setup
Windows 7 installation fails
I have my current OS which is Vista ultimate and decided to upgrade it to windows 7. But first i reformatted my computer with a fresh installation of VIsta ultimate and then installing the drivers. And then i upgrade it to Windows 7. All went right, but then after that when i almost arrived at...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App