Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update service is not working

03 Nov 2011   #21

Windows 7 Home Premium 32bit.

i've no idea what you are talking about :) so propably nobady changed those things.! Cleaning n registry is only done whn i'm using the TuneUp Maintenance. i didn't get any errors ID, just said that it automatically repaired windows update components..

My System SpecsSystem Spec
03 Nov 2011   #22

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Quote   Quote: Originally Posted by Panayiotis View Post
whn i'm using the TuneUp Maintenance.

WHose is that? If it's what I'm thinking of, then it's positvely dangerous.
My System SpecsSystem Spec
03 Nov 2011   #23

Windows 7 Home Premium 32bit.

I've used both FIX IT, but the problem stil remains...TuneUp Utilities is a program i'm using to delete temp files, disable apps on startup... i've been using it long time so i don't think this is what is causing the prob.. Finally i think i have to make a format?
My System SpecsSystem Spec

03 Nov 2011   #24

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

As I thought - if it's the one from, then it is dangerous.
the 1-click tuneup includes a 'Registry Clean' and a 'Registry dfreg' - both of which are dangerous tools if unsupervised.

The older the version in use, the more dangerous it's likely to be - but even the latest is bad enough to kill a system dead, as is the case with all such scareware.

If you're able to, I suggest undoing all registry changes it's made since before the problem surfaced.
My System SpecsSystem Spec
03 Nov 2011   #25

Windows 7 Home Premium 32bit.

oh ok didn't know that...thank you very much for all the files and the effort, i don't think i can undo all the registry changes, i'll try otherwise i'll do a format.!
thanks again
My System SpecsSystem Spec
08 Jan 2012   #26

Windows 7 Ultimate x64
Windows update cannot currently check for updates because the service

My HP G72-250 17" laptop's 15 month old Toshiba 320GB started giving my Windows 7 Home Premium x64 system problems until it finally wouldn't boot. So I bought a new WD500GB on eBay (I like WD drives) and installed it. I then reinstalled Win7 and all programs using the HP recovery disks. Right out of the gate Windows UPDATE would not work. Every time Windows Update is tried the message, "Windows update cannot currently check for updates because the service is not running. You may need to restart your computer"[/B]. After many attempts to recover I did a clean load of Win7 Ultimate. Surprise, same problem. I spent about 3-5 days trying various things including those found on this forum; Windows Update Troubleshooter, SFC, Update Readiness Tool x64, Fix It, Reinstall Win Update Agent (got ec 0x8000ffff) . HERE IS WHAT FINALLY FIXED IT:

Western Digital high density hard drives, such as 1TB or 750GB, may display abnormal error messages if the Intel Rapid Storage Technology Driver (IRRT) is not updated. Try installing the newest IRRT drivers

I installed the SP47845 Intel Rapid Storage Driver v9.5.6.1001 and Win Update WORKED! Hope this helps someone to an easier FIX...
My System SpecsSystem Spec
26 Aug 2012   #27

Windows 7 Home Premium

For future reference for others with the same problem, I had the same problem described here. Mine is a Sony VAIO laptop model VGN-FW560F, running Windws 7 Home Premium 64 bit. "linleHP"'s response solved the problem for me as well. My laptop was working fine until I upgraded the hard disk from a WD Black 500GB drive to a WD Black 750GB drive. (I had previously upgraded from 320GB to 500GB with no issues.) Once I upgraded to 750GB I had issues begin to arise, culminating in an inability to boot on Friday night. I used the Windows 7 repair disk to get it to boot again, swapped in a new drive (same WD Black 750GB) in case that was an issue, but still could not run Windows update. What fixed the problem was downloading & installing the new Intel IRST drivers mentioned in "linleHP"'s note. Installed those and everything is working perfectly again...
My System SpecsSystem Spec
10 Nov 2014   #28

Windows 7 Home Premium 64-bit

I ran into this this Windows 7 update problem after doing a full recovery on my HPE-170t. I thought the recovery install was corrupt on my hard drive, so I ordered a set of Recovery Disks from HP was no longer supporting my desktop. :-( Well, before the disks even came in, I was ran into an error installing .NET v4.0. When I looked up the error code, there was a suggestion on a thread to update the Intel RST driver (IRRT) just like what linleHP did. Low and behold, this fixed my update problem. I wish I had seen linleHP's post earlier; could have saved me some grief, along with $27 I paid for recover disks.

In any case, here's the Intel link

I downloaded version from 2/1/2013. I tried using the latest, but that was asking for .NET v4.5 to be installed, which I couldn't install because of an existing OLD Intel IRRT driver.
My System SpecsSystem Spec

 Windows Update service is not working

Thread Tools

Similar help and support threads
Thread Forum
Windows cannot update no update service
Hello All, i'm working on a pc currently, and have run into a big issue while trying to fix another, and i have just noticed this pc has not been updated since it was purchased. I have tried running windows updates but receive the error message "windows cannot update the service is...
Windows Updates & Activation
Windows 7 Windows Update service not working
Hi I am having a problem with my windows update service. I have recently had a few computer issues and I am trying to work through them to fix up my computer as good as possible without requiring a fresh windows install as I have no wish to purchase a new windows 7 disc, I have come across an...
Windows Updates & Activation
audio service not working, dependency service does not exist...
hi can anyone help? i have a medion akoya laptop running windows 7 64 bit i have no audio. if i click troubleshoot problems it says the audio service is not running it says the windows audio and endpoint builder arent working if i go into services, windows audio is set to automatic but its...
Sound & Audio
Windows Audio Service not working
This is like my third brush with this problem this week. The first two times I just jiggled the volume control knob and that fixed it. This time I got stuck at the Welcome Screen for over 5 minutes while logging in before I did a hard reboot to Safe Mode With Networking. I found a little X on my...
Hardware & Devices
Windows update service not working
Hi, I hope someone can provide me some help. I have recently bought an HP DV-7 pre-loaded with 7x64 Home Premium, and since I have started it up, it has not been able to download a single update. When I start windows update and check for updates, it gives me the error: Windows Update cannot...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App