Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 SP1 does not show in computer properties

03 Nov 2011   #1

win 7 x64
Win 7 SP1 does not show in computer properties

Strange problem. Using win 7 premium x64
SP1 shows a successful install in the update history. Win update shows 'up to date' when checking.
The only anomaly is when I check the properties page of the 'Computer' from the start menu it does not show under the Windows Edition section of the page.

Any ideas?

My System SpecsSystem Spec
03 Nov 2011   #2

Win 7 Ultimate 64-bit. SP1.

* If installed it should indeed be showing via Start > right click Computer > Properties >Viewing Basic Information > Windows Edition.

* Have you checked in Event Viewer?
Type eventvwr in search.
Go to the Windows Logs > Application { then System} > in the left hand column.
Note any error or warning that relates to when you installed SP1.
Please note the event ID, and the source codes and tell us what they are.
My System SpecsSystem Spec
03 Nov 2011   #3
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

type msinfo32 into Start/Search and hit Enter. Then see what it says under "Version" (second line).
My System SpecsSystem Spec

20 Nov 2011   #4

win 7 x64

Thanks for the replies. This is indeed a strange thing.
I checked the event viewer after checking the date of installation for SP1. It was installed on Feb 24th of 2011. The oldest item in event viewer (logs/application/system) was july of 2011 so there's no way to tie them together.

@WHS the version says 6.1.7601 Build 7601

So apparently SP1 IS installed it just doesn't show under the properties of "Computer".

I guess it's not a big deal but it just bugs me. :)
My System SpecsSystem Spec
20 Nov 2011   #5
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

Hmm, it is really hiding. Who knows what happened. Some bit probably went AWOL.
My System SpecsSystem Spec
20 Nov 2011   #6

Windows 7 Ultimate SP1 64-Bit

Have you checked Installed Updates under Uninstall a Program in your Control Panel?

It should show up as Service Pack for Microsoft Windows KB976932.

I'm bemused as to why it doesn't show up in Computer Properties.

I suppose you could try and reinstall it as you may have a damaged/missing registry key, which could explain the problem.
My System SpecsSystem Spec
20 Nov 2011   #7

Microsoft Community Contributor Award Recipient


Just some random thoughts in no particular order.

When you installed SP1 was it from Windows Update? Microsoft Download Center? ISO burned to CD/DVD? Some other way? Since it's a pretty large install it could have damaged some system files. Might not solve anything but it wouldn't hurt to try running a System File Checker scan just for grins.

SFC /SCANNOW Command - System File Checker

Did you follow the suggested install procedures offered by Microsoft?

Learn how to install Windows 7 Service Pack 1 (SP1)

Did you have any issues with your computer just prior to installing SP1? Any hints of virus or other malware that could have taken over your machine? Did you run a full scan for malware using your antimalware product of choice prior to installing? It may not hurt to try Malwarebytes Free as a second on demand scanner.

Malwarebytes : Malwarebytes Anti-Malware PRO removes malware including viruses, spyware, worms and trojans, plus it protects your computer

Have you tried uninstalling then reinstalling after checking for system file corruption, malware, etc? Yes it's a hassle but if there was a glitch or hiccup during the installation process all bets are off as to what might have been messed up.
My System SpecsSystem Spec
20 Nov 2011   #8

Win 7 Ult SP1/Win 10 Pro (all x64)

I've seen this before in XP and Vista as well as 7. Are you absolutely sure is was the system Service Pack 1 you installed and not Office...whatever Service Pack 1? Those 2 are often easily confused.

There is something not quite right here. You said earlier ....

.......the version says 6.1.7601 Build 7601
Assuming that's the second line of msinfo32 - it should read

6.1.7601 Service Pack 1 Build 7601 other words the Service Pack should be spelled out.

I think that perhaps it is corrupted and perhaps you should start over by uninstalling the Service Pack if it's listed in installed updates, reboot, disable your antivirus and any other system protection temporarily and reinstall the standalone version NOT the one from WU. (You could download this to your desktop in advance).

Windows 7 SP1 standalone installer: Click HERE (Note this for the US/Canada, alter the Country at top right if necessary)

If problems occur then there is help available free from Microsoft.

Error messages when you try to install Windows 7 Service Pack 1: Click HERE

How to obtain (Free) Windows 7 Service Pack support: Click HERE

How to Slipstream Windows 7 SP1 to Create a Bootable USB, Installation DVD, or ISO File

Meanwhile if you are in the habit of using any registry cleaners or optimizers stop, because this is typical of what happens when they are utilized.

The previous poster's suggestions are good but there is no need to pay for MBAM Pro, the free version is just fine as long as you always remember to update it before running it. It will actually remind you to do that.

MalwareBytes Free

Besides the Pro version could feasibly clash with your antivirus software.

My System SpecsSystem Spec
20 Nov 2011   #9

win 7 x64

Well it IS service pack 1 KB976932 that was installed.
SFC found no problems
It was installed via Windows Update (if I remember correctly) :)
I run malware bytes about once a week and have been doing so prior to SP1
@marsmimar - R U talking about uninstalling SP1 or Win 7 itself? But the answer to both is no. I might try uninstalling SP1 for a test but it isn't worth uninstalling win7 because it doesn't 'appear' to really be affecting anything.
Is it possible to do a 'dirty' install of SP1 or will it fail when it sees it's already installed?

Again, this really is more a curiousity thing than a real problem. I've worked on windows computers for about 25yrs now and have never failed to fix one. If someone came to me with this "problem" I would probably just tell them not to worry after trying a few things.

Maybe I'll download the service pack and try to re-install and see what happens.

Thanks again
My System SpecsSystem Spec
20 Nov 2011   #10

Win 7 Ult SP1/Win 10 Pro (all x64)

@sl2222 Please see my amended post above...I think you were posting a response as I was editing it.
My System SpecsSystem Spec

 Win 7 SP1 does not show in computer properties

Thread Tools

Similar help and support threads
Thread Forum
Win 7 SP1 is not in my computer properties
Service pack 1 shows a successful install in the update history..But does not show in my computer properties.. The version shows that :- 6.1.7600 Build 7600.. Please help. Thanks!
Windows Updates & Activation
My Computer Properties
When i right click MyComputer Properties the messages diaplays as " The operations has been cancelled due to restrictions effect on this computer.Please contact your system administrator". How to solve this problem?
General Discussion
show wrong size of a file in properties
hi guys.. is there a program or a way to change the size of a file?i mean for example i have a music with 4mb and i want to when anyone watch the propertise of this song , it shows 10mb to him???
General Discussion
Folder Properties General Tab doesn't show Folder 'Size', 'Contains'
Hello Friends, Over the past few days I have noticed that my Folder Properties (Right Click > Properties) doesn't show the 'folder size' or the 'number of files/folders' the folder contains. In the General Tab of the Folder Properties the following is displayed: Size : 0 bytes Size on...
General Discussion
Enabled EIST dosent show in the my Computer properties Win 7 ?
hi folks i have enabled my EIST (Enhanced Intel Speedup Technology) via BIOS but on windows 7 properties it wont show it always show the actuall reading of the processor which 3.0ghz and if i chk my cpu-z reading it shows that its working fine according to EIST so how can i fix this problem, so i...
PC Custom Builds and Overclocking

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App