CScript Error: Can't find script engine "VBScript" -alternate solution

Page 2 of 4 FirstFirst 1234 LastLast

  1. Posts : 2
    win7 ultimate 32
       #11

    I have the same problem. After running the code, here is the result:


    C:\Windows\system32>reg query HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-0
    0AA004A55E8}\InprocServer32

    HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32
    (Default) REG_SZ C:\Program Files\Kaspersky Lab\卡巴斯基安全部队 2011\
    scrchpg.dll
    ThreadingModel REG_SZ Both
    OriginalDll REG_SZ C:\Windows\system32\vbscript.dll


    i tried to create and run the regfix.reg, however, i got the following message:

    Cannot import C:\...\Desktop\regfix.reg: Not all data was successfully written to the registry. Some keys are open by the system or other processes.

    Any suggestion. thanks.
      My Computer


  2. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
    Thread Starter
       #12

    Are you actually running Kaspersky?
    If not, run the Kaspersky cleanup tool Removal tool for Kaspersky Lab products which should correct teh problem.
    If you are running Kaspersky, check its security settings and allow VBScripting.
      My Computer


  3. Posts : 2
    win7 ultimate 32
       #13

    thank for the reply.

    I solved the problem. The default value was changed by the antivirus software. After change it back to VBScript, the problem solved.
      My Computer


  4. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
    Thread Starter
       #14

    That is common - but if the AV software is properly installed, it should forward the request after scanning the script. The fact that it wasn't doing so is what caused your problem and you need to find out why that was happening, rather than blindly switching it off in such a way.
      My Computer


  5. Posts : 22
    Windows 7 Ultimate x32
       #15

    Code:
    >reg query HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA0
    04A55E8}\InprocServer32
    
    HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32
        (Default)    REG_SZ    C:\Windows\system32\vbscript.dll
        ThreadingModel    REG_SZ    Both
    Still shows that can't find script engine "VBScript"..
    Any help would be appreciated.
      My Computer


  6. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
    Thread Starter
       #16

    Please start a new thread of your own and post details there.
      My Computer


  7. Posts : 1
    Vista Business
       #17

    Everyone, I am at a loss! I am having the same errors as Cyroq and cannot to no end figure this out.

    I am the administrator and the system will not allow me to add the file to said directory, I cannot run the script and to make matters worse, I cannot delete the Registry entry as other posts have satated.

    So my question is this! is there any hope out there? someone please guide me through this NIGHTMARE That i cannot seem to get out of. I have lost more time fiddling with this than I care to.

    Thanks in Advance,

    TD


    EDIT: disregard, you will find the answer in this thread. Same Forum! I am sooooooooooooo happy!

    Cant find VBScript engine
    Last edited by Twindad97; 12 Nov 2012 at 17:47. Reason: Found Answer in another thread
      My Computer


  8. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
    Thread Starter
       #18

    Please start a new thread of your own, and post details.
      My Computer


  9. Posts : 1
    Windows 7 x64
       #19

    Unsolved: Windows can not find VBScript when needed by applications.


    Since my post is about Windows 7 not finding VBScript engine, I fail to see the relevance of the "windows genuine" and "Windows update" links on lines two and three of your "Notices" regarding my question. I downloaded and ran the SystemInfo, and it correctly identified my hardware. I just installed a Seagate SSHD that was not fully identified. The program's interface with your web site did not complete the web site's copy of the information for this system, but I see no reason to do that manually since I assume that SystemInfo normally records that information at your site.
    Concerning my problem with VBScript, I have not yet located a solution. Here are some of the steps that have not helped:
    • Run REGSVR32 for VBScript.dll.
    • Check the values for the CLSID {B54F3741-5B07-11cf-A4B0-00AA004A55E8}|Inprocserver.
    • Searched the complete registry to see if there were any obvious problems related to VBScript.
    • Searched the internet using multiple search engines for this problem.
    As I said, none of these actions helped. Furthermore, my searches of the internet convinced me that there are other Windows users out here that also can't do any new processes that require VBScript and are putting up with an error in Windows support for its own VBScript utility. The error first appeared for me when I wanted to try out the Zimbra email client. The Applications event log has reported other miscellaneous errors that probably occur for the same reason. As for me, the problem will not be fixed until I can run the Zimbra email client. The other error events are not as troublesome as that one for me.
    I am not experienced enough on forums like this to know if I am reporting this problem in the proper way, so if I have not done so, I will be grateful if someone will do it properly this time. I can learn by example.
      My Computer


  10. Posts : 21,482
    Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10
    Thread Starter
       #20

    This sticky was put up because one of the commoner errors resulting in a non-genuine status in Windows Vista and windows 7 was the 'Can't find...' one - possibly as a result of certain registry cleaners' inability to understand the new paradigms involved in Vista/7 compared to XP.

    I would be very surprised if you're getting this error without also getting a non-genuine notification, unless you've hacked Windows in some way, as WGA relies on VBS for the bootup license checks.

    Please start a new thread of your own and detail your problems there - a look at your event logs would be useful, as well...


    Open Event Viewer
    click on the Windows logs entry in the left pane to expand it.
    Now click on the Application entry - wait while it loads.
    Click on 'File' in the menu bar and select Save...
    Save the file as Appevt.evtx
    Repeat for the System log
    then zip both, and upload them to your new thread.
      My Computer


 
Page 2 of 4 FirstFirst 1234 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:52.
Find Us