Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Offline "slipstreaming" of SP1; KB976933-LangsCab 0 to 5 extraction

09 Nov 2011   #1

win7 ultimate 64bit sp1
Offline "slipstreaming" of SP1; KB976933-LangsCab 0 to 5 extraction

hi all!
i am new to this forum, i specifically selected to join here for resolving an issue regarding offline slipstreaming of SP!. Though MS doesnot officially provide slipstreaming of SP1, i know we can use RT7lite or DISM to do offline slipstreaming.

My daughter recently bought an ACER laptop which came loaded with minimal LINUX; and the dealer sold a windows 7 original DVD. Unfortunately it is pre-sp1. windows 7.

i thought i will use RT7lite to slipstream SP1 and also add latest post-sp1 updates before loading the Windows. ( i have my desktop running on windows 7 64bit with sp1 updated). RT7lite stops showing that Service pack not integrated properly.

So i thought i will check to see manually if i can slipstream; i understand the procedure from net and this forum; i ran the sp1.exe to obtain the cab files. i extracted all files in the bigger cab (using expand command) in a flat folder. i also expanded the nestedmpp cab; i can see the and .mum files which require modification for offline (not installed).

But the problem comes with to files. file is smaller and extracts quickly and without error. When i try to extract file (using winrar, 7-zip or uniextract) get the error message that blah~blah~blah (each time i get different file name!) file cannot be created. I then thought the sp1 file i downloaded is corrupt so i redownloaded another time (fc gives that both files are bit perfect matching!) and with this again the error comes.

so i decided to look into this exactly which file is failing. Wonder of wonder, testing archive gives no error; When i open another folder and extract the files, it extracts smoothly. To be precise,winrar shows that has 11862 files expanding to 232 mb; after extracting about 8900 files it starts giving errors. NOW if i open another folder and extract the rest of files, it extracts them without error.

if i try to copy the files from the new folderr to the original folder i get a windows error " cannot copy "blah blah file"; The directory or file cannot be created. So i understand it is something to do with the unusally long names ( with ~ characters. if i rename the file as it copies smoothly!

with this background, my questions now:
1) i think probably the issue is do with the unique shortname business as renaming is working;
2) i tried to change the temporary file location but it doesnot help as windows file ultitlity comes into play to copy the file from Rar$temp folder to the lang0folder.
3) i dont know if others ever had this problem and i am surprised ; i used my laptop on xp and my daughters with minixp to extract and failed;
4) as i am using en-us lang pack i am sure i neednot copy other language files as i am slipstreaming for my personal use and i dont require french, finnish or swedish or chinese strings! how i can filter them from the cab while extracting without manually scanning these file names.
5) there is no automatic renaming option to the extractor; even if it does, then the cabfilelist (which windows shall be using to use the cat file) will be all wrong.
6) i believe online updating will work as only en-us files will be extracted and updated;
7) is there a limit on number of files (based on unique short file names?) i thought the number is well beyond 30000 and not the 8892 files!
8) ASIDE: i also find two archives:: integrationcomponents.iso and precompact.iso in the extracted folder; what are they for and what should i do with them

thanks for your patience reading the long post; hope i get some useful answers.


My System SpecsSystem Spec
09 Nov 2011   #2

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

I will start by admitting that I did NOT read all the post.

Please be aware that 'slipstreaming' in both Vista and Win 7 is of very little validaity, since the result is a minimal installation which has no capability for either repair or reinstall.
Its sole validity is to create something that will boot, and *may* assist in troubleshooting an installation.
multiple languages CANNOT be supported in a slipstreamed disk - becuase the design of the disk is such that it will create ONLY an 'image' of the installed and operational parts of the OS.

If you wish to reinstall, then you MUST use legitimate MS disks, or clones thereof.
If you wish to do many other things, you will also have to use a legitimate disk.
My System SpecsSystem Spec

 Offline "slipstreaming" of SP1; KB976933-LangsCab 0 to 5 extraction

Thread Tools

Similar help and support threads
Thread Forum
"sfc /scannow" an offline Win7 on hard disk from booted Win10 ?
Assume a hard disk contains a possibly (partially) corrupted Windows 7. I boot now a ToolsCD or USB flash drive with Windows 10. When I open now a CmdPrompt and enter sfc /scannow /offwindir=C:\Windows /offbootdir=C:\ then I cannot do this since the local, active, running WinOS is...
Performance & Maintenance
Problem with Bootable "Windows Defender Offline" utility error code 0x
Computer Specs: Hp DV6-1355dx Windows 7 64Bit Ultimate Intel Core 2 Duo 2.20Ghz processor 4Gb Ram Hey guys thanks a lot for strolling through, I truly appreciate it and hope with everyones assistance this issue will get resolved. So here's my issue; have I've found that everytime I have...
System Security
Click-to-Run "updates have been applied, you can go offline now"
For the last little while, something called "Click-to-Run" on my computer was continually prompting me to update my version of Office, since I hadn't done so in awhile, and the other day it automatically ran the update for me. (Up until this point I continuously chose the option to remind me...
General Discussion
Outllook 2010 - Can't Change "Work Offline" Status
I just installed Office 2010 and setup Outlook. This is a home PC and not connected to an Exchange server. Under the Send/Receive tab, there is an icon indicating "Work Offline". I sent an e-mail to another G-mail account it WAS received. Outlook test messages work. But, I can NOT send an e-mail to...
Microsoft Office
"Unable to find a volume for file extraction" Error Message
I am trying to install a C++ Redistributable package and am encountering the following error dialog: I am also encountering a similar dialog when I try to install the latest Silverlight plugin for IE9. I'm running...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App