Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Using Windows 7 update fails ~ Help

06 Jan 2012   #21

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Sorry - copying the link must hav broken it - try this one..... on=%0A&DownloadType=Drivers

(and you're right, you need 32-bit drivers - but since Intel updated them last they seem to be in the same package as the 64-bit set anyhow :) )

My System SpecsSystem Spec
06 Jan 2012   #22

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Quote   Quote: Originally Posted by niemiro View Post
Fair enough. I haven't actually got any experience with these logs, only 0x800B0100. Any clues from a CBS.log? For me, without a single exception yet, whenever a 0x800B0100 error does not show up in a CheckSUR.log, CBS.log shows that it comes from the SoftwareDistribution folder, and the reset Fix-It in Aggressive Mode solves the problem. I would be incredibly interested to hear about your experiences with this error in a MGADiag log.

Have a look at the posts in the MS WGA forum here - Windows 7 Genuine Advantage Validation Issues (Windows 7) Forum

There is a common set of errors - and that set is mirrored by the ones affected if you switch the CRYPTSVC off. There are two modes of this file set - one in which all are b0100 errors, and one in which some are b0100 and some are 92003 errors.
When I have got the OP to run the CheckSUR tool, it has come back with no error.
SFC shows no problem either.
From this I infer that the problem lies somewhere in a service, or in the registry - but I haven't been able to either repro, or get my hands physically on an affected machine.

The first four errors in this log simply indicate that the WAT Update hasn't been installed - therefore the system hasn't been through any validation)
My System SpecsSystem Spec
06 Jan 2012   #23

Windows 7 32bit

Here is the report after the install Intel Rapid Storage files.
Still have a few file mismatches, but lots fewer than before. What can I do next?

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-QRHTY-37HHV-28XFV
Windows Product Key Hash: 6hMU9aR12Zt14MPblPbJaaQ7Qpo=
Windows Product ID: 00359-030-0378584-85379
Windows Product ID Type: 5
Windows License Type: Retail
Windows OS version: 6.1.7600.2.00010300.0.0.003
ID: {F6421BC7-4870-43A8-8186-2AF34CE50D1D}(3)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000000
Build lab: 7600.win7_gdr.111025-1503
TTS Error:
Validation Diagnostic:
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\npwatweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watux.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watweb.dll[Hr = 0x80070003]

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{F6421BC7-4870-43A8-8186-2AF34CE50D1D}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7600.2.00010300.0.0.003</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-28XFV</PKey><PID>00359-030-0378584-85379</PID><PIDType>5</PIDType><SID>S-1-5-21-3987594610-1065510729-2979400225</SID><SYSTEM><Manufacturer>Dell Inc.</Manufacturer><Model>Inspiron 1545 </Model></SYSTEM><BIOS><Manufacturer>Dell Inc.</Manufacturer><Version>A14</Version><SMBIOSVersion major="2" minor="4"/><Date>20091207000000.000000+000</Date></BIOS><HWID>8EBB3607018400F8</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>DELL </OEMID><OEMTableID>WN09 </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7600.16385

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, RETAIL channel
Activation ID: 2e7d060d-4714-40f2-9896-1e4f15b612ad
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00170-030-037858-01-1033-7600.0000-3652011
Installation ID: 003040469121297273327733538396062733774891881613498783
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: 28XFV
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 1/6/2012 6:57:56 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: 0x00000000
HealthStatus: 0x0000000000000000
Event Time Stamp: 12:31:2011 20:42
ActiveX: Not Registered - 0x80040154
Admin Service: Not Registered - 0x80040154
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information:
ACPI Table Name OEMID Value OEMTableID Value
SSDT PmRef CpuPm
My System SpecsSystem Spec

06 Jan 2012   #24

Windows 7 32bit

Update...I just tried to run Windows Update and it is running and downloading some, but not all the available files. Error Code 80240016. With the comment Windows is currently installing other updates.
My System SpecsSystem Spec
07 Jan 2012   #25

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

Great - that's good news!
It looks like everything is fixed now - all you need to do is validate the machine to get rid of the last error messages by installing the WAT update.
Go to and follow the instructions - you'll be offered MSE and IE9 when it passes, but you don't need to take them.
My System SpecsSystem Spec
07 Jan 2012   #26

Windows 7 32bit

Final report...NonelDP you have been more than helpful...Thanks..on a scale of 1 -10. You get a 10...MS support 0.5. MS was not helpful at all...and I am still waiting to here from MS...there REALLY slow...and their advice NOT so good.

Anyway the Validate went fine, it worked as needed. Downloads from MS with Windows update are now working as needed. Home networking is working.

Thanks a bunch!
My System SpecsSystem Spec
07 Jan 2012   #27

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

You're welcome - that fix has something like a 20% success rate, so ......

Good Luck!
My System SpecsSystem Spec

 Using Windows 7 update fails ~ Help

Thread Tools

Similar help and support threads
Thread Forum
Windows Update fails in Update Check. Error code C80003FA.
Hello, I recieve error C80003FA whenever I do a Windows Update run. It doesn't get past the stage of checking for updates. I've tried several fixes including: - Waiting 15 minutes and running Windows Update again. - Letting Windows Update run on its own schedule. - SFC /Scannow -...
Windows Updates & Activation
Windows Update fails to update, error code 800F081F
My Windows Update has been failing to update for a while now and I can't seem to find the solution. Here's the run-down of what happens step by step: Launch an update scan for Windows Update It scans for a few seconds then says: Once I click Install it begins to "Install and Update," but then...
Windows Updates & Activation
update fails, SP1 install fails, troubleshooter fails
I'm simply attempting to run update on my Windows 7 machine. Update will not run, downloading and running the SP1 update fails, downloading and running the Update Readiness Tool fails, trying to launch a troubleshooter fails. I ran sfc and have attached the log along with all the error codes...
Windows Updates & Activation
Windows update: fails
Hey all, I use a acer aspire 7750G windows 7 home premium 64 bit intel core i7 2630QM AMD radeon HD 6650M 1Gb A week ago I had to install 8 updates, so I did ofcourse. After the installation and the reboot the system told me to install 8 updates :shock: I tried many times to install...
Windows Updates & Activation
Windows 7 Update fails to update when running updates
After installing Windows 7 Home Premium Upgrade on a new seagate 320 g hdd on a Toshiba L300 Laptop with 32 bit that had Vista with latest SP on a 120gb hdd.then installing the sp1, the windows updater will not download and install updates. As it was I had to manually download the sp1 to a flash...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:44.
Twitter Facebook Google+