Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to update to SP1 on Win7 64bit Pro

20 Jan 2012   #1

Windows 7 64bit Pro
Unable to update to SP1 on Win7 64bit Pro

Last year or so I had an issue with KB2446709. My computer was one of those that ended up in the endless reboot loop, after uninstalling the KB I was back up and running but have since been unable to update Windows.

I have spent the better part of the last 3 days finally trying to fix this. I have gotten the error nailed down to one last file that for some reason is not included in the KB2446709 stand alone installer. I have grabbed that file already and expanded it, moving all files within listed in my Checksur.log file and have whittled them down to a single error. It's this last error I can not seem to get rid of as one file was missing from that package.

The file in question is Package_for_KB2446709~31bf3856ad364e35~amd64~~ and

I was able to manually install all other security updates that have been waiting for the last year, this is the last one to get finished.

An in place install or upgrade is not an option.

Am currently at work, but am willing to post logs when I get home.

System is a homebrew, no new hardware installed prior to errors, error began showing after failed KB2446709 install and subsequent removal.

Have already tried the System Update Readiness tool, always completes but does nothing. As I said when I started this there were 4 errors listed in the Checksur.log and I have gotten it down to this last one.

Any help is greatly appreciated.

My System SpecsSystem Spec
20 Jan 2012   #2
Microsoft MVP

Windows 7 Ultimate 32bit SP1

My System SpecsSystem Spec
20 Jan 2012   #3

Windows 7 64bit Pro

I had not seen that particular article, but several others similar. Like I mentioned in my post using that method, I lowered the number of problems from 4 or 5 down to 1, all the same KB number, just the package didn't contain the last entry that is showing in my Checksur.log file.

Was actually hoping someone had those particular files.

Thank you for the reply.


These two files are not included in Windows6.1-KB2446709-x64.msu from
My System SpecsSystem Spec

22 Jan 2012   #4

Windows 7 64bit Pro

Issue is fixed, since this KB pertains specifically to .NET 3.1 I treated it like any other failed uninstalled program and removed it's entries from the registry.

It took me less than 20 minutes to write an app in C# to do it. It would seem to me that if I can do it, MS should be able to fix these, and without doing a reinstall or in-place install.

Thank you for all the help. Happy computing.
My System SpecsSystem Spec
24 Jan 2012   #5

Win 7 x64 Ultimate

I'm trying to find out if your problem is the same problem I'm having. Were you unable to install SP1, it failing maybe 60-70% into the install regardless of whether you did it manually or through windows updates? If not then sorry to muddle your thread, if so then could you please share your C# app because not having SP1 is making me unable to install certain programs.
My System SpecsSystem Spec
24 Jan 2012   #6

Windows 7 64bit Pro

No problems, yes I was having errors trying to install both regular updates and also SP1. I was able to manually install the updates, and eventually I was able to install SP1 without doing an in place install. My system is now running my original install with SP1. I am still unable to update to IE9, but as I'm a Firefox user this isn't a really big issue for me.

Download and run the Windows Update Readiness Tool Download: System Update Readiness Tool for Windows 7 for x64-based Systems (KB947821) [August 2011] - Microsoft Download Center - Download Details

As for my app, I am not releasing it as it was specifically written to solve my problem, and unless yours is identical it would not do you any good.

Once you run the readiness update tool look in %WINDIR%\Logs\CBS\Checksur.log

There should be listing there what will help you identify why your update is failing. Also have a look in the Event Logs.

Click Start in the search field type eventvwr.msc Click the Event Viewer link under Programs that pops up. In the left hand window of Event Viewer expand the Windows Logs and select System. Here you should find direct error codes for the update failures. These will also help you identify your issues.

For instance one of my errors in the event log from failed updates was
Installation Failure: Windows failed to install the following update with error 0x80070643: Windows 7 Service Pack 1 for x64-based Systems (KB976932).
I'd be more than willing to help in any way I can to recover your system.
My System SpecsSystem Spec
24 Jan 2012   #7

Win 7 x64 Ultimate

Ok, thank you for the information.

My CheckSUR log:

Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 13.0 2012-01-19 21:10
Checking Windows Servicing Packages
Checking Package Manifests and Catalogs
Checking Package Watchlist
Checking Component Watchlist
Checking Packages
Checking Component Store
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.21747_none_acdc7a2fd087986e.manifest amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.21747_none_acdc7a2fd087986e
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_c180eb382346c80f.manifest x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_c180eb382346c80f
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_1d9f86bbdba43945.manifest amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.17632_none_1d9f86bbdba43945
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.21747_none_de05c1b3714cccd3.manifest amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.21747_none_de05c1b3714cccd3
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.21747_none_cf64bd82be6eec44.manifest amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.21747_none_cf64bd82be6eec44
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.17632_none_dd81f362582b9265.manifest amd64_microsoft-windows-m..drivermanager-trace_31bf3856ad364e35_6.1.7601.17632_none_dd81f362582b9265
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.17632_none_ac58abdeb7665e00.manifest amd64_microsoft-windows-m..cursor-library-ansi_31bf3856ad364e35_6.1.7601.17632_none_ac58abdeb7665e00
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_c204b9893c68027d.manifest x86_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_c204b9893c68027d
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_1e23550cf4c573b3.manifest amd64_microsoft-windows-m..simple-provider-dll_31bf3856ad364e35_6.1.7601.21747_none_1e23550cf4c573b3
(f) CSI Manifest All Zeros 0x00000000 winsxs\Manifests\amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.17632_none_cee0ef31a54db1d6.manifest amd64_microsoft-windows-m..sor-library-unicode_31bf3856ad364e35_6.1.7601.17632_none_cee0ef31a54db1d6

Seconds executed: 324
Found 10 errors
CSI Manifest All Zeros Total count: 10

Unavailable repair files:

My event viewer shows:
Installation Failure: Windows failed to install the following update with error 0x80070643: Windows 7 Service Pack 1 for x64-based Systems (KB976932).

Installation Failure: Windows failed to install the following update with error 0x80073712: Windows 7 Service Pack 1 for x64-based Systems (KB976932).

Service Pack installation failed with error code 0x80073712. (this was attempting manual install)

Please let me know if you need any other information, I will provide it ASAP.
My System SpecsSystem Spec
25 Jan 2012   #8

Windows 7 64bit Pro

Hello, a quick google of your errors indicates there is corruption in your Component Store. Several posts indicate to try the System Update Readiness tool to fix these, but most who have tried it have had little luck. You can try running a few disk utilities to see if that cures your issue. Have a look at the second reply in this thread. How to fix - error code 80073712 - windows component store is corrupt - Microsoft Answers

Also from your event log the first error indicates there is a problem with the .NET framework. You can try to uninstall the framework, upon uninstall shutdown the machine, DO NOT REBOOT, a reboot will not clear the memory, wait a minute or two then restart the machine and download and reinstall the .NET framework. That should rid you of that first error.

See this page for details on that error. Windows Update error 80070643

More information on error 80073712 can be found here. Windows Update error 80073712

Let's first try to uninstall, and reinstall .NET and go from there. I am currently at work but will keep poking around for more information about recovering the component store.
My System SpecsSystem Spec
25 Jan 2012   #9

Win 7 x64 Ultimate

So, I ran the tool that uninstalls .Net framework after turning the feature off. Shut down completely, upon reboot I try to install the .Net Framework ver 3.5 and it tells me "You must use 'Turn Windows features on or off' so I'm guessing it didn't get completely taken off. I'm not really sure how to proceed from here.
My System SpecsSystem Spec
25 Jan 2012   #10

Windows 7 64bit Pro

Windows 7 has .NET 3.5 built in by default. Try installing .NET 4, you should be able to turn 3.5 back on from Control Panel | Programs and Features | in the left hand window select Turn Windows Features On or Off, look for .NET 3.5 and just turn it back on. Then try to manually update .NET to version 4.

Use this version of .NET

It's the offline installer. When you install it, either unplug your network adapters or disconnect them under Windows. This will force Windows to use the files inside the installer.
My System SpecsSystem Spec

 Unable to update to SP1 on Win7 64bit Pro

Thread Tools

Similar help and support threads
Thread Forum
Update from Win7 32bit to Win10 64bit possible?
Hi all, I currently have a laptop with Win7 Professional 32bit, I read that it's possible to update it to Win10 without having to format the hard drive, is that correct? And will it be possible to upgrade to a Win10 64bit version as well? Kind regards
Installation & Setup
Win 7 Home Premium 64bit Unable to run windows update SP1
AS I said in the title, I am having problems installing windows updates. I have reformatted 3 times and get the same errors at the same spot. I ran SURT and then tried to update, but it still didn't work. Here are the files I believe you need to help me. Thank you.
Windows Updates & Activation
Unable to update Windows 7 Ultimate 64bit Service Pack 1
I am not talking about updating to Service Pack 1. I had a thread similar to this earlier in the week, but I started a new thread as I have more information. (I had to replace my SSD, that's why I needed to install Windows again (I did NOT activate Windows with old SSD)) I don't know if this...
Windows Updates & Activation
Multiple Update Failures / Win7 x64 - Unable to Update, Error 800b010
My problems are essentially those expressed in many previous posts, but specifically this one here was most pertinent (aside from the specific updates of course): Here is a list of the updates...
Windows Updates & Activation
Unable to connect the printer (hosted on the XP) from the Win7 64bit
Hi all, I'm running the win7 64bit, the printer is connected to the XP. That printer is not a network printer (Hp 5740,and 5520) , and shared from a Desktop running WinXP 32 bit. I cannot install it via network access ? can anyone have any idea about that problem. Pleave give me any advise....
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App