Can't see updates in Windows Update.

Page 3 of 4 FirstFirst 1234 LastLast

  1. Posts : 22
    Windows 7 Professional (32bit)
       #21

    I still have this issue and all posts here didn't help. Time settings are fine. Windows Update works, I just cannot see the optional updates in the list. So I am not sure if you really had the same problem, Firedawg. All my Antivirus etc. is able to update. I have no functional problem, I just cannot see the updates. So for me there is still no solution...
      My Computer


  2. Posts : 748
    Windows 7 Professional x64 PL
       #22

    If you use any extra language pack (through Vistalizator) then please restore original language

    Another possible reasons:

    -uninstall all 3p security software
    -reset router to factory defaults
    -it would be also caused by any virus...
      My Computer


  3. Posts : 22
    Windows 7 Professional (32bit)
       #23

    I don't have extra language packs and I don't have Vistalizator. The only security software I use is MS Security Essentials (prior I used AVG free, same problem there). The route cannot cause the problem - I have a laptop which I use in several networks (home, office...), the problem occurs everywhere. No viruses found...
      My Computer


  4. Posts : 3
    Windows 7 Ultimate 64 bit
       #24

    Flavius said:
    If you use any extra language pack (through Vistalizator) then please restore original language

    Another possible reasons:

    -uninstall all 3p security software
    -reset router to factory defaults
    -it would be also caused by any virus...
    Hello Flavius,

    I have Windows 7 premium 64 bit from Dell.

    I also cannot see my update history, and windows update tells me that I have never updated even though it has.

    I have installed English from a original Hebrew Windows with Vistalizator. I want to try your advice as this may be the problem. What is the best way to go back to the original Hebrew language without loosing my programs and files?

    UPDATE:
    Ok, so after changing back to Hebrew that did not fix the problem, I still cannot see my update history. I can see that updates were installed when I go to 'installed updates', but not able to view update history to see the detail of the update.
    Last edited by jerde; 27 Mar 2010 at 12:59. Reason: Update message
      My Computer


  5. Posts : 748
    Windows 7 Professional x64 PL
       #25

    @Spoke and @Jerde

    Do you use any proxy server?If yes please dispose this proxy server.

    You can also try reset WU components in aggressive mode How do I reset Windows Update components?
      My Computer


  6. Posts : 22
    Windows 7 Professional (32bit)
       #26

    No proxy here, just a standard win7 on a Thinkpad laptop, DSL Internet via Router, no extras. I point out again, that the problem is gone after a win restart but comes back after a while (don't know the trigger...). However I had the problem from the beginning of my win7 installation. I will have a look at the WU reset think, thank you!

    UPDATE: Uhm, this tool you linked above is NOT for Win7!
      My Computer


  7. Posts : 22
    Windows 7 Professional (32bit)
       #27

    In another forum I found this: One should enter "regsvr32 jscript" and/or (?) "regsvr32 vbscript" in a command window. That is supposed to fix the problem. Since I have no idea what these commands do I did not try yet. Can anyone here tell me what this means? I think it registers jscript.dll or vscript.dll. And what does this mean?
      My Computer


  8. Posts : 3
    Windows 7 Ultimate 64 bit
       #28

    Ok, looks like it is working now. This is a new computer so perhaps the first updates that were installed simply didn't register. I went ahead and installed a Spanish language pack to test to see if it would show up in Update history, and it did. I just hope this sticks and I don't get the same problems that Spock is having. Good luck.
      My Computer


  9. Posts : 22
    Windows 7 Professional (32bit)
       #29

    @jerde: What did you do? Did you fix the problem? It sounds like you did a fresh install, so no real fix?
      My Computer


  10. Posts : 3
    Windows 7 Ultimate 64 bit
       #30

    @ Spock: I don't know whether I had a problem to begin with, because this is a new computer. The first time I booted up the computer I went to check for updates. I then installed the updates it gave me and then I tried to go to update history to see the details of what was installed. I could not find the updates in update history, so I thought this was odd. I could see them when viewing 'installed updates', but Windows update did not register me as downloading any updates in the update history.

    I went ahead and updated the OS to Ultimate and then checked for updates again. It then showed me that I had 33 optional updates (the language packs). So, I installed one of the language packs to see if it would show up in update history, and it did. Since then I have installed one important update and that is also showing in update history. So it seems as though the problem is solved, which is probably due to my updating the OS to Ultimate.
      My Computer


 
Page 3 of 4 FirstFirst 1234 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:14.
Find Us