Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WinUpdate made Admin act as no admin privileges available?

17 Feb 2012   #1
Lone Wolf

Windows 7 Ultimate (32-bit)
WinUpdate made Admin act as no admin privileges available?

So, for the second time this month, a Windows Update has basically killed my machine.

As I was going to bed at 0230GMT, WindowsUpdate started an auto-install and rebooted my machine.
As I logged into the Admin-level account normally, it appears to stop loading any of my programs - firewall, AV, email, everything.
Volume appears, and that's it.

I click my browser icon on the jump bar, and it popsup an alert box that says :

"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."

I get this on everything : command prompt window, Games on non-boot drive, Windows utilities/programs themselves.

Funnily enough, although "Run as Admin" on my browsers doesn't work, using the "Run Safer" option through my OnlineArmor firewall/program guard does allow a browser to run. But not anything else. And not as with Admin Privileges.

Bloody annoying!
I can't uninstall anything.
"Last Known Good Configuration" and "Safe Mode" does nothing for this problem. There's no way to access "System Restore", so even if there is a restore point (which there should be - I made one after reinstalling at beginning of the month, the last time this happened), I can't use it.

The "Shut Down" button on the Start Menu constantly tells me to click it for the update process again....5 times or so, and it's still there.

I can access My Computer through Start Menu, and move files around.
What in blazes is happening? And why twice after a Windows Update that I cannot defer or block?

P4 3.06GHz
2GB Dual-Channel PC-133 RAM
ATI HD 3450 512 MB GPU

Win7 Ultimate 32-bit
EmsiSoft's OnlineArmor2 firewall
Avast! Anti-Virus.

My System SpecsSystem Spec
17 Feb 2012   #2
Lone Wolf

Windows 7 Ultimate (32-bit)

Addendum :

Managed to create a new Admin-level user.
No go. Same problem. Will not run anything - not enough permissions?!
My System SpecsSystem Spec
17 Feb 2012   #3

Microsoft Windows 8.1 Pro 64-bit

Hello Lone Wolf,

As this isn't a known or reported problem with windows, it is safe to assume that there is a program(s) or setting(s) on your computer that has caused this problem. I have never tried "EmsiSoft's OnlineArmor2 firewall" before, so I cannot tell you how it is, or if it is even worth it. I would think the built in and thouroughly tested microsoft firewall would be all you would need, and I would be careful when using anything else.

Before we get started, attempt a system restore in to a time before these errors began.

Avast! has proven itself to be a pretty poor quality antivirus. I highly recommend using another, as problems can arise with Avast! that effect your computer quality and usage. You can try MSE: It is quite good, and free. If you are looking for another AV or other security software, have a look at this thread (it is long, so the more you read, the bigger your understanding will be as more opinions come into play): What's the Best Anti-virus?

Before you uninstall ANYTHING, use Revo Uninstaller Free (advanced mode) to remove it, in order to remove all of the traces: Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems - Make sure you create a restore point before hand just for safety reasons!

If you've ever changed or modified any services from their original state, change them back. You might consider (if you can) creating another Administrator account and using that one, just in case you encouter more problems with the current one. It is recommended that administrator accounts not be used for problems such as this that might occur, as limited users have more trouble with tearing down the computer system than an andministrator. Viruses can have a big role in this, and because they are a risk, once more a standard user account is recommended for every day use.

Try this tutorial out: Repair Install (by Brink)
Might as well do this one as well: SFC /SCANNOW : Run in Command Prompt at Boot (by Bare Foot Kid)

Do you have other "security" programs that might be interfering with each other or your system? You only should ever have a single antivirus installed at any one time.

If you are still having trouble, and you've managed to create another admin account, you might consider just using that one instead, and be very careful with any program you install to your computer. I still highly recommend only using an admin account for installations and updates, etc. If you cannot create another admin account, perhaps the last resort would be a complete reinstall. However, let us view the permissions problem at this point in time.

Remember! For everything in the above posts that you cannot complete at this moment in time, wait until you are able to later on. DON'T FORGET IT! Other people will give suggestions and attempt to fix your permissions problem, so try not to give up just yet. But try to complete everything I've given you.
My System SpecsSystem Spec

17 Feb 2012   #4

Microsoft Windows 8.1 Pro 64-bit

As you posted before I could, skip over anything that I mention about creating a new admin account, as it obviously isn't working. You might try to see if permissions are different in the new admin account that would allow you to complete a step that you otherwise couldn't.

Now let us focus for the time on the permissions problem:

Follow this tutorial to give yourself permissions to specific things that you need right now: Permissions - Allow or Deny Users and Groups (by Brink). Remember to read everything the tutorial says in the tip/warning boxes, etc, including creating a new restore point (Make sure you have attempted to use system restore already as I've mentioned in the previous post)!

More will come later, be patient; I type slow. Try not to get ahead of yourself, and ask lots of questions

Right click you OS's main HDD and select "Properties". Click the "Security" tab and under "Group or user names:", select "Administrators (...)". Tell me what the permissions for administrators are (modify, etc.) Don't do anything else for right now, more to come later.

Also, the more programs you remove, the higher the chance this can be solved. While it may not be prudent to begin the mass exodus off all of your programs off of your computer, if there are any that you do not need or want, now (if you can) is the time to remove them. I would recommend ditching the extra firewall as well, but up to you. Disable security programs (Or remove if you are so inclined) just so we can ensure they are not the cause. As I said, MSE would be a better choice here, and it is even made by microsoft (think compatibility). You may not have permissions yet to install it. At this point in time (if applicable), try not to browse too much on the internet (such as google) without an antivirus. May be dangerous.

Let me know how all of this is going. If you do not want to do any of the steps above, don't feel pressured, but do let me know. I cannot read minds. This way I can know what you have and haven't tried.
My System SpecsSystem Spec
17 Feb 2012   #5

Microsoft Windows 8.1 Pro 64-bit

Keep in mind, despite your old security software, your computer may still have a virus. Here is some info from microsoft on the matter, and some links to security downloads: How do I remove a computer virus?

Is your computer up to date, completely? Updates are necessary, believe it or not. Have you ever done any customizing of windows, such as downloads that modify the way windows works? Please remove any of these.

After you remove as many programs as you are willing to part with as possible, try creating a new admin acount' to see if it has the same problem.

Try this out:
Type "CMD" without quotes into the start search, RIGHT-click it, click "run as administrator"
Type "TAKEOWN /A /F C:" without quotes and hit 'enter'. Now type "TAKEOWN /F C:" and enter again.

You might consider temporarily turning off indexing, as it has been reported that this can help, though I am not sure myself.

Now go into your HDD permissions again - Right click your OS's main HDD and select "Properties". Click the "Security" tab and under "Group or user names:", select "Administrators (...)". Tell me what the permissions for administrators are (modify, etc.). Have they changed, or stayed the same? Can you follow the tutorial to give yourself permissions on this HDD: Permissions - Allow or Deny Users and Groups (by Brink)?

Failing all of this, we can get into enabling the built in admin account: Built-in Administrator Account - Enable or Disable (by Brink).
My System SpecsSystem Spec
17 Feb 2012   #6

Microsoft Windows 8.1 Pro 64-bit

You done yet? lol
My System SpecsSystem Spec
17 Feb 2012   #7
Lone Wolf

Windows 7 Ultimate (32-bit)

As stated : Cannot access System restore. At all.

I've been using Avast! for years, with no problems. Little to no false positives, light on system resources, reasonable scan time, and hasn't missed anything yet. I have on occasion used AVG, and Comodo Suite.
OA firewall - well, I have had a minor issue or two with it in the past, (incompatible with old games), but nothing like this problem, however, I am willing to consider this, and/or, Avast! may be the problem. It's main use, for me, is the program guard, as the Windows UAC/DEP is rather anal-retentive and very annoying to use. But this is the second time, inside a month, that this has happened directly after an automatic Windows Update...

Revo Uninstaller : Cannot use any program. At all. If it can't use Admin-level it errors, as stated in my original post.
I cannot use windows uninstaller, even though this is an Admin-level account. Ditto a brand new account I created an hour ago - it too is Admin-level privileges, but still errors as though it's a normal user account.

Other Security : I use Malwarebyte's Anti-Malware utility, and CCleaner on occasion, but neither are TSRs, and are/were not loaded for this issue.

W7 Install Disc Repair : Cannot run as Admin, even in this Admin-level account. Only gives option to Install.

Other Admin Account : done and done. No effect. Still screwed up with not running anything.

I'm going to try to do that Barefoot Kid's Command Line repair at boot thingy, but I'm guessing I'm going to have to do a full reinstall of XP, then W7 again.
My System SpecsSystem Spec
17 Feb 2012   #8
Lone Wolf

Windows 7 Ultimate (32-bit)

Right-Click : Run as Admin == Errors out completely. On everything. Will not accept my Admin credentials for anything. I can use the Right-Click menu "Run Safer" option from the OA firewall/program guard - but that's at reduced privileges, and increased system security - it won't do anything other than basic.
My System SpecsSystem Spec
17 Feb 2012   #9
Lone Wolf

Windows 7 Ultimate (32-bit)

Virus : I did a full scan (Deep scan on archives/programs) with Avast! on Tuesday. I also run daily Quick Scans (System areas and downloads) and all were clean. I don't visit warez and cracks sites. I don't do porn. I have Adblocker script for the browser. I also use an IP-blocking program (PeerBlock2) that blacklists a lot of ad-serving/known-malware/P2P sites, etc.
Heck, I normally run 4 tabs for the normal sites I use all day. Occasionally extra for google/Wiki, and news. I don't click strange links, and I check for disguised URLs on those I do... (Yes, I'm tech savvy! and this is frustrating as it can get for me).

Paranoid? Maybe, But I'm fairly confident this is not a virus problem. :P
My System SpecsSystem Spec
17 Feb 2012   #10
Lone Wolf

Windows 7 Ultimate (32-bit)


Computer > Right-Click C:\ drive > Properties

Security Tab > Taking Ownership.

Owner is listed as "TrustedInstaller" - not my Account name.

Editing the Permissions to show the Account name, but Avast files, and some System32 files "access denied".

This could well be the firewall? But I haven't installed anything for over a week, and that was a game, IIRC. An OLD game.
My System SpecsSystem Spec

 WinUpdate made Admin act as no admin privileges available?

Thread Tools

Similar help and support threads
Thread Forum
Log-in with Admin privileges for COD?
So its a lazy afternoon and I decide to install COD (the first one). No issues during the install. However when I start the game I get this message: Weird. I am the admin for this PC. Uninstall and reinstall with 'run as administrator'. Start the game but get the same error message... ...
My Admin user name is corrupted so now PC has NO admin privileges
I created an administrator account for MSConway and changed my original account (pmconway) to user. Now when I log in to MSConway I get "The user name or password is corrupted." At the cmd line I entered "net users" and saw that my Admin account is mistakenly named "Ms. Conway". Also, when I use...
General Discussion
No Admin Privileges as Admin
So: I've had a recurring issue with Windows 7 that has only come to the forefront once again due to a need to upgrade Flash and finding I cannot delete a core file or do a fresh install of flash because it cannot write over said file. So. Let's get to business with the heart of the problem. I'm...
General Discussion
admin privileges
hi im trying to copy and paste a file but when i try and paste it i get the you need admin privileges but i am the admin, i have turned off the UAC and ive done the take ownership thing, in fact i think i downloaded something so ive always got the take ownership option in the folder options but it...
General Discussion
Admin acount no longer has admin privileges?
Hi. The main (and only account) I have been using since the first beta came out had administrator privileges. Today when I booted up I noticed that my account could no longer do things that are associated with an admin account, such as installing certain programs and writing to certain...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:07.
Twitter Facebook Google+